Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

AMD PSP 3.0 Device - Windows cannot initialize the device driver for this hardware.

Hi guys,

I'm in enough of a bind right now to sign up for a forum! That, like, never happens!

At any rate, here's my issue: the AMD PSP 3.0 Device driver (which I admit I have a very very very very very limited understanding of through my Google-fu) is not being picked up by Windows, making me unable to boot into Windows using normal means (I'm typing this in safe mode). My attempt to uninstall it merely turned it into some vaguely-named driver, and disabling it does nothing helpful as well. I tried updating and manually installing the driver but Windows reports back that it's the most recent version.

This issue initially started after I downloaded and installed my mobo's chipset: Support For B350 PC MATE | Motherboard - The world leader in motherboard design | MSI Global . After trying to uninstall the PSP 3.0 driver, I tried to reinstall the chipset, but it gave me an error about not having the drivers signed. I looked all over the web - I can't be the only one having this issue, right?


Mobo: MSI B350 PC MATE

CPU: AMD Ryzen 2600X

RAM: Corsair Vengance 16 GB DDR4 3000Mhz



OS: Windows 7 SP1 64-bit

Driver: AMD PSP 3.0 Device

2 Replies
Journeyman III

     "I'm in enough of a bind right now to sign up for a forum! That, like, never happens!"

same here

Just left your situation & know your pain as I myself made my 7-64-bit install work so why so hard of an install?

Well, turns out they dropped Windows 7 64-bit support so everyone else followed along, making it trivial however here's some tips (by now guessing you've solved this?):

-Use Linux or a newer version of Windows to determine your chip(s)

-Usually other mobo vendors use similar chipsets, check their driver lineup & extract key files to see if it works for W764 install (uh I got lucky; Gigabyte had mine, but well hidden).

-Check your BIOS settings. See if MSI have an update for the BIOS or perhaps your board has a bug.

-Reinstall Win7, starting with your mobo BIOS and drivers 1st, ending with your FRUs (Field Replaceable Units [vidcards, ssd, etc] ) and USB Peripherals last.

Hope it helps



for me, Ryzen 2600 and MSI B450M Gaming Plus same situation as user howdoicomputer. For me helped this. I made new install of Windows 7 Professional SP1 64bit, first I install all updates from Windows Update, it installed AMD PSP 3.0 Device driver. After that I had in my device manager AMD PSP 3.0 Device with error - no driver present or something like this. After install AMD Chipset Driver version 17.40.2815.1010 from site:

Support For B450M GAMING PLUS | Motherboard - The world leader in motherboard design | MSI Global 

and reboot system I had working AMD PSP 3.0 Device in device manager with no error.

Ryzen works great in Windows 7 Professional SP1 64bit.

For unsupported hardware message with no incoming updates from Windows Update I used wufuc software from github:

GitHub - zeffy/wufuc: Disables the "Unsupported Hardware" message in Windows Update, and allows you ... 

Hope it helps

Windows 7 forever!