cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

dec35
Adept I

Amd Graphics settings makes the wrong decisions

Hi, I recently bought a Dell G5 SE (or as some like to call it Dell G5 5505) which has a Ryzen 5 4600H and Radeon Rx 5600m. Every game I own and run on this laptop is running fine and smoothly but Minecraft which uses Java is running on the AMD Radeon integrated graphics. There is no way to add a power plan and set it to "high performance" (as I saw people do with intel CPUs) and I am guessing this is due to AMD smartshift. (Basically, smartshift shifts the power between the CPU and GPU. Smartshift is only available on the Dell g5 se for the moment as it's the only laptop to use AMD CPU and GPU.) So, going back to minecraft, I'm guessing that since Java is mostly a CPU based programm, Smartshift decides to use the integrated graphics at Minecraft's launch instead of my graphics card (radeon rx 5600m). In vanilla minecraft I get low fps (60 to 90fps) but when I want to put shaders on, I get around 10 fps. This is when the integrated graphics should be swapped for the dedicated GPU. I wish there was an option to force Smartshift to set Java to use the GPU and not integrated graphics. Though I might be wrong and in this case, please notify me and tell me what the issue is please. 

Thanks for reading this big thread (no pun intended) but this is a big issue for me.

Have a good day!

25 Replies
goldbat
Journeyman III

I'm having exactly the same problem! I also have the Dell G5 SE laptop and Minecraft Java Edition refuses to run on its dedicated GPU. I've tried adding both minecraftlauncher and javaw.exe to AMD Adrenalin Software's game list, and I've tried setting both programs to "high performance" under windows graphics settings, but neither have worked. All other games are using SmartShift wonderfully, but Minecraft appears to use literally 0% of the GPU when looking at both AMD Adrenalin and task manager. Any methods of fixing this that I have seen so far are either outdated, meant for systems that don't have SmartShift, or both. Apparently the G5 SE is the only system that has SmartShift right now, so this kinda makes sense. But anyway, I don't have any actually useful info or findings to add, but I think your idea might be exactly right, and we just need to find a way to force SmartShift or the GPU to recognize Minecraft as a game that needs GPU!!! 

Someone help us!!!

We just want to play some Minecraft dangit!!!

Have a good day too!

Exact Same issue Please Update me aswell if you find a fix. The High Performance tab in the Windows 10 Graphics Tab for "javaw.exe" options doesn't change anything for Minecraft.

If you find a fix please update us.

Good morning!

      After contacting both AMD and Dell, neither were able to help at all. 

AMD support told me to reinstall some drivers, and when I asked for ways to possibly disable SmartShift, or to force the computer to use the dGPU, they just stopped responding. Dell support was literally just a person copying and pasting info from old tutorials on Google. Both of these "supports" were just wastes of time.

      It doesn't seem like there even is a fix for this right now, and I think it's up to us to spread the word and make AMD or maybe Dell aware of this issue so they can release some driver updates or SOMETHING.

      I've heard this new laptop has a number of rough patches, so I'm sure/I hope that AMD and Dell already know about some of these issues, and have some updates in the works. Best case scenario, it'll just take some patience before this stuff gets fixed.

Please fix this!

Have another good day!  

I think I would ask Dell to take the thing back unless they will extend the return period for a fixed driver that who knows when will fix it. 

I saw people complaining about Asus laptops with these chips being complained about too. 

If AMD stops responding I would open another ticket. Just to make sure you are using the correct form: https://www.amd.com/en/support/contact-email-form 

kingfish
Volunteer Moderator

I wasn't aware java application could use the high performance graphics...just like Open GL is not allowed. These are restrictions the OEM places...on laptops, battery power is king. I could be wrong, but this is something you should ask the supplier about.

Minecraft is a game and most definitely should run on the better graphics than integrated if available. It certainly does for me on desktop. Not to mention it now even supports Directx 12 and RTX raytracing so it can be pretty intensive.

Looks like the same old same old issue to me with AMD integrated graphics and AMD discrete graphics not working on yet another new generation. 

Even before RTX was added it isn't using java3d like a lot of mobile games.

Minecraft uses the lightweight Java Game Library for its graphics, that is a wrapper to OpenGL. LWJGL also encapsulates OpenAL for audio and OpenCL for vertex/fragment shaders (frequently also used for graphics).

dec35
Adept I

Hi, just wanted to say that your ideas are really interesting and that I'm still here. I contacted Dell community and Amd (here), I've sent e-mails to Dell and AMD as well as posted posts on Reddit to get some attention on this problem. If you could do this as well, this could gather eiven more people for AMD and Dell to see that this a serious issue. Thank you for spreading the word...

Have a great day (again)!

dec35
Adept I

Here is one of the posts I made on reddit if you want to check it out and send people to it (I think most people know about reddit more than AMD community).

https://www.reddit.com/r/Minecraft/comments/hulwkk/how_to_force_minecraft_to_use_an_amd_gpu_instead/ 

Thanks

0 Likes
disciple7
Adept I

There is no control over which graphics card is used in the AMD radeon software. They should change this instead of leaving it to the windows graphics tab to solve it, which it's just not working for minecraft(java-based), but it's working for every other game.

It's important to realise it's not the fault of smart-shift, Smart shift has no control over which software uses the 5600M or 4800H/4600H igpu. Smart-shift only does load based wattage shifting with a few tweaks and higher efficency. The fault is that AMD shifting the control of which graphics card is used to windows instead of its own software. Windows graphics settings, doesn't properly force the 5600M to work in this java application "javaw.exe" it should be very easy to fix, we need a bit of traction to get them to fix this for us as it continues to use the iGPU in this laptop configuration despite us picking the "High Perfomance Option".

I hope someone at AMD sees this and does a quick fix for us as this is a very niche issue probably specific to our configuration Dell G5 15 SE (4800H/4600H & 5600M), and mabye the MSI Bravo(4800H/4600H & 5500M/5300M).

If anyone finds their own fix please update us, we are eagerly awaiting to unlock the full potential of the 5600M in this game.

Hope this helps.

Exact Same problem!
I Have the same Laptop, Dell G5 5505

And i commonly play fortnite and minecraft,
Fortnite uses Radeon RX No Problem, But minecraft just won't switch to the high-end Radeon RX 

I Just bought this today, I'm being Tortured by how amd isn't letting us do this option,

I might not like this laptop.

0 Likes

Microsoft impose the restriction on what applications can use the discrete GPU. Java is automatically assigned to the integrated GPU.

0 Likes

So It's basically useless? 

 

0 Likes

For a lot of things, yeah. Even Desktop Manager in Windows 10 causes excessive heat.

The method with which Dell, and others, ensure that the GPU/CPU is 'smartshifted' is to artificially change the power delivery. It's within the manufacturer's limits, but if I overclocked using the same, then my warranty would be void.

It will eventually work. Though if I stop using software that should use the GPU and doesn't and log this with the software developers, that should get more traction. And I hate pause screens ramp the CPU to 100% and it sounds like a tornado. Works like 'Smart**bleep**'.

Seriously considering selling at a loss when I buy an Intel / Nvidia based laptop. This takes away so much of my time. And AMD don't appear to care, just pass-the-buck...

0 Likes
disciple7
Adept I

I have found a way to make it work with 5600M on Minecraft.

Edit registry settings.

https://www.reddit.com/r/Amd/comments/iawemp/amd_switchable_graphics_and_windows10_2004/ 

once you have changed registry settings

go to Power Options.

"For balanced I suggest disabling performance boost mode(completely) and setting the switchable global settings to use Maximize Performance while plugged in and force power-savings graphics when on battery. Then click Apply and OK, then close the power options.

Now press Fn+F7 to ramp the fans up and then go back into the advanced power settings for the High performance plan. For High performance I suggest disabling performance boost mode on battery and enabling it for plugged in(Enabled, not Aggressive) and setting the switchable global settings to use Maximize Performance while plugged in and force power-savings graphics when on battery. Then click Apply and OK, then close the power options."

After restarting it should work with 5600M if you launch the game, with fn+f7 or on balanced power preset.

Hey so I checked the redit thread but I can't figure out what to do... Am I supposed to find a switchable graphics file? I don't understant the procedure.

Have you done it? If so could you help me please? Thanks

0 Likes
disciple7
Adept I

Very sorry I didnt see this. Go into Registry Editor.

copy these 2 into the navigation bar.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\be337238-0d82-4146-a960-4f3749d470c7

find attributes on the right, double click and change the Hexadecimal value to "2"

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\e276e160-7cb0-43c6-b20b-73f5dce39954

there is one folder below this that you select and then you will see attributes on the right.

find attributes on the right, double click and change the Hexadecimal value to "2"

Go into battery power settings on the Balanced and High performance(press Fn+F7 to see this, or use the Alienware command centre).

then follow my above instructions.

Hope this Helps.

0 Likes

hi can u help me 

i wen to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\e276e160-7cb0-43c6-b20b-73f5dce39954

but wasnt able to find atttributes

help

0 Likes

there is a folder below that one. if you click on that one the attribites there can be changed from 0 to 2

0 Likes

Hello, I am suffering from the same problem  i can't play minecraft with gpu. I did everything which I read. I can't do pls help to me I've been working for 3 or 4 days.

my laptop:

msi bravo 17

amd r7 4800h cpu rx 5500m gpu 16 gb ram 

 

0 Likes

Hello, I am suffering from the same problem  i can't play minecraft with gpu. I did everything which I read. I can't do pls help to me I've been working for 3 or 4 days.

my laptop:

msi bravo 17

amd r7 4800h cpu rx 5500m gpu 16 gb ram 

 

0 Likes

Same issue, but not with gaming. Cannot configure or force discreet GPU for paid-for version of DaVinci Resolve. £1000+ on software and control surfaces and it won't run on a £1300 laptop.

They need to get a grip and fix this, before these errors force me and others to choose Intel and nVidia - they do a much better job. Why change something that is not broken - the Calalyst Control Center worked fine.

0 Likes
NoriNori
Adept I

SmartShift causes the Genshin Impact gameplay to stutter because it always switching back to CPU while GPU obviously need more power for it.
Perhaps this is also the reason of choppy gameplay for other games if you guys happen to encounter it?

0 Likes
iapposki
Journeyman III

Having the same problem on Bravo 15 5500m 4600h. Hope it is resolved quickly...

0 Likes
enlighten
Journeyman III

I managed to get Minecraft to use the discrete GPU. Simple solution:

In the installations tab in Minecraft Launcher, edit the installation of the version you would like to play. Click 'More Options' and set the Java Executable to the correct version javaw.exe file. For 1.17.1, I am using jdk-16.0.2. You can usually find this executable in C:\Program Files\Java\jdk-16.0.2\bin .

Additionally, in windows settings, navigate to 'Graphics settings'. Click browse, and select javaw.exe in the folder above. Change options to 'High Performance'.

Restart for fun and let me know if this works for you!

0 Likes

I was able to get it on the discrete gpu. I use Badlion client to play Minecraft and in the Badlion launcher it shows where the javaw.exe file is located and putting that into windows graphics settings as high performance worked. The problem I have though is that whenever smart shift switches to the integrated gpu my fps drops down to around 10. The reason I want to fix this so badly is because I make youtube videos and I can't upload videos on 10 frames. Someone has to implement a way to disable smart shift and just change your gpu manually like on Nvidia. Honestly I would be fine if smart shift didn't even exist because it's so bad.

0 Likes