Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept III

AMD fTPM Causes Random Stuttering Issue

Good evening together
I wanted to ask if anyone here knows anything about the still existing fTPM Bug in Windows 11 or in Windows 10 as I have heard in the meantime.
I am affected by the bug myself and it really gets on my nerves to have to go into the bios every time I update to activate fTPM and then immediately deactivate it again so that I don't get jerks and sound problems. I have a x570 Steel Legend board with the latest bios and 32 GB Ram Trident z Royale Gold. It would be really time that one of AMD times to this but very widespread problem.
If there are errors in the text I apologize for it because I come from Germany and English is not my greatest strength.


AMD Ryzen 5600X, Asrock X570 Steel Legend, 32GB G Skill Trident Z Royal Gold, AMD Rx 7900XTX, Gygabyte G34WQC
145 Replies

This issue occurs with windows11 OS (according to some reports with windows10 also). It's unlikely related to a specific chipset.
I've checked it with several A520 and B550 motherboards - issue occurs with all of them in case of using windows11 with fTPM enabled.

Will the fTPM & stuttering problem be ignored by AMD for half a year now, or can we finally expect an official statement from you. I find it slowly an impertinence how you deal with the paying customers and many others see that certainly the same as I do.

AMD Ryzen 5600X, Asrock X570 Steel Legend, 32GB G Skill Trident Z Royal Gold, AMD Rx 7900XTX, Gygabyte G34WQC

If had tpm stutter with discrete tpm and onlyt happens more or less once a month my last stutter was 26th januari when i got discrete tpm chip within an hour i got first tpm stutter after doing a clean install.

does not look like x570 only issue and not ftpm only either, its has something to do with how AMD proceses TPM rather or runs with it enabled.

Wieso auch nicht ?!?!? Das Netz ist voll davon. Jeder hat Probleme mit AMD Karten Diese sind einfach schlecht. Viel Geld für wenig Leistung und nur weil man Cyberpunk oder Sonst was relativ high spielen kann macht das keine karte aus. Amd ist eine Katastrophe. Die 6900xt ist so unfassbar verbuggt ubd die Treiber sind komplett fürn Arsc*. Amd Support interessiert auch überhaupt nichts. 


I guess I'll just keep waiting for an official fix (if it happens) to see if my FS2020 FPS drops disappear afterwards.


In Windows 11, I have my wallpaper set to slideshow and to change every 30 minutes.  I've noticed that when the wallpaper changes, I'll get get massive stutter for a few seconds then it'll go back to normal.

Journeyman III

Have same issue. w10 20h2, r9 5950x, gigabyte x570 aorus elite, 64gb corsair vengeance 3200

Journeyman III

Lenovo legion 5 pro, ryzen 7 5800H, windows 11, tpm enabled. Just wanted to say I have the same issue to beef up this forum more. Really hoping for a fix from above, stutters seem to be getting worse. Very noticeable 1-3 times a day when gaming and they last 1-2 seconds, audio becomes crazy distorted and hung up in my headset as visuals hang up almost completely. 

Thinking of doing a windows 10 install and disabling fTPM. Are most of you trying that or are people hopeful for a fix? 


The problem doesn't really seem to interest anyone on the part of AMD or even Microsoft. A few comments before, someone commented on it, but that was it again. They are probably all more interested in selling their new products than taking care of existing problems. I know in any case that my next CPU will come from Intel again if this continues.

AMD Ryzen 5600X, Asrock X570 Steel Legend, 32GB G Skill Trident Z Royal Gold, AMD Rx 7900XTX, Gygabyte G34WQC
Journeyman III

Having the same issue with Asus TUF gaming B550 and ryzen 5600x.

Disabling fTPM helped me.

Adept I

 AMD has no intention of addressing this. I am on windows 11 and this problem started yesterday.  It doesn't just cause freezes, for some it causes blue screens as well and random system reboots. The thread here about random freezes and reboots was locked so no no one can reply to it. If AMD expects us to live with these errors and problems with AMD 5000 series processors then maybe it's time for the AMD community to move to Intel. I'm still dealing with USB dropouts that were not fixed with their chipset updates or bios updates. And so yes the root causes here are AMD 5000 series processors and the  X570 chipset seems to make matters worse.

AMD 5900X 

MSI X570 Gaming Pro Carbon

May I ask what motherboard you have? Just curious

ThreeDee PC specs

I have read on the internet there are ways to make Windows think there is a TPM, but none is installed, and then you will not have problems. What a disaster by MS, no one asked for this, I won't be going to Win 11 until they fix this mess. Also the bait and switch on hardware requirements by corporations has got to stop, be honest or go broke.

Not just a disaster by MS. The processor has a TPM module that plainly doesn't work. This is as much AMD's fault as MS. Just had a reboot after using registry hack to disable TPM in Windows 11 and then disable TPM in bios. Lasted 12 hours like that then did a shutdown and  reboot into bios. Bios did not clear itself, it saved all settings. Error logs shows nothing in windows. I've had it with this unstable mess that AMD refuses to fix. The reason for disabling TPM was due to reboots and stutters. There a serious hardware power flaw and AMD refuses to acknowledge and attempts repair through software fixes. Going to RMA this POS and go back to Intel. I have 2 Intel systems neither experience TPM issues.  This is from error log before disabling TPM.

SCEP Certificate enrollment initialization for WORKGROUP\DESKTOP-5E5O7I0$ via failed:

GetCACaps: Not Found
{"Message":"The authority \"\" does not exist."}
HTTP/1.1 404 Not Found
Date: Sat, 26 Feb 2022 21:17:35 GMT
Content-Length: 121
Content-Type: application/json; charset=utf-8
X-Content-Type-Options: nosniff
Strict-Transport-Security: max-age=31536000;includeSubDomains
x-ms-request-id: c709294c-ed9e-430f-915a-4bba93d65906


This is from after disabling TPM through windows registry and bios.

A fatal hardware error has occurred.

Reported by component: Processor Core
Error Source: Machine Check Exception
Error Type: Cache Hierarchy Error
Processor APIC ID: 0

The details view of this entry contains further information.


It'd be great if MS would have not favored intel too much, but they probably were some shady things with favorites being played. Why do we have to put up with stuff businesses wanted (TPM) where it probably is a way to watermark everything you do or shut you out if some powers don't like you? TPM is some tech hoisted on every Windows user that no one but businesses wanted. Also changing at the last minute what version was needed was plain evil by MS. But they don't care too much for users, make them test and have mega problems so MS can save a few bucks, like they don't have enough already. What a mess.

Edit: Also if MS decides to try a subscription model for Windows, that will be the last one I use, and play the games and use the software I have on the last version that isn't subscription, and basically say no new games. I know lots will probably go along with it, I don't think they understand Windows doesn't mean that much to me. I can go on without it. Also they are about to already start the next Windows version development, do you enjoy the technology treadmill yet?

In the meantime, I find it simply laughable what AMD gives away here. Last year it took ages to get the driver to run reasonably well. After that, there was a break and the motherboard manufacturers had to screw together a suitable driver. Now since over 4 weeks at the beginning of my thread no answer from the AMD crew. Much longer are the complaints in countless forums on the net from users who have the same or similar problem as me. I don't expect anything different from Microsoft because they seem to have slept with Intel during their TPM history in order not to cause any errors, but I was always used to something different from AMD. Good support and excellent products. Since it now seems to be the AMD rather concentrates on ignorant users or buyers to pull the money for new hardware from the pocket instead of helping them, I will buy the next system rather at the competition. I've been annoyed for weeks about how I could throw almost 1000 euros into the maw of AMD. That will truly be a lesson for me in the future.


AMD Ryzen 5600X, Asrock X570 Steel Legend, 32GB G Skill Trident Z Royal Gold, AMD Rx 7900XTX, Gygabyte G34WQC

There is nothing that leads me to believe the Event 86 errors from failing to enroll the AIK certificate is related to the stuttering. I used to think they were related, because I would be more likely to notice the other when I encountered it's partner.

But even disabling the AikCertEnrollTask and KeyPreGenTask and even the Tpm-Maintenance task -- the Event 86 errors will stop entirely along with Windows' attempts to get an AIK cert from Microsoft. But I didn't notice any change or reduction in the stuttering from it.

But I would be very kindly appreciate if AMD could roll out two fixes in one, maybe a double-whammy release of AGESA 1207 to fix stutters, along with maybe a new chipset driver or something pushed out in a Windows update to resolve the certificate problems.

I had my first actual freeze from this yesterday.  Before, I was using an Nvidia card and all my Event 86 errors regarding AMD's certificates were pretty much symptomless.  But, I finally got an AMD card (6700XT) and it looks like with that, those errors result in a locked system.  I haven't really noticed stutters, but with yesterday's total freeze (had to hold the power button down to get things to reboot), the only thing in the Event log at the time was another pair of Event 86s.


I have an all AMD system, x570 mb, 5950x cpu and rx 6900 xt gpu and my stutters come at random times and arrive completely unexpected.  One time they were so bad they crippled my system forcing me to reboot and that was after installing a header TPM module.

For some reason Gigabyte bios doesn't differentiate between the firmware ftpm and the header module so there's no selection option between the two.  I've seen some Asus board differentiate between them in the bios but not here.  AMD really needs to get the fixed AGESA out to their partners to get this nipped in the bud once and for all time.

FWIW I never had any similar issues while running Intel equipment with Nvidia gpu's and each instance takes me ever closer to returning to their components.

Tis a shame after spending that extra $40 for the standalone header TPM module only to have the stuttering start up again.


hi, perhaps Gigabyte Bios has some sort of auto-detect if a discrete TPM-module is installed?
You can check which one is used fTPM-Firmware or fTPM-Discrete
- In the command prompt (Windows key+R) type: tpm.msc

On my Asus ROG Crosshair VIII Hero X570 in BIOS I can change between fTPM-Firmware or fTPM-Discrete
Right now I have an ASUS TPM-M R2.0 Module 149SEK (15USD) installed.

fTPM-Discrete in BIOS

fTPM-Firmware in BIOS

Best regards from Sweden


That's what I was saying about the module as Asus shows it in the bios menu and Gigabyte is like oh well.  None of the settings changes after I installed the module and cleared out the ftpm settings.  Yes I checked to make sure that it was seated in the socket and you can see the individual pins in each of the contacts in the socket.

Next go around I see myself with a 13900k and rtx 4xxx card on an Asus motherboard.


Why spending money on TPM module, just go in bios and deactivate TMP there the time AMD releases the fix. 


Because a "Deactivate" Option has been completely removed "ages" ago from many Mainboard fw versions.



I always get an error in the Eventviewer:

CertificateServicesClient-CertEnroll Event 86

Fehler bei der Initialisierung der SCEP-Zertifikatregistrierung für Lokales System über

GetCACaps: Not Found
{"Message":"The authority \"\" does not exist."}
HTTP/1.1 404 Not Found
Date: Thu, 03 Mar 2022 03:35:36 GMT
Content-Length: 121
Content-Type: application/json; charset=utf-8
X-Content-Type-Options: nosniff
Strict-Transport-Security: max-age=31536000;includeSubDomains
x-ms-request-id: 3516a9b7-7b1d-4c99-af1e-8665b695e6d5

Methode: GET(297ms)
Phase: GetCACaps
Nicht gefunden (404). 0x80190194 (-2145844844 HTTP_E_STATUS_NOT_FOUND)


My Specs:

Ryzen 9 5900x, x570 Meg Unify, g.skill Ripjaws 2x16gb, Noctua-nhd15, Rtx 2070, corsair 550w, sn850_black M2nvme 1tb, 500gb crucial ssd;


I read a big book about this error on google, but still i haven't found a solution.

Is there a solution now for this error?

Thx and regards!


unfortunately, there is no solution from AMD in sight yet. The high lords and ladies don't even care about these errors. They simply keep quiet about the issue for weeks and probably wait until most people simply stop complaining about it or they are tired of inquiring about it. The behavior on the part of AMD is simply subterranean.

AMD Ryzen 5600X, Asrock X570 Steel Legend, 32GB G Skill Trident Z Royal Gold, AMD Rx 7900XTX, Gygabyte G34WQC

How is this still not fixed? It's been at least 6 months since I've updated to Windows 11 and began having this issue, with no fix in sight besides disabling fTPM.  I'm almost tempted to switch to another competing platform where quality issues like this are resolved in a much more timely manner.

Yesterday I had this problem for the first time while playing a game and it really annoyed me.  I am running a bios containing the latest AGESA on a gigabyte aorus master x570 mb, 5950x, 32gb g.skill ddr3600 and an xfx speedster merc 319 rx 6900 xt black using adrenaline 22.2.3.

Community Manager

Please refer to the following knowledge base article for more information. 

Intermittent System Stutter Experienced with fTPM Enabled on Windows® 10 and 11

Hello Matt
Signs and wonders are still happening hallelujah.
Finally an info where we have been waiting for it for almost months. Now you finally see light at the end of the tunnel and we have to hold out until May, but at least the bios version has brought me a little relief.
Thanks for the information of the problem

AMD Ryzen 5600X, Asrock X570 Steel Legend, 32GB G Skill Trident Z Royal Gold, AMD Rx 7900XTX, Gygabyte G34WQC

Was anyone getting the random flashing like seen in this video clip before aswell




Can't wait for people to say they still get tpm stutter after switching to dTPM chip, speaking of which experienced this my self, work around is false.

Yeah, I have also this stuttering problem once in a while on my Asus ROG Crosshair VIII Hero X570 mobo (latest Bios 4004 with AGESA V2 PI ).
CPU: Ryzen 9 3950X AM4 CPU
O/S: Windows 10 64-bit Pro for the foreseeable future.

I was wondering if I could just disable fTPM in Bios, since I don't use Bitlocker or any other Drive Encryption?
Without the need for buying and installing a separate ASUS TPM-M R2.0 TPM-Module (which btw. my mobo supports).

Then I was wondering if this fTPM issue also cause sound crackling on my Sennhesiser (Epos) GSP670 Headset connected via USB-dongle (wireless)?
Only in games and just once in a while and never a sound problem if I use my stereo speakers 2+1 (Realtek audio).

Best regards from Sweden

TPM is required by Windows 11 in order to receive updates properly.
As far as i know, Windows 10 doesn't require a TPM in order to work properly (unless there're some another related update released recently that i don't know about).

A stuttering occurs in any random moment, unrelated to any specific kind of task being processed at this moment.
It suspends all the processing completely, for a short time interval. This means, if you play games or watch movies - picture gets "frozen" for a moment, and the sound is distorted by a "crackling" effect in that moment.
"Crackling" effect might be not noticeable with Speakers that much as with Headphones.
If you do typical office work with no sound and no video, this problem is unnoticeable at all.

If stuttering affects only video, but doesn't affect the sound, it is highly likely unrelated to this fTPM issue (there are a lot of another reasons existing that cause video stuttering and/or sound crackling effects), or some specific sound adapter device is being used that is not affected by this fTPM issue (most are affected though).

So when AMD gonna admit dTPM does not fix tpm stutter ?

its really starting to annoy me how AMD is dodging the issue, are you even capable of fixing this ? or this gonna be one of those issues that will always stay around regardless and becomes less common ?

You cant really claim a fix about something as random that can be as rare as monthly issue even and yes it can happen daily but just cos it stops happening daily does not mean its fixed, there is a reason this is happening and AMD is dodging answers.

I ordered a TPM module for my Gigabyte X570 Aorus Master which should be in this week.  Several people who installed it say their stuttering was fixed by it.  I'm not happy that such expensive hardware is suffering from stupid things like this and that fixes from AMD to their partners are so slow.

Trust me it can still happen maybe it becomes more rare but it wont fix it Asus has Spi modules you can install in their mainboards bassicly that have SHA-384 support even and still giving issues, it was not a matter of forgetting to switch to discrete tpm either for me i am 100% sure i experienced tpm stutter, i have no proof but the issue is so rare you unlikely to record it unless you have recording on 24/7

fTPM can't be disabled in BIOS > Advanced > 

If I try and then save & exit the system will revert back after reboot to enabled fTPM Firmware.
This is also confirmed by running an elevated command prompt with the command: tpm.msc

I thought I could do this since I am running Windows 10 Pro and don't have Bitlocker or any other encryption on my drives.
I think AMD changed this a couple of Agesa versions back, when they automatically enabled fTPM in Bios.

Motherbord: Asus ROG Crosshair VIII Hero X570
BIOS ver. 4004 with AGESA V2 PI

So right now I'm stuck with stuttering and sound crackling until may(?)
I think AMD should really speed the development and testing of new the Agesa s/w.
Best regards from Sweden

On my Win 10 B550 5800X RX 6700 XT 32 GB 850 BeQuiet! Soundblaster AE-5 Plus system I noticed my fTPM is also enabled and I disabled it before. Also, with 22.2.3 and 22.2.1 if I disable vsync or enable enhanced sync, I get audio stuttering on all games. If I enable vsync it's fine. I did put in a bug report to AMD. I did use AMD cleanup utility before installing 22.2.3. I may try reinstalling the AE-5 Plus drivers, but I shouldn't have to do that, I am not sure what is causing the problem.

Edit: I removed and reinstalled my Soundblaster AE-5 Plus drivers, no change. Seems there is either something on my system configuration or a bug in the drivers. I don't feel like testing older Adrenaline drivers just yet. I hope it will be resolved soon. All games using DirectX with no vsync have audio stutter, Quake II RTX doesn't, but it uses Vulcan and doesn't surpass 60 fps. Sure am tired of things in the world marketed as fixes causing more problems than they fix.

So, if fTPM can't be disabled with Agesa, then it's better to stay with Agesa until with fTPM fix is released.
I'll skip Gigabyte BIOS F15b version then. Running F14 with fTPM disabled now, no any Windows 11 stuttering so far.