Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

AMD Drivers timeout and general instability


I have been struggling with getting any AMD drivers to work well with Hitfilm Pro for a couple months now. I will be listing all the specs that I think I should provide along with all the things I have tried so far. But first, some general observations of what the issues are the way i see it. Whenever the "3D" graph in task manager reaches 100%, the program freezes, i get black screen first on the main monitor and sometimes followed by the second monitor. Then back to hitfilm program, which is now a white screen and unresponsive. Adrenaline sometimes notifies me drivers have timed out but other times it does not. Whenever i render a project that has any moving 3D elements, the program crashes, followed by either a driver timeout notification or a memory access error. There is an interesting interaction with the program, where if i first render a very simple project, for example a blank background and then turn the background into a 3d plane and render again, i will be able to render a very simple 3d project without a crash. Basically, if i work up the intensity, the ceiling of renders before it crashes increases. Other issues involve general instability like frequent crashes when just playing the project timeline, issues with real time caching and a 24-bit color profile inaccuracies (colors for this profile are wrong. for example if i have an orange background it will turn blue in the program. However, on some drivers this is not an issue while on others it is). Some drivers also caused an issue where my ram usage for hitfilm would get capped and the program severely lagged. Oh and sometimes i get an OpenGL error saying an error has occured but no error code.

Im not sure what data is useful to share so I will just post everything I think might be relevant:
System information:
OS Name Microsoft Windows 10 Home Single Language
Version 10.0.19045 Build 19045
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Manufacturer ASUS
System Model System Product Name
System Type x64-based PC
System SKU SKU
Processor AMD Ryzen 9 7950X 16-Core Processor, 4501 Mhz, 16 Core(s), 32 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. 1654, 25/08/2023
SMBIOS Version 3.5
Embedded Controller Version 255.255
BaseBoard Manufacturer ASUSTeK COMPUTER INC.
BaseBoard Product TUF GAMING X670E-PLUS WIFI
BaseBoard Version Rev 1.xx
Platform Role Desktop
Secure Boot State On
PCR7 Configuration Elevation Required to View
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume2
Locale United Kingdom
Hardware Abstraction Layer Version = "10.0.19041.2728"
Installed Physical Memory (RAM) 32,0 GB
Total Physical Memory 31,1 GB
Available Physical Memory 22,2 GB
Total Virtual Memory 40,7 GB
Available Virtual Memory 26,6 GB
Page File Space 9,53 GB
Page File C:\pagefile.sys
Virtualisation-based security Not enabled
Device Encryption Support Elevation Required to View
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualisation Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

the Graphics card is: AMD Radeon PRO W6600 Professional Graphics.

RAM is vengenace ddr5 5600hz

Here is the list of the drivers i have tried and didnt work with hitfilm pro:

if its adrenaline i will write A, if its pro i will do P:
A 23.9.3
A 22.3.1
A 22.6.1
A 22.11.2
A 23.9.1
A 23.9.2
P 23.q3.1
A 23.2.1
A 22.2.1
A 22.6.1
A 23.5.2
A 22.3.1
A 23.7.1
A 23.8.1
P 23.q1.1
P 23.q3
A 23.7.2

My monitor setup is: display1: XG2401 series at 144hz connected to the gpu via display port and display2: T27B300 at 59,940hz connected to the motherboard via hdmi. The reason I am using A version is because P isnt compatible with the 2nd monitor that goes to my motherboard (no signal).

Now i will list the things i have tried so far and any other compatibility issues i have encountered. This will not be in order because i honestly forgot: disconnected and reconnected the gpu and ram (also switched positions), tried a different display port slot, different display configurations and fps configurations like: only display 1 or 2 at 30hz, 60hz and the main one at 90hz, 120 hz, 144hz. Tried a different monitor (dont remember which one, frend let me lend it but doesnt matter there was no difference). Tried different color profiles on the monitors: 6 bit, 8 bit, 10 bit. Removed my speakers. Set to run as administrator and tried compatibility mode. Updated my bios. updated windows. updated the display drivers independently (windows recommended them). Cleared all drivers with DDU i think 4 times now, since i was trying so many different drivers. Tried a clean install after DDU only drivers without adrenaline (newest driver). Tried changing virtual ram. tried disabling antivirus. Gazillion different settings combinations in adrenaline, im not going to be able to list them. Oh and i tried the custom refresh rate setting. At some point i did a factory reset when installing drivers and my pc wouldnt boot, i tried clearing all the amd drivers that arent sistem related through the boot cmd but didnt change anything. ended up reverting to an earlier state. I tried setting Hitfilm pro to performance mode in windows and changed the priority levels. Ive tried different versions of Hitfilm. The one that is integrated with Vegas pro (version 3 and 4) and the stand alone version. No difference. I played around with the fan speed. I dont seem to have any overclocking options for my card and also i downloaded after burner but no options there either (greyed out). I tried checking if my ram is corrupted with memtest, 31gb's, it found 0 errors.  Inside hitfilm i tried enabling or disabling hardware encoding/decoding, changed the pixel format, audio format, anti aliasing mode from 4 to 8. Here i note that if i set in andrenaline to override anti aliasing settings and set it to 2, the 24-bit color profile seems to get fixed. Lowering the resolution helps but only to the point where i am not hitting that 100% in the "3d" graph.

I am not having any issues when playing videogames. I think armored core 6 crashed once out of around 4 AAA games i have played for around 100hours and league of legends was crashing only on 1 specific drivers version, i dont recall which one but it stopped once i changed the driver.

If i remember anything else and if I should post any other information please tell me. The crash reports dont give any information or i cant find it.

edit: this message when trying to post "Your post has been changed because invalid HTML was found in the message body. The invalid HTML has been removed. Please review the message and submit the message when you are satisfied."


1 Reply
Journeyman III

Forcing to same issue, but not in same software. Just use anything which require HW acceleration like video player, 3D software, lightroom, etc... I use just integrated GPU in AMD Ryzen 7950X and it constantly crash every f***g day many times. More than one year without any luck on fix :(.


OS Name: Microsoft Windows 11 Pro
OS Version: 10.0.22621 N/A Build 22621
OS Manufacturer: Microsoft Corporation
OS Configuration: Standalone Workstation
OS Build Type: Multiprocessor Free
Registered Owner: xxx
Registered Organization:
Product ID: 00330-80000-00000-AAXXX
Original Install Date: 13.10.2022, 18:59:10
System Boot Time: 16.10.2023, 13:03:28
System Manufacturer: ASUS
System Model: System Product Name
System Type: x64-based PC
Processor(s): 1 Processor(s) Installed.
[01]: AMD64 Family 25 Model 97 Stepping 2 AuthenticAMD ~4501 Mhz
BIOS Version: American Megatrends Inc. 1654, 25.08.2023
Windows Directory: C:\Windows
System Directory: C:\Windows\system32
Boot Device: \Device\HarddiskVolume1
System Locale: cs;Čeština
Input Locale: cs;Čeština
Time Zone: (UTC+01:00) Praha, Bratislava, Budapešť, Bělehrad, Lublaň
Total Physical Memory: 64 655 MB
Available Physical Memory: 31 450 MB
Virtual Memory: Max Size: 68 751 MB
Virtual Memory: Available: 27 906 MB
Virtual Memory: In Use: 40 845 MB
Page File Location(s): D:\pagefile.sys
Logon Server: \\XXX
Hotfix(s): 4 Hotfix(s) Installed.
[01]: KB5030651
[02]: KB5012170
[03]: KB5031354
[04]: KB5031592
Network Card(s): 4 NIC(s) Installed.
[01]: Realtek Gaming 2.5GbE Family Controller
Connection Name: Ethernet
DHCP Enabled: Yes
DHCP Server:
IP address(es)
[02]: fe80::ef94:eead:35c7:5eef
[02]: Bluetooth Device (Personal Area Network)
Connection Name: Síťové připojení Bluetooth
Status: Media disconnected
[03]: Realtek 8852BE Wireless LAN WiFi 6 PCI-E NIC
Connection Name: Wi-Fi
Status: Media disconnected
[04]: Realtek USB GbE Family Controller
Connection Name: Ethernet 2
Status: Media disconnected
Hyper-V Requirements: A hypervisor has been detected. Features required for Hyper-V will not be displayed.


Motherboard: Asus X670P WIFI