cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

slink_jingles
Journeyman III

AMD Drivers Not Installing Linux

I have an MSI Radeon RX 580 graphics card that I am trying to get to work on Fedora Linux. Now since Fedora Linux is basically the same as RHEL / CentOS I'm trying to install the RHEL CentOS 8.5 drivers on my computer. I'm getting the drivers from this page. When I install amdgpu-install-21.50.2.50002-1.el8.noarch.rpm and then run amdgpu-install from the command line, I get this output:

$ sudo amdgpu-install
AMDGPU 21.50.2 repository                                                                                                                                                                                     1.2 kB/s | 178  B     00:00    
Errors during downloading metadata for repository 'amdgpu':
  - Status code: 404 for https://repo.radeon.com/amdgpu/21.50.2/rhel//main/x86_64/repodata/repomd.xml (IP: 13.82.220.49)
Error: Failed to download metadata for repo 'amdgpu': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried
Ignoring repositories: amdgpu
Last metadata expiration check: 0:00:33 ago on Tue 10 May 2022 01:17:32 PM EDT.
No match for argument: amdgpu-lib
No match for argument: amdgpu-dkms
Error: Unable to find a match: amdgpu-lib amdgpu-dkms

 So I looked into the URL it gives me there, https://repo.radeon.com/amdgpu/21.50.2/rhel//main/x86_64/repodata/repomd.xml , and it is indeed a 404. But I found that if I edit the URL a bit and put an 8.5 for the version number in between 'rhel//main' I get a URL that works and doesn't take me to a 404 page. ( https://repo.radeon.com/amdgpu/21.50.2/rhel/8.5/main/x86_64/repodata/repomd.xml )

So I'm thinking that there is a problem with the amdgpu-install script where it isn't putting the version number in the URL for the metadata, which is preventing the package amdgpu from being installed properly, which is causing all the other problems I'm seeing.

As a side note,  I also tried installing the drivers on CentOS Stream 8 and I had the same problem with the URL, so it seems to be universal.

Does anybody have any ideas how to fix this?

Tags (3)
1 Reply
MtKrRa
Journeyman III

Re: AMD Drivers Not Installing Linux

Same problem, Fedora 36 with RX 6000 series. Seems like a really stupid problem, hope they fix this very soon.

0 Likes