Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

AMD Drivers and VR

Ever since Radeon-Software-Adrenalin-2020-21.10.2-Win10-Win11-64Bit-Oct25 came out, none of the updated ones work properly with VR applications without some sort of problem and this kept going... two years later and this latest 22.5.1 and 22.5.2 is even worst, I think AMD forgot about VR and all related to that so i strongly recommend if your card is supported on the last properly working driver 21.10.2 please use that one otherwise i'm sorry for you, your only alternative is using virtual desktop with h264 encoding.


This is the part where some dev, community manager or anyone that can deliver this small list to the drivers team that actually has a quest 2 and is not blind so it can check easily and see how terrible it is (most likely this will die here like all the threads related).

This are the problems with any newer driver after 21.10.2:

Airlink: For some reason bitrate is capped at 65-75Mbps (i think this cap appeared with 22.5.x), looks awfull, tons of compression artifacts, stuttering every few seconds, depends on the driver version sometimes you get like a bad reading on the controls and the screen keep shackin like you'r moving while staying still. And the encoder HEVC from AMD is not supported and seems like it never will be, why not reach out to the meta team? and get support from the most used headset on the market?.

ALVR: The configuration of 150% scale, 90hz, 150Mbps, HEVC that worked smoothly now has stuttering issues, white dots appearing and makes the app unstable with possible crashing but H264 gets very choppy forcing a scale of 100% tops, unfortunely making it look blurry.

Relive VR: I have made a thread here related to the beta 2.0
TL DR: You won't get the same image quality as Airlink, ALVR or Virtual Desktop, but it will work. (preferable to play with a cable at this point unless you are ok with a blurry, low quality image)

Virtual Desktop: The only app that works BUT the encoder has to be H264 otherwise you will crash in games, in SteamVR, some at the moment of loading like Hellsplit: Arena, or other like GORN or Into the Radius will crash after a few minutes or hours and when it happens you will be lucky if you don't need to reboot the system in order to get the Adrenalin menu to work again or steam to launch a game properly.


Tested on a 6800XT and 6900XT.

93 Replies
Adept II

I experienced the same issue for the past 6 months with Oculus Airlink. I didn't know why, until now. Reverted back to 21.10.2 and Airlink bitrate is no longer capped and functions correctly.

Please fix this. I should be able to update the drivers for my $1000 dollar GFX card without crippling one of the main things I use it for.

Adept I

+1 for this. Air Link quality has been getting progressively worse and more restricted, and Virtual Desktop HEVC support has been outright broken, resulting in driver crashes when trying to play games. VD's developer claims these are issues with AMD's encoder. I don't know if there has been any word from Oculus about why Air Link's image quality has degraded but I'm guessing it is for the same reason. Getting really tired of finding yet another problem with VR/video encoding support every time I update my driver... it would be nice if AMD acknowledged the issue and took it's encoder stability more seriously. Apparently this is now a running joke within the VD/VR community.

I was able to update to 22.2.3 with full functionality.

The problems return for me using 22.3.1.

Journeyman III

I don't really understand, why driver team ignore this issue for 2 years for now. I have RX 6700 XT and I have same experience. My VR set is Quest 2 with Wi-Fi 6 router, that I use only for streaming.

Tested newest driver (22.5.2) vs 21.10.2 and gap between them is huge.

Everything according to HEVC fine in older driver, but performance in everything is worse, than in newest. HL Alyx difference about 20+ fps.

Relive VR is unusable, on stock settings have worst performance for now - picture is laggy and unresponsive and falling apart. For first time I think it was a joke, because it don't work at all.

ALVR have some issues with latency (it is about 50-60, that's huge).

Virtual Desktop works, but only with x264, HEVC crash video driver. Without HEVC you have 40-50 latency and worst picture. With HEVC you have about 15-20 latency.

Interesting thing that this problem is not a problem for AMD at all, I haven't see any "known issues" in driver release notes. That's really frustrating.

Adept II

Would be nice to have some reply from any devs @Matt_AMD 

I agree. 3+ weeks without a response.

I wonder if the majority of the users aren't noticing the issue. It was clear and obvious to me when the image quality took a nose dive but maybe it's not so noticeable when using Airlink at a lower render resolution.

On 22.5.1 the Oculus software pretends AMD cards with HEVC support have no support for HEVC and encodes in AVC/H264, although as a bonus, you can now push the Air Link bitrate back up to 200mbps now that there is a supported Oculus profile for AMD RDNA1/2 as of the latest Oculus software release. On 22.5.2 even H264 is broken, resulting in log spam from the AMF encoder stating "Warning: SetProperty ReferenceBPicturesDeltaQP not found" and weird Oculus Home tracking behavior, although this doesn't seem to stop games from playing properly (all I tested was Alyx and Beat Saber). Even at 200mbit, the H264 quality is noticeably lower than the working HEVC implementation from last year.

It would be nice to see AMD at least acknowledge there is a problem with the HEVC encoder as this is a feature these cards are marketed as including. There isn't that much info out there to the end user who is considering buying a Quest 2 and an RDNA2 card expecting to use HEVC that this combo hasn't been working properly for months.

So, are you saying that 22.5.1 works like 22.2.3, but the image quality is reduced? In my last attempt, I tried the latest 22.5.2 with the same results and a severely capped bitrate. I don't think I tried 22.5.1 and Airlink together.

It's weird, because I was pushing 400+ megabit through the network when using airlink and 22.2.3. It seems that there is no limit. Obviously it was a laggy mess and wasn't playable, but the transfer rate was WAY over the 200mbit limit/cap. I only noticed this because I forgot to reduce bitrate back from when I was using the USB cable and regular link.


EDIT: Had to try 22.5.1 : It capped the bitrate again near 65-75 Mbit. Reverted back to 22.2.3. (airlink)

Using HVEC does gives better image quality, ALVR (free) or Virtual Desktop can use it and the banding introduced on H264 is mitigated, airlink never supported that and that's no way to play vr via wifi when you can get much more quality.

On 22.5.1 and Oculus app version, the Oculus app seems to recognize my GPU (6600XT) and allow 200mbps bitrate. I haven't checked if the actual traffic is pushing 200mbps but I will check that next session. I have PTC enabled in the settings of the Oculus app; not sure if this version is testing, but this is the highest I've seen the slider go on Air Link so far. Last I checked, the Oculus app would report my spec as below the minimum for VR and cap the bitrate slider for Air Link at 100mbps. I typically use Virtual Desktop for Wi-Fi streaming so I have only checked into Air Link sporadically over the last few months. I also recall the Oculus Debug Tool setting for bitrate overriding this slider at one point but that no longer seems to be the case for me as I had it set to 500mbit for wired link when I last used it, but this did not affect my recent Air Link session.

I haven't seen bitrates capped below 100mbps but I have heard people mention this. Can you clarify whether the bitrate slider for Air Link is capped at 75mbit or whether you are observing the rate of traffic from the network interface to be capped instead?

The slider does move but any changes above 75 are not reflected on the network usage, but aside from bitrate the issue is that it affects things like the tracking head/controls at least for me on the desktop, it starts to shake a little bit.

Thanks, I was able to confirm similar behavior on my hardware. Air Link Slider and Oculus Debug setting both affect actual network bitrate until ~95mbps and then no further bitrate increases are observed on 22.5.2 and 22.5.1.

There is a way to reverse the odd tracking issues of 22.5.2 through a regedit mentioned in the UWP thread on the guru3d forums, but this doesn't improve quality/encoder behavior so it doesn't seem all that useful at the moment.


I am wondering if the less flexible fixed function video hardware AMD is using now is to blame?


Cyberstorm64 of UNYU
Tessellation Enjoyer.

I think the mayority don't know where to complain, is easier to sell the card and jump to nvidia (i'm in this process right now) since filling the bug reports for longer than a year seems to do nothing and AMD doesn't have any type of support, we are at the mercy of the devs/reps. that look into this forum when they want.

I am also weighing up my options around this, but at the moment there are a few things AMD does better in open source that my setup relies on (such as adaptive sync support on only one monitor in multi-monitor configs via Wayland), and in my country's market the price difference is still quite high between equivalent 'general' performance.

I guess I will keep bumping this thread with useful info and filing crash reports until an opportunity to switch cards presents itself. I like AMD (specifically the Ryzen and chipset support in recent years) but this complete lack of addressing an issue for months is hard to justify. I hope if other people are suffering this issue and find this thread, please leave a message to make it clear to AMD that more people are affected by this and hopefully the numbers will be enough for them not to ignore.

Yeah, some form of feedback will be nice. From both sides. Tons of people complain about encoder that used in VR apps (Oculus Airlink for example or VD) and have zero response from devs. That's not right, I guess.

Journeyman III

I'm also frustrated that neither h.264 nor h.265 encoding works properly

Journeyman III

Yes, this is very frustrating to me too, I specifically got the more powerful 6900XT to be able to play VR games with higher resolution. So far I'm getting a very janky experience - fiddling with the drivers, crashes, latency spikes, and all that noise. I would love to see an ETA on encoder problems. 

Journeyman III


The most stable connection with 6700xt and Oculus quest 2 is virtual desktop for me. That being said even that is OK not great.

The Link Cable is basically not playable because of stuttering. Is anyone else having this problem? 

I have had no problems when using a 3060Ti.

Sold my 6900xt for a used 3080 12GB, what a surprise... in not-vr games the 6900xt is better, yes (sometimes), BUT on vr is another story, not only the framerate is better, frametimes and it actually does look better using the same codec (with VD), airlink on the other hand is waaaay better. If you can, switch now that the gpu prices are dropping.

yes... please please fix this. AMD has made so much progress in drivers and I prefer using my 6800XT to my laptop 3080 when playing Skyrim VR. I would really like to be able to use both airlink and relive VR for different games as they have different strengths and weaknesses. 

I had no problem when I had my 3060Ti. I switched to the 6700xt and nothing but problems with VR. 6700xt is a beast when it comes to anything else but VR. It is sad that the only thing keeping amd back is there drivers.

Adept I

I'm having the same issue with my 6700m. It's really frustrating not getting any type of acknowledgement about this from AMD. I kind of regret switching over from my RTX 2060 since I didn't have any issues what so ever with it.

I am new AMD 6900xt user (just a few days) and I am already regretting it. Probably will return the card to amazon to take a Nvidia 3080ti.

I just posted my issue here, but now I see that this is a long standing issue.

Right now I am using very old drivers (21.5.2) and VR works quite well, but this is not the right solution.

I hope AMD aknowledge the VR issues

Journeyman III

Hi, since January as I got my laptop (Omen16: RX6600M ryzen9 32GB) I experienced same as you wrote on Quest2; my first PC VR after years of PSVR.

Yesterday I did this and something unexpected happened. I removed drivers of both my vid cards and installed the Pro Edition (22.Q2). My bitrate was 150 Mbps and had peaks near 300. I now decided not to push too much and put my resolution to 1x and 90 Hz that is fine to me (now 120 Mbps). I'm on beta on SteamVR and Oculus PC software


I can now enjoj Fallout4 VR that I've been playing last weeks and was really a sad experience.

/edit: forgot: using Airlink; ALVR is always a bit blurry to me; ReLive I did not test now but had worst experience before.

/edit: this must be done (suggested on this thread and as on

reg add "HKEY_CURRENT_USER\SOFTWARE\Oculus\RemoteHeadset" /v "HEVC" /t REG_DWORD /d "1" /f

I cancelled this key and all became unusable while bitrate reached also 1000 Mbps !

I will try more changes; system is not perfect yet but much better to me. 


Journeyman III

update: I set my Quest2 to 1x and 72 Hz as (raccomended values to me) because of some overheating.

I wanted to give a try to 22.8.1 - the results: 50 Mbps and 7 Mbps with the HEVC register hack - very blurry in both cases.

I went back to the PRO edition 22.Q2 with some troubles this time. The correct procedure was: uninstall the adrenaline software - close all processes that could use the graphic drivers; uninstall both vid card drivers (on my laptop the integrated and the 6600M); install the 22.Q2; windows update (I guess for the integrated card).

This pushes to 600 Mbps but is unusable (very laggy) to me and to 150 Mbps with the HEVC hack: here it works well.

To me HEVC causes some white dots lines but are visible in some cases only (head movement in dark background).

I also have been using ALVR (beta - very updated these last days) and sometimes is more stable but the picture is always less sharp and light.

Adept I

I have spent weeks and weeks trying to understand why my Reverb G2 has either flickering or a grey screen in Windows Mixed Reality.

HP graciously replaced the headset, then the cable, then the power supply. Nothing fixed it.

Until I rolled my AMD graphics drivers for my 6900XT back to a random one I chose from 2021 (22.2.3).

Today, it happened again. WMR had a flickering screen on startup and subsequent times I tried to restart the program either had a grey screen or the flickering one.

So I looked at the Radeon software... Yup, the drivers had auto updated to the latest version. IT'S THE DRIVERS!

So I went back to 22.2.3 and it works again.

It has been a huge waste of time trying to find out what was causing this. It is good to see this thread about it and frustrating to see AMD is not addressing the issue. I've lost faith in AMD graphics after this experience.

Bobjones. Your issue is supposedly fixed in 22.8.1


Just tried it out...

Still not working.

Adept I

No issues at all with a real PCVR headset - and on 8.1 performance is better than ever, unsurprising that the quest barely works considering it needs transcoding to work and that has been broken for a long while for some inexplicable reason.

Adept I

New Photoshop Update gives me an error when I start PS saying my rolled back drivers are out of date.

Can anyone tell me if this has been fixed in the latest drivers or not?


of course not

Adept I

Just updated to 22.8.2 and my Reverb G2 issues are resolved.

Adept I

Hello. Any progress with the issue? I had swaped to AMD card to find out it is not working with virtual desktop as nvidia does. After a small research i found this toppic. Is AMD trying to fix the issue or should I swap back to nvidia? Using x264 is like pain in the a.. I downgraded to  2years old driver recommended here but using so old driver on the latest gpu does not sound right.

You may try a workaround to get Virtual Desktop to work properly with a Quests 2 and the new drivers.

Disclaimer: I am not responsible if this breaks anything. Try this at your own risk.

1. Download version 21.10.2 and the recent AMD driver (and optional Display Driver Uninstaller from

2. (optional) Uninstall your AMD drivers with "Display Driver Uninstaller" in Windows Safe Mode

3. Extract version 21.10.2 of the AMD driver, but do not install it

4. Copy the files "amdh264enc32.dll", "amdh264enc64.dll", "amdh265enc32.dll" and "amdh265enc64.dll" to your desktop. The files can be found in this folder: "C:\AMD\Radeon-Software-Adrenalin-2020-21.10.2-Win10-Win11-64Bit-Oct25\Packages\Drivers\Display\WT6A_INF\B372333"

5. Install the recent AMD Driver Package (22.9.1 at time of writing)

6. Copy the files from step 4 to this the folder named like or exactly like this: "C:\Windows\System32\DriverStore\FileRepository\u0383673.inf_amd64_8471f20f3f44a327\B383556". Overwrite the existing files. You may have to take ownership of the folder

7. Disable "Automatically adjust bitrate" in the "Virtual Desktop Streamer"-App if your Wifi is good. Set "HEVC" as "Preferred Codec". In the Virtual Desktop Settings try setting frame rate to 90, bitrate to 150 and set space warp to automatic oder disabled. Launch a game through Steam VR, open task manager and watch your network activity, it should show around 150 MBit/s upstream

Unfortunately, this does not solve the whobble/shaking or the low bitrate of Oculus Air Link. Air Link uses another dll, i think (amdenc64.dll). Using the old version of amdenc64.dll with the new driver does not work with Air Link.

Dear AMD, i like your products, but the low bitrate and the shaking when using a Quest 2 suck. Please fix this.

Virtual Desktop is fine but everyone seems to miss the FOV Tangent multiplier which isn't available with Virtual Desktop. Reducing the FOV multiplier can result in a considerable gain in performance which is essential for the best possible experience. I can go 26% smaller with my viewport without seeing the edges. It literally translates to 20-25% more performance and headroom. Apparently this can differ based on the application but I have quite a few titles and .74 horizontal and .74 vertical works perfectly for all of them. This itself makes Virtual Desktop a non contender. I'd rather swap my drivers or dual boot with old drivers and use Airlink rather than VDesktop.


It's been 6 months and they haven't even addressed the crippled bitrate issue. I've been through Oculus support ticket twice. NO RESOLUTION.

Oculus work fine if you are windows 11 clean and not if you have upgrade win 10 for win 11

driver Amd 22.10.2

Radeon 6700 xt


(sorry for ma langage, i am french)


Maybe your 6700xt is unaffected by the issue or you just don't notice it because you can't go that high with resolution.

The problem still exists in all drivers since March 2022.