Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

AMD not compatible

I recently installed the Samsung 860 EVO ssd and found that at times the system locks up for a few minutes. According to the Samsung utility 'Magician' there is a compatibility error: Driver AMD 'Under the current system environment, some functions in Magician CANNOT be run'.

I visited the AMD download page but couldn’t find an alternative driver for the SATA controller there. Not sure if I’m supposed to replace it with a newer version or find an older driver that is compatible. I tried updating the driver in win7 device manager but that returns a message that I’m using the most suitable driver.

The MB is Asrock 970M Pro3

I really would appreciate some guidance on this.


9 Replies

Kinda difficult to answer your post without the required computer information as per AMD Forum rules: INFORMATION REQUIRED WHEN POSTING A QUESTION .

How and what slot do you have your SSD installed on your motherboard?

Try installing AMD Chipset for the 9xx series Motherboards from here : Previous AMD Chipset Drivers .

Found a slightly newer version of AMD SATA CONTROLLER driver from Microsoft Update Catalog for Windows 7 here: Microsoft Update Catalog . Version AMD

By the way do you have the latest BIOS installed which the last one was version 1.60 from 07/16/2016 which suppose to help make the motherboard more compatible with hardware?



Thanks for your response, its appreciated. I’ve spent hours trying to sort this problem.

I changed the chipset driver that you recommended from to from the AMD link that you provided. Checked the Samsung utility and the conflict message has now gone. However, the problem is still present.

I’m thinking now that it may be a problem with the driver to the graphics card. I didn’t mention this initially because Samsung Magician has only highlighted this as a ‘recommendation’. The heading reads VID 1002: ‘Under the current system environment, some functions in Magician CANNOT be run. If multiple iterations of Read and Write are performed, RAPID mode may become inactive due to system internal errors on some of the AMD / AsMedia Controller or Driver’.

I’ve done some research on this today and find that many ssd users who have had this problem suggest that problem is with NVIDIA drivers. One thread that I read suggested uninstalling this driver and doing a reboot. I have tried this, it did change the driver but didn’t change the situation with the system locking up.

The existing graphics card driver is The previous driver (which I didn’t make a note of) came up as the ‘most suitable driver’ when I did a standard update in Device manager.

The SSD is connected to SATA1 socket.

Thanks for your help so far, I do hope that you can provide further assistance because I’ve run out of ideas.


Graphics Card: Nvidia GeForce 210

OS: windows 7 Professional 64-BIT

Monitor: LG E2442

MB: ASRock 970m pro3

Bios: 1.60

CPU: AMD FX-4300

Power Supply: Evo Labs 500CB: 500Watts

Ram: DDR3 8GB 133 MHz


You have a old Legacy Nvidia GPU card installed. The last Nvidia GPU driver for this card is from 12/2016 from which you can download and install from here: Drivers | GeForce .

LoL, is this you under PCSPIKE at : Correct Drivers for Samsung 860 EVO ssd - Windows 7 Help Forums ? Same Nvidia GPU card and Motherboard and SSD but no solution.

From ASRock Support FAQ concerning NVME devices: ASRock > FAQ

Question (Q&A-116|390): I cannot install Windows 7, 8 to my NVMe storage. What should I do?(3/1/2015)

Answer:Microsoft Windows 7 and Windows 8 do not bundle the NVMe driver, please install Microsoft Windows 8.1 or later versions to the NVMe storage.

Really old thread from 2011 but might help in troubleshooting. In BIOS do you have AHCI instead of SATA enabled? Adding an SSD to a Windows 7 PC | Technology | The Guardian .

This is  from your ASRock Manual concerning IDE/AHCI/RAID settings in BIOS:

This thread from might be useful: Another "my SSD is slow, help me PLEASE" post - Page 3 - - An Overclocking Community .

Try connecting your SSD to SATA 5 or SATA 6 slots and see if it makes any difference (Those slots are used for RAID setups).

Thanks for that. Will go through it all and see how I get on


I would highly suggest you open a ASRock Support Ticket and see what they say. If others are having similar problems maybe they might know what the problem is.

Or go to Samsung Support and open a Ticket with them and see if they have any suggestions on why their SSD is intermittently freezing.



Making progress now. I installed the NVMe driver yesterday and to date no more lockups!

I then turned my attention to AHCI mode. Everything regarding this is pointing to it being correctly set, Magician shows it as active and the Bios is set to AHCI. However when I ran some checks to confirm this they indicate otherwise.

Looking at your link in the Guardian, it states that: ‘Basically, Windows 7 and Vista don't load drivers for storage systems that are not being used, so if you change from SATA to AHCI it won't load the Msahci.sys driver needed to read the SSD’. The link in this article also shows the required changes to the Msahci.sys driver in the registry. I have made these changes but it doesn’t seem to have had the desired effect. I also tried changing the bios setting to ide and then a reboot.

I changed to ssd as a fried has it install and he tells me that boot-up is almost instantaneous, but I’m experiencing more like 50 seconds, sometimes longer. Operating in ide would account for this.






Don't change the SSD as IDE because it isn't an IDE drive.  That is why it is taking so long. The adjustment you made by changing the SATA slot to 6 and installing the NVME Drivers should be enough to solve your problems.

BIOS seems to be configured correctly and Magician showing everything to be good. so far.

The boot time has been 50 seconds from installation with the bios set to AHCI. Despite this, device settings is showing IDE as does AS Benchmark. 

As for changing the bios to IDE, was merely a trial attempt to see if windows would change from IDE to AHCI on boot-up after changing the registry as there was no change after booting with bios set to AHCI

Journeyman III

I have this problem too.

My 850 pro worked fine, 860 pro is freezing and gives event 129 port reset.

Its the 860 series thats the problem.