Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Adrenalin cause reboot PC in Flight Simulator 2020


Hello, a week ago I am having problems in FS2020 with resets after the simulator loading screen.
I have searched for solutions on the MSFS2020 forums where it is suggested to reinstall the entire system. Obviously I won't do it because all the programs work correctly but for some reason it seems that the latest Adrenalin drivers have problems with the sim

I have updated the BIOS, the drivers are all up to date, the same with Windows 11 pro and I see no reason for the program to start restarting from one moment to the next.

My setup: AMD Ryzen 9 5600X, 32G RAM DDR4 Corsair vengeance, Mother MSI X-570A pro, GPU MSI RX6700XT 12G, SDD Kingston 1TB X2 (M2), SSD Kingston 1TB SATA 6 and enough amount of coolers and watercooling. The system run as-is, no overclock, no undervolt, no overvolt at all.

After trying many configurations and not finding a solution in the two days that I could not fly and refusing to completely reinstall everything.

The easiest thing to try without having to reinstall the entire operating system, programs, download the MSFS again was to remove the video drivers despite the fact that with these that I mentioned in the request for help it was working correctly until now (without having updated any drivers and the only thing that was updated was only the SIM in the past update).
Lost for lost, I completely uninstalled AMD Adrenalin, rebooted and Windows 11 installed its own by default, which are version 27.20.21034.37 of 7/27/2021 (very old!)

Just in case I left out the COMMUNITY folder.

However, the SIM booted into safe mode, as it had reset itself many times on the loading screen before reaching the main menu.
I did a short flight of about 12 minutes (SAEZ - SABE) with the C152 without noticing failures

I rebooted the PC and booted into normal mode and repeated the flight with the Sim already in normal mode (still no COMMUNITY installed)

The next thing was to place this folder in the sim and repeat the same flight in normal mode. I tried both the C152 and the PA-28 Arrow IV that I have purchased. They worked without a problem.

The litmus test is then to put the previous Adrenalin driver to the latest, which is 23.4.1 from April 3 (where I know for sure that MSFS did not have any problems).

It worked smoothly about imagen1.pngfoto2.png

Obviously there is something that interacts with the Adrenalin video drivers and causes this failure since when I install the previous ones (second to last) where I know for sure that there were no problems I see that it works a couple of times and it restarts.
As I said, this started happening to me after the updates in the middle of this month (May 2023).
Using the control panel option to revert to the previous video driver (Microsoft’s) MSFS works normally again but it is obvious that I lose all the configuration facilities that Adrenalin gives me.

We will have to wait for both FS and AMD to find the problem.

4 Replies

Report the problem using the AMD bug report tool. If it's a problem with your OS, then you could try doing a repair upgrade, which will reinstall windows with the latest version while keeping your files and programs.

Asus ZenBook UX407IQ, Ryzen 5 4500u with Radeon graphics, Nvidia mx350, 8gb LPDDR4X ram, Samsung 970 Evo Plus 500gb SSD, Win11 home



Hi, friend. There was no solution, I have tried everything I found both on the net and in the official FS forums. I have also given notice there.
The strange thing is that it was working correctly and suddenly I found that blockage at the start of the program. I have tried the previous Adrenalin drivers (which I know for a fact worked because they gave me no problems at all) and to my surprise there were no results. Finally, already discouraged and thinking that I could not use the simulator again, it occurred to me to eliminate everything from AMD (video) from the control panel and let Windows put the generic drivers from the update. To my amazement they work perfectly, the video card does not heat up and I have not lost performance at all.
I can leave it like that for now but it's obviously a problem with AMD and its drivers from what I see happening after the May update of FS2020. A pity because it allows me to configure the board to my liking, but I'm not going to risk it again.
Thanks for your time


I have a similar setup... and the same problem.

Ryzen5 5600 (with a good air cooler not exceeding 60°C) + XFX 6700XT + 32gb Ram + MOBO AS Rock steel legend B450m + SSD NVME 2 Ultra 1TB Wersten Digital, and enough cooler.

No overclocking...


I don't know what to do.... nothing solves this problem.

I tried another clean install of Windows last week and only on FS2020 did I have this problem.