cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

tommmmy555
Journeyman III

5700 XT - Black Screen

I keep getting the dreaded black screen error with my new build.

I’ve tried a few suggestions from online research:

Use two power cables instead of one
Updated bios (was 6months out of date)
Remove MSI afterburner
Latest drivers

Anyone had a similar problem and resolved it?

I’m getting a bit annoyed and leaning toward returning it... if I can and getting a nvidia.

PSU is a seasonic 750w 80 platinum plus so I’ve ruled that out too.

Gigabyte Radeon RX 5700 XT GAMING 8GB

0 Likes
13 Replies
landolf
Adept I

Re: 5700 XT - Black Screen

Would be good to know the rest of your rig.

Had a similar problem with a new build, sometimes there was still sound, but mostly it was just both screens turning black and an instant reboot.

After changing GPU for another custom 5700 xt, changing PSU to a 750 platinum and every tweak I could find (2 different PCIe-cables for GPU, updated Windows, GPU drivers, reinstall drivers without setting any profile when installing, installing 5 different older GPU drivers and many more), I contacted AMD and told them what my problem was. 

For me, the solution was to change my memory. I have the 3800 xt which safely supports up to 3200 MHz, I was using 3600 MHz memory. After changing it in my bios to 3200 MHz, it was stable and the crashes were gone. I then changed to a 2x8 GB cl14 G.Skill Flare X, single rank (F4-3200C14D-16GFX) kit, got the timings a little tighter 14-14-13-28, so it was still safe according to DRAM Calculator for Ryzen. I even overclocked the GPU a little now, haven't had any problems since.

I hope that helps!

0 Likes
tommmmy555
Journeyman III

Re: 5700 XT - Black Screen

Hi landolf.

Thanks for your reply.

System details for you:

Seasonic Focus 750 Platinum PSU

Corsair 3600 16GB ram (XMP enabled to 3600.......)
Ryzen 5 3600 CPU

MSI X570 Gaming Plus motherboard

So... could be the RAM?

0 Likes
landolf
Adept I

Re: 5700 XT - Black Screen

If your tried everything else, I would give it a shot. I mean, it's easy to change, just set the multiplier in the bios to 32, check with cpu-z if it's running at 1600 Hz and play some games.

Have you also checked wether your RAM is compatible with your motherboard? (https://www.corsair.com/de/de/memoryfinder?type=motherboard )

0 Likes
mickeekung
Challenger

Re: 5700 XT - Black Screen

What is your window 10 version? 2004(20H1)?

0 Likes
tommmmy555
Journeyman III

Re: 5700 XT - Black Screen

Windows 10 Pro

Version 1909

Hopefully that's what you mean?

Fresh windows bought/installed about a month ago when I built it.

0 Likes
landolf
Adept I

Re: 5700 XT - Black Screen

You should check for an update, build 2004.

The newest optional gpu driver (25.x) is optimized for the current build. 

0 Likes
tommmmy555
Journeyman III

Re: 5700 XT - Black Screen

I do see a update in there. Going to try it a bit later tonight. Will post with the results.

0 Likes
tommmmy555
Journeyman III

Re: 5700 XT - Black Screen

Updated to 2004, had a black screen at the weekend.
Trying Windows reinstall this weekend (use it for work, so have to pick the right time).

0 Likes
tyrop
Adept I

Re: 5700 XT - Black Screen

I may have an answer.  I have a Sapphire Radeon RX 5700 XT, but the problem may be for any modern Radeon card.  I also have an X570 motherboard.  I have a similar problem where I get random black screens.  I hear sound for a few seconds and then the system reboots.  It seems to happen when the computer is idle or not under a heavy load.  Someone else posted a link to a video they found online with a possible solution and it worked for me.  I cannot find the post or the video, though.

The problem was that the video card actually does not work well with PCI-E generation 4.  (If you have a motherboard that does not have PCI-E gen 4, then this will not be your solution.)  

Many (but from what I understand not all) motherboards have a setting for the PCI-E slots that allow you to select the highest generation of PCI-E that it will accept.  The solution for me was to go into the motherboard's advanced BIOS settings and find the settings for the PCI-E slot where the card is plugged in. For almost everyone, it would be in PCI-E slot 1.   Change the setting from Gen 4 to Gen 3.  (From what I read online, we probably are not getting too much benefit from Gen 4 anyway). 

I have not tested this for more than a day, but I left my computer alone for hours, and it would have black-screened and rebooted.  It never did, so I think it worked.  

0 Likes