Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

4k 120Hz via HDMI on RX5700 broken since Driver version 22.2.3

I have a RX5700 and have not been able to upgrade from driver version 22.2.3 because that was the last time my setup was fully supported.

I have a SONY X85J series TV that is 4k 120Hz that I have hooked up as my monitor. With driver version 22.2.3 and using an 8k HDMI cable (no display port, have to use HDMI) I can run at 4k 120Hz by running color format YCbCr420 at 8bit depth without issue. See attached / below.

Since this driver version however whenever I install a new driver (I have tried each new version) I am limited to 4k 60Hz no matter what color format or bit depth I choose.

The issue seems to be (from the limited info shown via the utility) with the G.Pixel Clk (kHz). With the 22.2.3 driver it would run at 11880000, however with every driver since it is limited to 5940000... and if you try to create a custom mode based on the settings that worked with the 22.2.3 driver, it will warn you it can't do it when you attempt to set the G.Pixel Clk value.

Any chance someone from AMD will acknowledge this issue and either 

1) State that they will look into it and attempt to fix.

2) Tell me that folks like myself are not worth their time, go buy a different graphics card.

It's not like the card can't support this setup, it did up to driver version 22.2.3... someone in the driver team broke this support, and I'd appreciate knowing if it will eventually get looked at because it is never mentioned in the drivers known issues despite it being discussed previously.


22.2.3 working at 4k 120Hz22.2.3 working at 4k 120HzNewer driver limited to 60HzNewer driver limited to 60Hz22.2.3 reporting 120Hz support22.2.3 reporting 120Hz supportNewer driver limited to 60HzNewer driver limited to 60HzNewer driver preventing G.Pixel Clock kHzNewer driver preventing G.Pixel Clock kHz





0 Replies