Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

21.4.1 crashing problem

T oday i updated my driver and games have been crashing after a few seconds of gameplay and if i initiate a stress test on the amd radeon software the screen goes black and the amd software recognizes it as a timeout. Tried downgrading and the same thing happens, also tried cleaning up but no luck.
42 Replies
Adept I

I have the same problem!

tried too to install previous driver but did not work as well. My screen sometimes go black and if not i see black squares popping up randomly on the screen. If u find a solution let me know asap

Adept I

I have the same problem!

tried too to install previous driver but did not work as well. My screen sometimes go black and if not i see black squares popping up randomly on the screen. If u find a solution let me know asap


same probleam i  install previous driver 23.12.1 now it fixed 

Adept I

It's happening to me, too. But only in versions 21.3.1 and 21.4.1. When I install 20.11.3, all issues disappear instantly. 

With 21.3.1 and 21.4.1  I get crashes (while not doing anything in the windows explorer) or even artifacting squares with patterns all over the screen. Freezes and such. The most common is that it freezes, then the screen goes black and then it recovers. When I'm gaming, nothing happens. Everything works normally under load... I'll just stay in 20.11.3 for the time being until the next version to check again. (Relevant info: I'm using an rx590 fatboy).


i have the same problem

After installing 21.4.1. new drivers had this errors...and crashing 

Faulting application name: Radeonsoftware.exe, version:, time stamp: 0x6075cb03
Faulting module name: Radeonsoftware.exe, version:, time stamp: 0x6075cb03
Exception code: 0xc0000005
Fault offset: 0x00000000001685f0
Faulting process id: 0x3418
Faulting application start time: 0x01d73b6e24600e36
Faulting application path: C:\Program Files\AMD\CNext\CNext\Radeonsoftware.exe
Faulting module path: C:\Program Files\AMD\CNext\CNext\Radeonsoftware.exe
Report Id: a78ff769-4409-4ecb-9e15-d9e63fc45b32
Faulting package full name:

Im a newbie here, so you saying that i must delete these files?


Same issue here with my RX 580: after installing 21.4.1 drivers, I have the same exception code (0xc0000005)

With drivers 20.12.1 everything works just fine!

I installed the driver 21.4.1 and i have same problem 
I have random blue screen and if i open the app i have instnt a blue screen


Try this fix also I am working on another video I found another problem I will post that soon


Thats all a crap...


I never updated windows 10 for a **bleep** long time, so the problem has nothing to do with windows. The problem only started when AMD broke the drivers like 3 or 4 updates behind and they even had it in the known problem list, but somehow on recent updates it's not listed anymore and never went to the fixed list...


Then who uses AMD utilities? I guess we all use the DDU in safe mode for many years and before it we had other...


My Drivers are always on default settings, never even used gaming mode, I have AMD Freesync and all features OFF.


And the only solution is to roll back a few updates ago and loose all the latest gaming performance improvements sadly.



problem is the windows and AMD drivers we did not had this issue until windows 10 start to update and add more **bleep** that we do not need for gaming. lot of them taking our Ram and HDD and CPU . also windows 10 force ppl to update it because it connect AMD software with it services they reason you need to use old AMD drivers because you did not update you windows . I bet you have lot of lags and FPS drop at this moment  or barely getting 60 to 70 FPS. 

also if you turn off you update without using the software that I use windows will update itself if you like it or not. 


this is happening to me too. i've had my RX580 for almost 3 years now and have had zero issues until the last 2 updates...crashes every 5 minutes now with Chrome even.


Same issue but only on Chrome. Happened with last 2 updates and this one ran fine for like 15 days and I just got a t/o watching Youtube and playing WoW. First time I got it playing so I believe is a browser issue. I think that turning off Hardware Acceleration helped me (I got it on on Friday to use on Roll20). 

I read somewhere else that installing just the driver (and not Adrenaline) helps too. 

"I read somewhere else that installing just the driver (and not Adrenaline) helps too."

I can confirm that: installing just the driver works fine. Installing the "minimum" did not give me any trouble for some days, until it did. That's when I decided to install windows all again from scratch because I thought that maybe the previous driver (in version 20.11.3) had left corrupted files behind or something, but nope. Even after a clean installation, version 21.4.1 was still causing trouble. This is why I decided to stay in 20.11.3
Journeyman III

Almost returned a new build because of this issue. Just upgraded my A8-7600 to a ryzen 3 3100 with new motherboad and set of ram. I was using an MSI aero RX 560 with my old A8-7600 pc with radeon 21.4.1 installed, it was working fine, didn't have any crashes. After changing hardware though, the crashes started happening. I did not do a fresh install of windows 10 and I thought it might be the issue. Did a fresh install and it still the same. Good thing I tried radeon 20.11.2 before returning cpu, motherboard and ram.

Journeyman III

I have a brand new 6700xt and had to roll back my driver to 21.3. 21.4 crashed every few minutes when starting a game. I uninstalled and reinstalled several times, same crashing. I even unistalled the games and reinstalled, no luck. The 21.3 driver does not crash at all on my system. 


general rule, if it works, don't touch; unless it's to fix a bug or an improvement for something you do/play

Journeyman III

same problem with me, the only thing that fixed the issue was to completely format my pc. I'll never buy amd gpu again, every update there's always an issue not like in NVIDIA. tsk3


Just purchased a 6900 XT. Crashing every time i load a game. 

It's going back for a refund. Won't make this mistake again.


I installed Auto-Detect and Install Updates for Radeon™ Graphics and Ryzen™ Chipset Drivers for Windows at

I ran the repair/reinstall option and so far I haven't had any timeouts for the last few days.

Journeyman III

same problem with me, the only thing that fixed the issue was to completely format my pc. I'll never buy amd gpu again, every update there's always an issue not like in NVIDIA. tsk3

Journeyman III

Hoo boy did I have this issue.

Before updating, 21.3.1 and 21.3.2 were working fine (as well as previous [official] versions up to this point). I've not had any problems with updating yet, and this PC was built nearly a year ago. Everything has been going smoothly with my system.

But then I updated to 21.4.1 and all hell broke loose.

Everything seemed fine when I initially started up AC Odyssey. Then about eh, twenty minutes into it? or so, a crash. Black screen, driver timeout error. Started it up again, went to the same general area, attempted to walk to my marker, and it happened again. Tried again, saved at the fast travel location near my marker, spun my camera around to where I would have been looking west, and bam. crash. Was able to reproduce that at the same location each time. Thought it was just the game at that point.

Gave up with Odyssey then went off to try AC Origins. Ran fine for about an hour and while in the middle of a quest, bam. crash. Same symptoms as with Odyssey. Now Origins got a little random at times, but was eventually reproducable each time. Sometimes while loading the game and before getting to the menu, it'd crash. Sometimes it'd let me load into the game, and once the game world finished loading up around me, it'd crash. And then, if I was lucky, and got past that on another attempt, as soon as I'd hit a key/button, the game would crash. Each time would produce the same symptoms. Black screen, driver timeout error.

I was also having similar issues with AC Valhalla, but I didn't test that one as much as I did the other two. Those two were more than enough for me to troubleshoot with, tbh. This was an all day headache. Did have the same black screen + driver timeout error combo though.

I then eventually reverted back to my previous drivers (21.3.2 and 21.3.1), and was getting the same problems with both. I never had issues until I installed 21.4.1, even though I had them installed at one point before this latest update. Using DDU to remove all traces did not change things (and yes, safe mode method was used). I even used CCleaner to see if maybe DDU missed something. Even made sure to set the driver re-installs to factory reset. Even looked into Windows updates and I didn't have any offending ones. Nothing was working. Nothing was making sense.

I gave up with those 21* versions and eventually used DDU again and installed 20.11.2 since it's got Valhalla support. Have had no issues since, and both Origins and Odyssey are now working again without any issues whatsoever. Haven't tested Valhalla yet, but I'm at this point in time, done with testing right now.

I hope this gets resolved. Have a Sapphire PULSE Radeon 580 8gb model in my case (heh. pun.).


I crash everytime with this driver too.

Crashs happens very often when I'm on the desk or using my web browser.

When I'm in a game it doesn't crash, except when I try to change the sound.

Strangely it looks like it doesn't crash when I'm using my desktop after playing a game.



Have you guys turned off freesync, both in adrenaline and on the monitor itself?

Try it and get back to me.


The Radeon Software is showing FreeSync as disabled on my PC.

I setup a brand new PC a couple of days ago with Radeon RX550 and Ryzen 5 3600 installed by PC Specialist. The first day it ran without any issues. I then updated all the software that came with the PC. Radeon Software identified and installed 21.4.1. Since then, each time I start my PC after a minute or two my display freezes, the screen goes black and I am given the option to report the timeout to Radeon.

This error happens when I am just looking in Outlook, browsing in Firefox or even with no apps open and just viewing the desktop. I am a novice when it comes to PCs and it has been stressful enough setting up my new PC without what appears to be a major driver fault. My old PC had an AMD graphics card and never caused a problem in 10 years. After this, I won't buy AMD again.


I did update the drivers using AMD Software - that’s what updated it to 21.4.1. These are the latest drivers. Why would my RX550 freeze for several seconds with a black screen and error report just a few minutes after start up with Outlook, internet browser or just my desktop open?


Guys I have a temporary and permanent solution.

Please NOTE:

given you dont have any problem with psu, and memory and some other hardware and you are sure that the gpu or driver is the problem try the method below and get back to me. 

And please tell me if it is work for you or not so we can help each other.

Sorry for bad english or wrong grammar. English is not my native language.



Go to performance then tuning.

Adjust your freq state 6 and 7 to 

BASE CLOCK "its depend on amd card"

Search your gpu specs and you will see it 

The easy way is, take the slide clock freq to 

" -8 to -11 " make your way from -11 much more stable to -8 "sweet spot" 

Take not the lower number -11 is much stable than -8.

If you are stable on higher number posible -8, and make a rigorous test.

Its not gonna hurt to test it to higher number -7, -6, and so on untill you make iit crash again,

Take note the lower its NEGATIVE number the higher the value. If you confuse when i say -8 is higher than -11.

Ok , obviously 0 is the default value.

As you can see amd gpu have boosting features, its like an over clock that's why its unstable.

You can also include it with aggressive fan curve, but first test it with all default value other than freq. Slider.




My exp.


I alway crash on SCAVENGERS, 


Temp is not a problem.

60 to 72c,  while playing.

So far I test -6 on freq, and sometimes it crash, but this time i can play 2-3 games onscavengers before its crash, in deafault setting i will insta crash 2-5 mins in game.


Now i test -11 i play a lots of warzone and scavengers around 10pm to 2am without a single crash.


If your card is not on warranty and willing to take a risk.

Another thing is replacing the thermal pad and thermal paste, as reported from others they replace thier thermal paste and pad and now working properly and with the default setting , boost or auto oc even though its not officially state that boost is actually oc.

Oc mode is much higher oc as far as i understand it.

I did not replace my thermal pad and paste as of now. Im satisfied and for now i dont have time and items to do the job.


Reason behind this thermal pad or paste is that by factory sometimes the VRAM of gpu is not properly cooling, we cant see it to gpu sensor , the temp we see is on gpu core not its vram.

Its all base on my research and as i said above i did not replace my thermal paste or pad as lowering my freq from -6 to -11 solve my crashing issue for 4 hours i dont know if its hot like in the morning, but so far, 4 hours of playing give me a good result. Cod and the notorious crashing game in my case, scavengers. 

Before you replace your thermal pad. Or paste be sure you have a proper pad thickness different gpu have diffirent pad thickness make sure its a quality one. 

Sorry for a very long post, but i hope i helped 1 or 2 people out there, it will.make me happy!

Please report back if you try these so we can help someone. ☺️

Now for the finally!!!


Permanent solution:

Sorry to say but we should buy NVIDIA and avoid AMD Cards,


Yes its cheap and powerful vs their competitor but its really unstable, 


I hope i helped someone.


Please update me!!


Same here with RX580...


I think it started on 21.3.1, can't even remember.

AMD known Problem list for AMD 21.3.1 "Radeon RX 400 and 500 series graphics products may experience a TDR during extended periods of video playback."; 21.3.2 = same.


Then AMD removed it from the known problem list on later updates, but never shown up in the Fixed list either, so it's like AMD just removed it from this planet and didn't also fix it...


After updating here like 3 or 4 updates ago it started the same problem. My PC just keep crashing on firefox web browser randomly, almost all games crash and I updated every time they made a update after and I'm currently on last update and nothing fixed it, just get less crashes on Firefox and are faster to recover and almost all games keep crashing the same way making it impossible to use this GPU broken by AMD again for like the hundred time since I bought it...


Already used DDU on safe mod and remove all AMD stuff, already tried the full clean install from AMD driver too, same thing, nothing fixes it...

Journeyman III

I got got the same issue. 



It’s pointless to try establishing a new era for your you power and having them crippled by your drivers. 

I got a RX5700. Normally runs the Rainbow Six Siege at 2k/230fps in ultra graphics settings. BUT especially since the update, the game crashes during the match and a window pops up indicating that ‘there is a driver timeout’. Following the obvious steps, i found out from windows reporting error system, that Radeonsoftware.exe was crashing unexpectedly creating all these game crashes.

Of course i DDU and reinstalled the latest recommended adrenalin like a million times.

Of course i tried everything in the nature of reinstalling and installing back.

And i come back to my original question:

Why can’t you at least, support your own GPU? I’ve always disliked NVIDIA, but at least they keep their costumers happy, long after their purchase. Please don’t make me choose something i don’t want. 

P.S. I hope to fix all the issues with RX5700, so one day i can download and use the drivers without always having to tweak something…..

Never had a single problem with my older Nvidia Asus GTX570 DirectCu II (Massive 3 slot cooler), it did around 25% OC over stock clocks with 1.2 Vbios flashed at 60% fan which isn't even much noisy, was hitting just around 80Cº max even with the massive OC and was giving me above 1.8 Tflops instead of the stock 1.4.


When I went for AMD all the problems started including black screen not even being able to go to the bios as UEFI wasn't Working, had to put back the Nvidia to change bios to Legacy...


Then back with the AMD, bad texture problems on grass and many other stuff even until now and a lot of ppl also have the same issues across multiple different AMD generations and was never in the known problem list even with many reports.


And the worse was really that I only had to wait almost 2 years to be able to use it because drivers were broken and nothing would play since was all Crash to Desktop, BSOD, Green screen of death, Red screen of death... Even sent it to RMA for Asus and came the same GPU saying it had no problems and they stole my box and accessories since the store sent the original case and should have been a cardboard one even though that still very bad practise from Asus.


AMD sadly broke it again for like the hundred time already while I never had a single problem with the Nvidia for many years even at Huge OC and maximum voltage with custom bios to allow more voltage, it's still working...


Yeah, AMD is dropping the ball heavily with these blunders.

I have a 5700xt running stock, only non-stock setting is extra 15% speed on fans, to keep stuff nice and cool.

Gaming works fine, but I'm also a content creator and get this: no serious video editor works currently on my 3500$ Pc...
The amd graphics driver crashes under davinci resolve, and hitfilm as well. Basically same issues that you describe with gaming.

This f*cks me harder than anything, because my worksation is basically not usable for one of the main reasons I have it.

2 months ago I had to stop for a month because my 5900x cpu was defective and rebooted the pc randomly due to interconnect errors. To be fair AMD sent me a replacement (which is a bit slower, one of the ccx doesn't even boost up to 4800mhz), but at least it's working.

Now of course it is the gpu acting like a little bitch... But no worries I think to meself, GF also has a radeon 580, I'll just edit on her rig for a while. SAME F*cking problem on that pc as well... How these drivers pass QA is beyond me.

I have managed to buy a 6800 a week ago (for a fortune, mind you), it's arriving soon, but at this point, I don't even know what driver I would install on it. If that's going to give me trouble, I'm going nvidia. I'm practically holding video production for almost 3 months now due to AMD **bleep****bleep**ery.


If at all possible, install 20.11.2. Ever since I installed that version before I made my initial post here, I've had no issues with it since I did that myself.


Granted, we shouldn't have to bloody downgrade but ya know....


OP have you tried using the AMD driver removal tool on their website?  It will purge all gpu drivers from your system and once done  you can reinstall the driver.  I had to use it tonight on a clean install when the adrenalin control center started malfunctioning and after it was done everything started working normally.


DDU is for that already...


Anyway AMD just updated drivers and once again I see nothing in the fixed list neither on the known problem list...


Won't even bother updating to this one

I updated to 21. 5.2 and it provided a slight uplift in my Time Spy score plus the control center still works.


then I will try it later since performance dropped for a few GPUs on the latest one before that one...


I made an account just to discuss my own experience. I started using Davinci Resolve (Free) in August/September of 2020. I eventually lucked out and snagged a 6800 XT. I have spent 10s of hours dealing with crashing in Resolve, all due to AMD's drivers and Black Magic's "we don't care about AMD" mindset. Now, 6 months later, the ONLY driver that works with Davinci Resolve and AMD graphics cards appears to be the November 2020 WHQL release (20.11.2). I've tried close to a dozen different versions over the last 6-7 months. Everytime I've updated drivers, which greatly benefit some games I play, it completely breaks Davinci Resolve and I'm forced to go back to 20.11.2. I've tested this on two separate all-AMD rigs, one running a 6800 XT + 5900x, and one using a 2700x with 5700 XT. Can totally replicate on both machines using any drivers more recent than 20.11.2.


I eventually bought Davinci Resolve Studio as I love the software and the included Speed Editor they gave out for 17 preorders was too good of a deal to pass up . I will tell those of you who may be considering upgrading that this bug is still present in Studio, and made no difference on my ability to use the program. Another thing worth mentioning, that once I have upgraded, in order to return to 20.11.2 I have totally strip my AMD drivers (using DDU), AND reinstall Davinci Resolve after downgrading the drivers. This process seems required every single time, and has become my go-to after dozens of hours of trying to troubleshoot this issue, both on my own and with Davinci Resolve. I am an IT professional with about a decade of people paying me to fix problems like this. At this point, I'm appalled at how little effort both AMD and Black Magic are putting into compatibility, especially considering AMD's workstation cards are out now.


Anyways, I know this was a long post. Hopefully it helps someone out there. If anyone else knows a better way to fix, please let me know!


Summary of steps to resolve crashing with AMD and Davinci Resolve

DDU AMD drivers


Install 20.11.2 WHQL drivers


Reinstall Davinci Resolve (may need to do a "clean" install, can find the process elsewhere)


It should now work, I've replicated this process a bunch of times on two separate workstations. It's a huge PITA, so upgrade your drivers sparingly and hopefully avoid this pain.


I want to update on my case.


I was having the same issue as pretty much everyone in this thread. Version 20.11.3 works perfectly, but version 21.4.1 was giving me artifacts and crashes all the time. I'm now on version 21.5.2 (optional, which used to give the same problems as 21.4.1) but I read somewhere that if you update Windows 10 MANUALLY, paying especial attention to optional updates, it should fix most of the problem.


I did that, and I haven't had any artifacting ever since, but I HAVE still had freezes every now and then (around once a week or so).