cancel
Showing results for 
Search instead for 
Did you mean: 

Blender Discussions

fabrizioboni
Adept I

Where can I download 2.0 version?

I accidentally installed the 2.1 version on catalina, and it is practically unusable (continuous crashes). How can I get back to 2.0?

Tags (3)
6 Replies
emildrahos
Journeyman III

Re: Where can I download 2.0 version?

Same issue, I have version 2.1.1 on Catalina and it crashes pretty much all the time. (AMD Radeon Pro 5500M)

bsavery
Staff
Staff

Re: Where can I download 2.0 version?

What are the errors?  Can you start Blender from a Terminal and post the issue here?  

fabrizioboni
Adept I

Re: Where can I download 2.0 version?

Hello and thanks for the reply, I hope it's enough:

found bundled python: /Applications/Blender.app/Contents/Resources/2.81/python

RPR Core version 0x103404

Image Filters version 0x41000020592f2f8

Plugin is registered: plugins=[0], cpu_device={'flag': 16, 'name': 'Intel(R) Core(TM) i7-7820HQ CPU @ 2.90GHz'}, gpu_devices=[{'flag': 1025, 'name': 'AMD Radeon Pro 560 (Metal)'}]

Material library located at /Users/Shared/RadeonProRender/MaterialLibrary/2.0.0/Xml

2019-12-05 09:03:55,453 WARNING rpr.export.node [123145561673728]:  TexCoord Generated output is not supported, UV will be used <bpy_struct, NodeSocketVector("Generated")> <bpy_struct, ShaderNodeTexCoord("Texture Coordinate")> <bpy_struct, Material("Material.003")>

2019-12-05 09:03:56,190 WARNING rpr.export.node [123145561673728]:  TexCoord Object output is not supported, world coordinate will be used <bpy_struct, NodeSocketVector("Object")> <bpy_struct, ShaderNodeTexCoord("Texture Coordinate")> <bpy_struct, Material("Material.002")>

2019-12-05 09:06:39,549 WARNING rpr.export.node [4587945408]:  TexCoord Object output is not supported, world coordinate will be used <bpy_struct, NodeSocketVector("Object")> <bpy_struct, ShaderNodeTexCoord("Texture Coordinate")> <bpy_struct, Material("Material.003")>

objc[8778]: BronzeMtlCmdBuffer object 0x7fdf5ee9b200 overreleased while already deallocating; break on objc_overrelease_during_dealloc_error to debug

Abort trap: 6

Thanks

 

0 Likes
bsavery
Staff
Staff

Re: Where can I download 2.0 version?

Hi there.  Is there some chance you're disabling gl_interop in config.py?  That's the only time I've seen that error.  Otherwise I have the same hardware and OS here.  And it works fine.

0 Likes
fabrizioboni
Adept I

Re: Where can I download 2.0 version?

I enclose a video, hoping it's useful

In this case the error is different and is generated when I scale the viewport, but blender crashes even when I modify the nodes through the value slider (without entering numeric values)

gl_interop in config.py is set on true

MacBook-Pro-di-FabriTricky:~ fabritricky$ /Applications/Blender.app/Contents/MacOS/Blender 

Read prefs: /Users/fabritricky/Library/Application Support/Blender/2.81/config/userpref.blend

2019-12-05 21:43:47.500 Blender[995:19143] apply_selection_policy_once: prefer use of removable GPUs (via org.blenderfoundation.blender:GPUSelectionPolicy->preferRemovable)

found bundled python: /Applications/Blender.app/Contents/Resources/2.81/python

2019-12-05 21:43:48,733 INFO rpr.core [4821589440]:  RPR Core version 0x103404

2019-12-05 21:43:48,749 INFO rpr.core [4821589440]:  Image Filters version 0x41000020592f2f8

2019-12-05 21:43:48,751 INFO rpr.default [4821589440]:  rprsdk_bin_path: /Users/fabritricky/Library/Application Support/Blender/2.81/scripts/addons/rprblender

2019-12-05 21:43:48,751 INFO rpr.core [4821589440]:  Registering plugin with: tahoe_path=/Users/fabritricky/Library/Application Support/Blender/2.81/scripts/addons/rprblender/libTahoe64.dylib, cache_path=/Users/fabritricky/Library/Application Support/Blender/2.81/scripts/addons/rprblender/.core_cache/0x103404

2019-12-05 21:43:48,779 INFO rpr.core [4821589440]:  Plugin is registered: plugins=[0], cpu_device={'flag': 16, 'name': 'Intel(R) Core(TM) i7-7820HQ CPU @ 2.90GHz'}, gpu_devices=[{'flag': 1025, 'name': 'AMD Radeon Pro 560 (Metal)'}]

2019-12-05 21:43:48,855 INFO rpr.material_library [4821589440]:  Material library located at /Users/Shared/RadeonProRender/MaterialLibrary/2.0.0/Xml

Read blend: /Users/fabritricky/Desktop/cactus_c.blend

2019-12-05 21:44:12,626 WARNING rpr.export.node [123145471213568]:  TexCoord Generated output is not supported, UV will be used <bpy_struct, NodeSocketVector("Generated")> <bpy_struct, ShaderNodeTexCoord("Texture Coordinate")> <bpy_struct, Material("Material.003")>

2019-12-05 21:44:13,086 WARNING rpr.export.node [123145471213568]:  TexCoord Object output is not supported, world coordinate will be used <bpy_struct, NodeSocketVector("Object")> <bpy_struct, ShaderNodeTexCoord("Texture Coordinate")> <bpy_struct, Material("Material.002")>

2019-12-05 21:44:28,118 WARNING rpr.export.node [123145471213568]:  TexCoord Generated output is not supported, UV will be used <bpy_struct, NodeSocketVector("Generated")> <bpy_struct, ShaderNodeTexCoord("Texture Coordinate")> <bpy_struct, Material("Material.003")>

2019-12-05 21:44:28,543 WARNING rpr.export.node [123145471213568]:  TexCoord Object output is not supported, world coordinate will be used <bpy_struct, NodeSocketVector("Object")> <bpy_struct, ShaderNodeTexCoord("Texture Coordinate")> <bpy_struct, Material("Material.002")>

Writing: /tmp/cactus_c.crash.txt

Segmentation fault: 11

I hope it was useful

0 Likes
bsavery
Staff
Staff

Re: Where can I download 2.0 version?

Hmmm, ok that is useful.  Thanks We'll take a look.