Showing results for 
Search instead for 
Did you mean: 

Blender Discussions

Journeyman III

Prorender keeps crashing on macOS

I downloaded radeon prorender so I could render with my gpu on my Mac since OpenCL isn't supported. However it keeps crashing sometimes before I even click render. Occasionally works on low samples but very temperamental. 

My computers specs are:


-2.6 GHz 6-Core Intel Core i7


-16 GB 2400 MHz DDR4


-Radeon Pro 560X 4 GB

- Intel UHD Graphics 630 1536 MB

11 Replies

What are you selecting for render devices when you render?  Also which macOS version and blender/plugin version


Im using os 10.15.1 with blender 2.83 and the latest version of prorender. I normally kept the device on both my cpu and graphics card and when I tried to switch to only one of them blender slowed down and I had to force quit it.

Journeyman III

I am having the same issue with a 2019 iMac, with an i9-9900 processor, 64GB ram and the Radeon Vega 48. 

When in MacOS (the latest version) i can render single images but when i render an animation (as frames) it does one frame and then while initialising for the next, blender crashes consistently from blender 2.83 - 2.82a, i tried it with 2.81 but i got artefacts on the left side of the image with the right hand side totally fine (weirdly, wondered if this will help troubleshoot the source of the problem for developers)

I have run the same file on macOS using Evvee and it worked perfectly, and using bootcamp i am using Prorender in blender 2.83 on windows 10 and is working fine with no crashes while rendering. 

Hope this can be fixed as the frames are actually rendering slower in windows 10 so would like to get back on macOS.



Hey Guys.  Try with just GPU rendering.  

Ahhh, that much better, I read up on it on AMD website and cpu + gpu rendering only works when an AMD CPU+AMD GPU are used. 



It is better. It doesnt crash but it renders out glitches.

2,6 GHz 6-Core Intel Core i7

16 GB 2400 MHz DDR4

Radeon Pro 560X 4 GB

Intel UHD Graphics 630 1536 MB

eGPU radeon 580

Journeyman III

Hi, I got this week a complete new MacPro with the 16core processor and one W5700 videocard. I installed the newest 2.83 Blender version and the most recent version of AMD Prorender. Different attempts to render a single image or a animation have the same result: the system crashes. What is going wrong?

Journeyman III

Problems were caused by older projects using the material shaders for the cycles-rendermode.

Adept I

Not sure if I should make another thread but I've found that RPR crashes pretty regularly when working on a standard scene like Blender's Barcelona Pavilion.

It is after I've switched the renderer to RPR and start changing the settings. Specifically — and I'm not sure if this feature uses RPR or Cycles — it happens most often when switching back and forth between a render preview in the main viewport. If I don't ever attempt to use the viewport preview render than the crashing is less frequent. But otherwise I can expect it to happen 3-4x a day. The steps looks something like:

1. Launch Blender open the blend file, set the scene switch to RPR

2. Change RPR samples, quality, add sun-sky, set those.

3. In the viewport switch to render preview mode to see where the shadows are falling, if light it too bright etc

4. Switch back to non-preview mode, then render.... result doesn't look right, cancel

5. Go back to render preview in viewport change more settings, then switch off the preview again

6. render

7. iterate 3-6 until crash occurs

What I'm not sure of is whether if using RPR, and choosing a render preview, that preview is being generated by RPR engineor by Eevee or something else. Maybe this is not RPR but an Eevee bug.

macOS 10.15.6, latest Blender LTS build, current RPR and material library versions (downloaded a couple weeks ago). MBP14,3 with AMD 560 dGPU. Later plan to test with eGPU.


So, just on a higher level, your workflow seems a bit strange.  Can't you stay in the viewport preview mode and iterate on lighting until it looks correct?  Why not? 

Otherwise it's a bit hard to diagnose


The reason for the extra steps was that the Render Preview mode did not look the same as what I saw in the render window, but it was close enough for things like evaluating the position of sun and shadows. Later I found in documentation that the preview does use the RPR engine not Eevee, so the difference may have been due to incompatible nodes or materials in the scene file that were getting baked during render but not preview, not sure as I'm relatively new to Blender + RPR.

Off-topic but related to above: all of the scenes I can find for real world testing are built for Cycles; it would be awesome if AMD built a page with a few different test scenes where everything in the Blend file works with RPR (uses Uber Shader etc). Most of the downloadable items in the guide are very simplistic / not something on the level of a typical archvis or other complex scene with a variety of lights, surface material types, shader instances, etc.

Going back, I looked into this crashing more and I believe now this is a known Blender bug, specific to macOS. To be more clear, at Step 4, on the occasions where things crashed I believe I was jumping back to the Material / Shader preview mode in the viewport. According to the bug info, that specific mode seems to cause the crash, whereas jumping back to Solid or Wireframe mode does not crash the app, all else being equal.