Showing results for 
Search instead for 
Did you mean: 

Blender Discussions

Adept II

How to install proprietary GPU driver Radeon Pro (Manjaro, Arch linux)

Can anyone help me install a proprietary video driver for "Radeon Pro W5500" in Linux Manjaro?

Hello! I have two related problems for which I have not found a solution. The topics are either quite old or blurred in the sequence of actions.
Please help to configure the video card.
Operating System: Manjaro Linux
KDE Plasma Version: 5.26.4
KDE Frameworks Version: 5.101.0
Qt Version: 5.15.7
Kernel Version: 6.1.1-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 24 × AMD Ryzen 9 3900X 12-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: AMD Radeon Pro W5500
Product Name: B550 Pro4
Unfortunately, I don't quite understand how MHWD works and without it, I can't do it correctly, I just don't understand how...

I tried different versions of AMDGPU and PRO driver installation from AUR, but MHWD does not use them or does not see them. How to do it?

The point is that I need Blender, but it does not see the video card on the free driver.

There is one topic for this question, which allegedly found a solution, but there is no modified driver file, and the manual is not clear to me.

There is a driver on the official AMD website, but I did not find how to install it correctly, I could not find how to do it in Arch.

How to do it?

14 Replies
Journeyman III

It's good jobs

Here is ArchWiki explaining how to install AMDGPU Pro:

If that does help then try this popular Linux forum Phoronix: AMD Linux - Phoronix Forums 

AMD Moderator for Professional GPU Card might be able to assist you or give his opinion using the W5500 Pro GPU card. 



No, the first link doesn't help, I already tried all available solutions. As many as I could find online. I think that AMD, as a distributor of free driver, should take care of this problem, this is not an amateur segment of video cards, but looks like "AMD Radeon NOPRO W5500".

And in this situation, I think in the section of the official driver, it should be written "Only for" X "-Linux".
Can't it be made more generic? A whole team is working on this! And such a technically narrow nuance is far from the average user, such as a designer.

You can push it to industrial use, where equipment is configured by experts in this field, but I think that this is a bad excuse.

In my case, of course, it probably depends on the support of the blender itself, but the problem is not only with it, but in general! It turns out that product support is at a low level. Perhaps this video card is already considered obsolete for improvement, but I hope that in the future more attention will be paid to the PRO segment.

These dances with a tambourine and the attitude of rapid obsolescence are very upsetting ...

I'll look into the second link, thanks.

I see in another Thread FSADOUGH is already helping you with Manjaro Linux.

I have no solution at the moment, will try Ubuntu….

did not help

Maybe I don't understand something, or... I don't know.

Installation manual for ubuntu, consists of two lines.
This did not help me, I rummaged through the Internet, I did not come up with a solution.

Ubuntu simply does not see the proprietary AMD driver, although it is installed!

It seems to be the same as on Manjaro


The instructions below are very clear and easy to follow:

And the driver for Ubuntu can be downloaded from:


It's all wonderful, of course.
But none of the instructions helps to see the video card in Blender, and it does not see the processor either. True, on Linux it may not be important to display the processor, I'm not sure. But no matter what I try, it doesn't help...

All last night I fought with the official manual from HIP, we expect the result, nothing!

I have doubts that ASRock motherboards are not compatible with Linux, this was exactly the case on the previous hardware, none of the distributions could work on the AB350Pro4, there were crashes, freezes, freezes and overheating.

On the B550 Pro4, this is much better, but it is possible that there is a problem here too.


My response was related to the topic of the thread. You complained about not being able to install AMD Linux drivers for W5500. Now, you bring up a different issue. Latest Blender uses HIP and for that you need to install ROCm when the OS is Linux. W5500 however is not supported by ROCm. If you need to work with Blender using W5500, you need to switch to Windows OS. If you insist on the combination of Linux and Blender then you need to change your GPU to W6800 or Radeon Pro VII.


Adept I

On straight arch it's just installing them from pacman or AUR and setting it up to use it instead of the MESA stack.

Please use a separate thread for your issue

Hello, when are the new enterprise drivers coming with huge leaps in performance gains and the new OPENGL and vulkan extensions found in the newer Adrenalin drivers?

Almost 3 months now, no new driver. thanks. 

ISV certified driver will be released first week of August