cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

asylum29
Adept II

[SOLVED] OpenGL "hidden bug" related to VAO - shader signature relationship

(edit: ignore this post; since the AMD driver didn't optimize out the input attribute it obivously works)


First I thought, that this is an Intel bug, therefore the repro sample's name is "51_IntelBug". But it turned out, that the Intel driver was right.

What I'm doing is very simple: I use a shader with a VAO where certain input attributes are disabled (it relates to caching VAOs, but you don't have to deal with that).

Repro source code: Dropbox - AMD_hidden_bug.zip

The point is, that you shouldn't see the 4th quad, as the gx_TexCoord0 attribute was never enabled in that VAO.

On my R7 360 I see it (bug!!!), while on the Intel HD 4600 and 530 it's (correctly) invisible, as the vertex shader doesn't fetch the texture coordinate (instead fills it with zeros).

This is the INCORRECT image:

incorrect.jpg

0 Likes
3 Replies
marty1885
Adept II

Re: OpenGL "hidden bug" related to VAO - shader signature relationship

Could you provide the binary of your program?

I want to test it out on Linux. (I know you uses Windows API in the code. I'll run it with WINE)

0 Likes
asylum29
Adept II

Re: OpenGL "hidden bug" related to VAO - shader signature relationship

Added a compiled exe to the package (bin folder).

0 Likes
marty1885
Adept II

Re: OpenGL "hidden bug" related to VAO - shader signature relationship

Thanks. I have tried it under Linux. But it does not run under WINE. Sorry that I can't help on this bug

0 Likes