Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

Journeyman III

Bug in the DRI fglrx library under Linux 64 bit using the AMD GLES 2.0 SDK

Hi, apparently there is a big problem with the DRI library under Linux.

I have compiled many OpenGL ES 2.0 based applications, including the ones from the samples in the AMD GLES SDK and the official repository for the OpenGL ES 2.0 book and every single one of them gives me the same error; generally speaking the application always exit with just a segmentation fault error.

I have tried to dig deeply with valgrind and this is what i have found:

valgrind --leak-check=full ./CH02_HelloTriangle
==11404== Memcheck, a memory error detector
==11404== Copyright (C) 2002-2011, and GNU GPL'd, by Julian Seward et al.
==11404== Using Valgrind-3.7.0 and LibVEX; rerun with -h for copyright info
==11404== Command: ./CH02_HelloTriangle
==11404== Jump to the invalid address stated on the next line
==11404==    at 0x0: ???
==11404==    by 0x6F9271A: ??? (in /usr/lib/fglrx/dri/
==11404==  Address 0x0 is not stack'd, malloc'd or (recently) free'd
==11404== Process terminating with default action of signal 11 (SIGSEGV)
==11404==  Bad permissions for mapped region at address 0x0
==11404==    at 0x0: ???
==11404==    by 0x6F9271A: ??? (in /usr/lib/fglrx/dri/
==11404== HEAP SUMMARY:
==11404==     in use at exit: 144,423 bytes in 407 blocks
==11404==   total heap usage: 1,009 allocs, 602 frees, 189,993 bytes allocated
==11404== LEAK SUMMARY:
==11404==    definitely lost: 0 bytes in 0 blocks
==11404==    indirectly lost: 0 bytes in 0 blocks
==11404==      possibly lost: 0 bytes in 0 blocks
==11404==    still reachable: 144,423 bytes in 407 blocks
==11404==         suppressed: 0 bytes in 0 blocks
==11404== Reachable blocks (those to which a pointer was found) are not shown.
==11404== To see them, rerun with: --leak-check=full --show-reachable=yes
==11404== For counts of detected and suppressed errors, rerun with: -v
==11404== ERROR SUMMARY: 1 errors from 1 contexts (suppressed: 2 from 2)
Segmentation fault (core dumped)

all this reports from the various applications are basically telling the same story, there is something wrong with the library


How i can develop an OpenGL ES 2.0 based application under Linux if the drivers are not working properly ?

A general recap on my machine:

  • Ubuntu 12.04 64 bit
  • ATI 5770 1Gb
  • package fglrx-updates installed from the official Ubuntu repository with the drivers @version 8.96.7-120312a-135598C-ATI

I hope you can help me to solve this because right now i'm not able to develop anything with this GLES SDK .


0 Replies