3 Replies Latest reply on Jan 17, 2008 9:30 PM by C

    Linux, Radeon X1200 and XVideo

    Skyvalley
      This is probably not the right place for this post, but I'm getting desperate and I would really appreciate all help in this matter!
      So now to the problem:
      I'm trying to use XVideo Overlay in Linux, but I can't get it to work with my integrated ATI Radeon Xpress 1250. I'm using Gentoo 2007.0 with x11-drivers/ati-drivers-8.443.1-r1 and x11-base/xorg-x11-7.2

      # lspci|grep "VGA compatible controller:"
      01:05.0 VGA compatible controller: ATI Technologies Inc Radeon X1200 Series

      I get the following error:
      # more /var/log/Xorg.0.log|grep "(WW)"
      (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/local".
      (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/TTF".
      (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
      (WW) fglrx(0): board is an unknown third party board, chipset is supported
      (WW) fglrx(0): Only one display is connnected,so single mode is enabled
      (WW) fglrx(0): Textured Video is currently not supported on IGP hardware.
      (WW) fglrx(0): Video Overlay not supported on AVIVO based graphics cards.
      (WW) fglrx(0): Option "DynamicClocks" is not used
      (WW) fglrx(0): Option "VBERestore" is not used
      (WW) fglrx(0): Option "RenderAccel" is not used
      (WW) fglrx(0): Option "VendorName" is not used
      (WW) fglrx(0): Option "ModelName" is not used
      (WW) AIGLX: 3D driver claims to not support visual 0x23

      xorg.conf
      Section "Module"
      Load "bitmap"
      Load "dbe"
      Load "ddc"
      Load "extmod"
      Load "freetype"
      Load "int10"
      Load "record"
      Load "type1"
      Load "vbe"
      # These modules are required for 3D acceleration
      Load "GLcore"
      Load "glx"
      Load "dri"
      # Load "extmod" but omit DGA extension
      # (the DGA extension is broken in the fglrx driver)
      SubSection "extmod"
      Option "omit xfree86-dga"
      EndSubSection
      EndSection

      Section "Device"
      Identifier "ATI Technologies Inc Radeon X1200 Series"
      Driver "fglrx"
      BusID "PCI:1:5:0"
      Option "DynamicClocks" "true"
      Option "VBERestore" "true"
      Option "backingstore" "true"
      Option "RenderAccel" "true"
      # If X refuses to use the screen resolution you asked for,
      # uncomment this; see "Bugs and Workarounds" for details.
      #Option "NoDDC"
      # === Video Overlay for the Xv extension ===
      Option "VideoOverlay" "on"
      # === OpenGL Overlay ===
      # Note: When OpenGL Overlay is enabled, Video Overlay
      # will be disabled automatically
      Option "OpenGLOverlay" "off"
      # === Use internal AGP GART support? ===
      # If OpenGL acceleration doesn't work, try using "yes" here
      # and disable the kernel agpgart driver.
      Option "UseInternalAGPGART" "no"
      Option "TexturedVideo" "true"
      EndSection

      Section "Extensions"
      Option "Composite" "true"
      Option "XVideo" "true"
      EndSection

      Thanks!
        • Linux, Radeon X1200 and XVideo
          C
          I had trouble with my first installation attempt on similar hardware. I tried FC8 x86_64 and I think its a bit early yet.

          Going to try FC7 64 and run a KVM FC7 i386 userland.

          Good luck. I would love to know which driver people are using for integrated 690G ATI x1250 on latest stable linux kernels.

          On that busted FC8 attempt, I think the kmod-fglrx were working ok. I couldn't get the latest ATI/AMD drivers to do 1400x900.
          • Linux, Radeon X1200 and XVideo
            C
            FC7 x86_64 is looking much better. FYI I have a gigabyte ga-ma69g-s3h
            • Linux, Radeon X1200 and XVideo
              C
              I'm a much happier camper now. It wasn't just one thing I did wrong in my first FC8 attempt.

              First, the x1250 driver from livna is the amd driver rpmed for fedora. Please correct me if I'm wrong here.
              The open source driver is called radeonHD, and I have not tried it, and don't plan to do so until it is more mature. Awesome that AMD has opened this up. Very nice!

              My big solution for the problems I was seeing was the good old xorg ModeLine

              Samsung syncmaster 941 ATI onboard x1250

              # this one looked "flaky" it was generated by $>gtf 1400 900 60 -x
              #Modeline "1400x900_60.00" 104.23 1400 1480 1632 1864 900 901 904 932

              # this is one someone posted on a blog. It works but my monitor OSD complains it isn't optimum
              ModeLine "1400x900" 100 1400 1500 1600 1700 900 1000 1100 1200

              # this one doesn't work
              #ModeLine "1440x900_75.00" 136.49 1440 1536 1688 1936 900 901 904 940

              If you want me to post my xorg.conf let me know.

              The FC7 x86_64 stuff seems much better. I loaded an XFCE, and haven't missed KDE or GNOME yet. I did not load firefox x86_64 at all, used all 32bit stuff. That made all my stuff work great, mplayerplug-in, sun jre plugin, flash, etc.

              If you want me to talk more about this let me know.

              I played nexuiz, for a minute, but got a lockup. It looked great until it locked up

              I had been playing with X a lot, so I think that caused the lock, not sure yet.

              I would like to know more about any problems caused by using the max shared memory for x1250. I would like to use the max I think its 1024MB, or 512MB on my mobo. ( gigabyte ga-ma69g-s3h )

              Thanks,
              C