AnsweredAssumed Answered

Ryzen 3 3200g Linux

Question asked by amd_linux_test on Mar 5, 2020

Hello,

 

I just bought a Ryzen 3 3200g APU to build a Linux PC for my uncle. ZEN + Vega in an APU was nice on specs but it does not run on Linux at all. I tried with both A320 and B450 chipsets.

 

I've tried kernels from 5.0 to 5.5 with no luck. Always a BSOD or similar.

 

Manjaro XFCE/KDE/i3, Ubuntu MATE, Linux Mint MATE, MX Linux AHS. Bleeding edge or stable distro it doesn't matter, they are all unusbale.

 

I've also tried to boot 2 separate SSD with full working installations of Manjaro with Full AMD Open Source Drivers and Propietary AMDGPU Pro from an existing Ryzen 5 3600 + RX 580 setup. Kernel 5.4 and 5.5. In Ryzen 3 3200g they all fail to load X.

 

This method runs fine with the Open Source installation if I switch the SSD from Ryzen 5 3600 + RX 580 to an older FX6300 + R9 280x.

 

This APU Ryzen 3 3200g is a dead end as of now. It reminds me of an A10-7970 I bought years ago and it's been used as an expensive cyberpunk paperweight, but not as expensive as this luxury Ryzen 3 3200g Paperweight for your Linux environment.

 

Please give Linux support for all of your hardware.

 

I'll be glad to test any improvements.

Outcomes