AnsweredAssumed Answered

no Catalyst Control Center after Win 10 installation

Question asked by jcrowley on Nov 3, 2019
Latest reply on Nov 3, 2019 by elstaci

I have been unable to open CCC after a Windows 10 upgrade on my computer.  Somehow Windows has removed all traces of ANY peripheral hardware/software so no monitor drivers, they have instead installed "generic PnP monitor" no audio driver or software for on-board  - instead I have "High Definition" Audio Device of which it is neither High or Definition.   This all worked very well in Win7 64-bit.  This is what is inside...

DESKTOP-BPPLK02

Processor:  AMD A8-5600 APU with Radeon™ HD Graphics (4 Cores)

3.60 GHz

RAM:  32.0 GB (3.12) useable

Device ID:  2944B68E-07DE-443E-9CAE-8CC909AAE948

Product ID 00326-10852-48007-AA051

64-bit operating system, x64-based processor

No pen or touch input is available for this display.

For Devices from Computer Management - there is no multi-media Audio Controller and cannot update because Windows does not recognize my "device".

M/B:  msi-FM2-A85XA-G43

Audio:  Realtek® HD Audio - unable to fix sound issues since upgrade - unable to open Realtek Manager as well.

Unable to fix graphics issues because I cannot view CCC at all even from the device Manger.  The button is there but CCC does not open.  Graphics worked perfectly on CoredDraw and Photoshop and GIMP but now there are issues with something that has been turned off in Win10.  

Tried to speak with the MicroSoft folks but apparently all they are able to do is send me into circles by saying things like.  Well, then upgrade your system, or download a new driver - non of that is practical for me at this time and yet I remain quite unproductive because of a myriad of issues.

 

Outcomes