AnsweredAssumed Answered

MAJOR problems with XFX Radeon RX 570 RS XXX Edition

Question asked by rushfanyyz on Oct 9, 2019
Latest reply on Oct 10, 2019 by drallim

HI all, I am looking to hopefully get some help here. I have dell inspiron 3847 dektop, windows 10 home 64 bit, version 10.0.18362, i5-440 cpu, 16 gb ram, 3 monitors, and over 9 tb of storage. I very recent added a XFX Radeon RX 570 RS XXX Edition 1286MHz, 8gb GDDR5, DX12 VR Ready, Dual BIOS, 3xDP HDMI DVI, AMD Graphics Card (RX-570P8DFD6) to my setup, and it has so far been an absolute nightmare. I installed, and with it I downloaded it's latest driver. That worked OK for a few days, but was completely unsuccessful using it for the reason I bought it- as a GPU accelerator as opencl in Adobe premiere and encoder, as well as ray tracing in Adobe after effects. The option was there in premiere, but selecting it resulted in either a fullbwhite video frame in both preview and program, or random letters, numbers, and characters (will include pictures) encoder worked ok, and after effects would not even allow it to be used. I tried one driver back from the newest, to the same result.
However, that was only the start. After about 2 days, the whole thing took a massive downturn. I currently have massive graphical glitches in all applications and even just the desktop and windows file explorer. Slashes appear across the screen when I move the mouse, things dissappear and reappear, letters and numbers change and become unreadable, just a total mess. At first I considered the possibility of a virus, yet after completely uninstalling all traces of drivers and controls related to the card, all worked fine, yet started up immediately again after trying a reinstall. I tried newest driver, one version before that, the oldest available I could find on their site, and the drivers on the included install cd that came w the card. Even now doing a video encoding w adobe media encoder using opencl results in many of the same graphic glitches appearing in the video itself, however without using opencl, it looks so far to be without those glitches in the outputted video files. I should note I did an export before the glitches started appearing all over my system using opencl in encoder, and the video came out fine.
ANY help is so appreciated, I am at my wits end with this, and am beginning to question if I have a defective card? One thing of note, I cannot find a "hardware" option in my bios, so have not made any changes at that level.
Also of note, this card replaces a nvidia quadro 600, which I used without any errors

Outcomes