loccothan

Problem with Monitor EDID/Freesync

Discussion created by loccothan on May 25, 2019
Latest reply on Jun 25, 2019 by loccothan

I've installed (Upd.) new WinX 1903 and Adrenalin 19.5.1 & 19.5.2

Everything was good until i Turned ON Variable Refresh Rate in Display settings/GFX settings

My screen turns RED (yup only one colour, shades of Red)

 

IMhO it's EDID related bug in Windows or Drivers

Im using CRU (Monitor Tests Forum - Monitors & Video Cards )

Here is my monitor specs ( https://iiyama.com/pdf/Product/512/gb_en.pdf )

 

When im not using CRU, my monitor is 70Hz 10Bit panel but with FreeSync range of 48-70 instead of 35-70 !

Also the bug returns if i switch ON VRR in Win Display settings.

That's an hudge difference. Thanks to CRU im able to get FS range at Great 30-70Hz.

No Tearing/lag or anything in this combo, Forza DX12, VLK Games & DX9/10/11.1 Performs Great.

 

Please check this behaviour.

 

I'm not seeing Red Bug anymore (Steps to make):

1. Reset CRU

2. Set only basic settings in CRU (do not put monitor H/V leave it at default) + FS range 30-70

3. Restart & don't touch the Windows Variable Refresh Rate (Set to OFF before restart)

4. Gaming NP no Red bug.

 

My System:

ZEN 8/16 1700 with 32GB 4x8 at 3466CL14 LLC | Hero VI BIOS 6401

Vega 64 Original XTX LC by AMD (UV and max clocks for gaming 1668MHz 1.094v | HBM2 at 1120MHz 912mV)

SB-Zx + 1TB SSD

===

Screens:

 

VRR in Windows

===

Here is CRU settings

 

====

Problem is semi-solved !
Games no longer gets Red bug.

But after loading of windows (first time) after 30sec. screen gets red or pink (or sometimes green)

It can be restored if i enter into windows Display settings (right click on desktop then Display settings).

Then is fine VRR can be turned ON and can Play games NP.

So Valid ranges are not the case, the problem is driver or OS.

 

No such problems at Win 1809.

When VRR is OFF everything is fine.

If You have it ON then after restart You need to go into Display settings once.

 

I've Read through IiYama User Manual and there is 2 different settings (H/V) for DP
With FreeSync & without !

 

IiYama ProLite XUB2792QSU
DP w/o FreeSync = H=30,0-89,0 V=50-75
DP w/FreeSync = H=30,0-115,0 V=48-70

Last pages here:
-> https://cdn.iiyama.com/f/dd7b66fcdb91e2756c1410e9faa9ee52_xub-xu2792qsu-usermanual-e-revb.pdf

 

So to solve this, i needed to dig deeper into Monitor Specs, and input Valid ranges + go into Display settings once after restart/boot.

Im 90% sure that this is new Win 1903 bug... & not AMD/ATI Fault.

But guys if You can look into this problem.

I was gaming few days and everyhing was OK, then i saw this VRR in Win settings and i go for it -> Bug happend !

 

 

===

Problem solved !
Games no longer gets Red bug.
I've Read through IiYama User Manual and there is 2 different settings (H/V) for DP
With FreeSync & without !
Problem solved !
Games no longer gets Red bug.
I've Read through IiYama User Manual and there is 2 different settings (H/V) for DP
With FreeSync & without !
Problem solved !
Games no longer gets Red bug.
I've Read through IiYama User Manual and there is 2 different settings (H/V) for DP
With FreeSync & without !
Last pages here:
IiYama ProLite XUB2792QSU
DP w/o FreeSync = H=30,0-89,0 V=50-75
DP w/FreeSync = H=30,0-115,0 V=48-70
Now it's working fine.

Outcomes