AnsweredAssumed Answered

Vega 56/64 crashing, black screen/no video under high load

Question asked by thedood365 on Apr 7, 2019
Latest reply on May 21, 2019 by heartless_ca

My setup:

CPU: AMD Ryzen 5 1600 @3.8 GHz, 1.4v
GPU: Sapphire Reference Vega 56 w/ 64 BIOS + Morpheus II
RAM: Corsair Vengeance LPX 16GB @2933 MHz
SSD (Primary): Samsung 840 EVO 500GB
HDD (Secondary): Western Digital 1TB 7200RPM HDD
PSU: Seasonic SSR-550RM 550W 80 PLUS Gold
Monitors:
ASUS 24" 1080p 144Hz VG248QE
LG 27" 4k 60Hz IPS 27UD58P-B

OS: most testing done on Windows 7, some crashing experienced on W10

 

Alright, So I've been fighting this issue for a while now, and I've run out of ideas. My PC crashes when playing games that put the GPU under high load, such as GTA Online, Forza Horizon 3, and even Risk of Rain 2, primarily when running them on at full resolution my 4K monitor. Sometimes it will crash on the menus, sometimes it will crash about 10 minutes in, but I never seem to get over 30 minutes in these games without a crash when playing them at 4k. If I play them on my 1080p monitor, I see no issues. This crash happens on both Windows 7 on my SSD, and Windows 10 on my HDD.

Now when it crashes, I will lose video on both monitors in addition to audio, in what seems to be a complete lockup, forcing me to hard-reset the PC (I used to get a black/grey screen, but disabling MSI Afterburner has left me with crashes like this). Another weird thing is, if I try to reboot without disconnecting and reconnecting my monitors from the GPU, the PC won't get past POST, and will show a GPU failure LED on the motherboard.

 

What I've tried:

Reinstalling/ downgrading video drivers normally

Using DDU to uninstall the video drivers in Safe Mode, then reinstalling the latest driver (19.4.1)

Disconnecting/turning off my 1080p monitor before playing

Putting my Ryzen back to stock clocks

Swapping around the power cables at the PSU (I do have 2 separate 8-pin cables going from the PSU to the GPU)

Setting Windows power options to High Performance/Balanced (no difference)

Changing the Color Depth to 8bpc for both monitors (the LG supports 10bpc by default, the ASUS can't)

Setting the Performance / Watt profile to Power Save

Setting the power level to +50% in Wattman

Setting the Minimum Memory State in Wattman to State 1 (500 MHz)

 

That last one's a bit special, because I was having this sort of issue a while back, and doing this seemed to fix it for quite some time. Now that it started to act up again, I tried going into Wattman to see if maybe a driver update wiped my settings, and I found something peculiar. My minimum memory state is now set to State 2 (800 MHz) by default, and will not go any lower (if I try to set it to state 1 or 0, after clicking "apply", it just resets to state 2 again). I'm thinking whatever is causing this might be my culprit. I've recently found it was doing this BEFORE and AFTER using DDU then reinstalling the drivers. And the weird thing is, the GPU memory will only idle at 800 MHz if Radeon Settings is running in the background; if I restart my pc, and I don't launch the settings, GPUZ shows the memory idling at 167 MHz (attached is a GPUZ readout when I launch Radeon Settings). It seems my games can go a bit longer if I just run them without launching the settings, but they do still crash after some time. Might be a separate issue

 

I would blame the PSU not being powerful enough, but under max load, GPUZ reports around 180 Watts, and this issue only really flared up recently (I've had this GPU/setup since the Vega 56 launched).

 

Any ideas? I'd really hate to have to get another GPU, the 4k performance of this card is pretty good, besides the whole crashing thing.

 

Thank you.

Attachments

Outcomes