aerofly

Driver crash with AMD RX 560 and Vulkan

Discussion created by aerofly on Jan 10, 2019
Latest reply on Feb 26, 2019 by aerofly

Hello there,

 

sorry to post here, but I can't open a thread in the forum 'OpenGL and Vulkan',
so please move this post over there if possible.

 

I have a question related to Vulkan and the AMD RX 560 GPU.

 

A few month ago we ported our rendering engine to the Vulcan API.

Our game runs just fine on many GPU's including Intel and NVIDIA

and even on the AMD RX 460 GPU. We seem to pass a validation test,

and do not observe any validation errors at all.

 

However, when running our game on AMD RX 560 we get real driver

crashes, e.g. the driver itself seems to crash and we sometimes

even have to reboot our computer. This is on Windows 10 with the
latest AMD driver.

 

Keep in mind this is not isolated to a single developer machine,

we have customers reporting the same on various other hardware

configurations. E.g. only the AMD RX 560 gives a crash when running
our game.

 

We tried to pin point down the issue using various methods,

including adding full pipeline barriers and so on, but we can't
find out whats causing it.

 

Any idea on what we can do to find out what's causing the issue?

What is the general hardware difference between the AMD RX 460

and AMD RX 560 that could cause this? Is there any special debug
driver we might be able to try?

 

We even prepared a demo executable and tried to get help from
AMD developers, but nobody has responded so far.

 

Any help would be greatly appreciated as we are really at the

end with any ideas on what the cause might be.

 

I can of course provide more information and might even try to
provide a source sample.

 

 

Best regards,
  Torsten Hans

Outcomes