2 Replies Latest reply on Dec 11, 2018 7:47 PM by nd7pszmc

    Can't install amdgpu-pro 18.40 on ubuntu server 18.04.01

    nd7pszmc

      Hello, I seem to be having issues installing the latest driver on ubuntu server. I've installed amdgpu-pro 18.2 on ubuntu 18.04 in the past but I can't at all get the amdgpu-pro 18.40-676022 driver (Download Not Complete | AMD from Radeon™ Software for Linux® 18.40 Highlights | AMD ) to install on a fresh install of ubuntu server 18.04.1. I've downloaded the driver twice and verified that both had the same SHA256 checksums (is there an official repository of the driver checksums?)

       

      it works neither on its own nor with flags

       

      ****************************************************************************************************************************************

       

      ./amdgpu-pro-install

      deb [ trusted=yes ] file:/var/opt/amdgpu-pro-local/ ./

      Get:1 file:/var/opt/amdgpu-pro-local ./ InRelease

      Ign:1 file:/var/opt/amdgpu-pro-local ./ InRelease

      Get:2 file:/var/opt/amdgpu-pro-local ./ Release [816 B]

      Get:2 file:/var/opt/amdgpu-pro-local ./ Release [816 B]

      Get:3 file:/var/opt/amdgpu-pro-local ./ Release.gpg

      Ign:3 file:/var/opt/amdgpu-pro-local ./ Release.gpg

      Hit:4 http://ppa.launchpad.net/ethereum/ethereum/ubuntu bionic InRelease

      Hit:5 http://archive.ubuntu.com/ubuntu bionic InRelease

      Get:6 http://archive.ubuntu.com/ubuntu bionic-security InRelease [83.2 kB]

      Get:7 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]

      Fetched 172 kB in 4s (45.3 kB/s)

      Reading package lists... Done

      Package: *amdgpu*

      Pin: release o=AMD

      Pin: version *-676022

      Pin-Priority: 1000

       

       

      Package: *amdgpu*:i386

      Pin: release o=AMD

      Pin: version *-676022

      Pin-Priority: 1000

       

       

      Reading package lists... Done

      Building dependency tree

      Reading state information... Done

      Some packages could not be installed. This may mean that you have

      requested an impossible situation or if you are using the unstable

      distribution that some required packages have not yet been created

      or been moved out of Incoming.

      The following information may help to resolve the situation:

       

       

      The following packages have unmet dependencies:

      amdgpu : Depends: mesa-amdgpu-va-drivers (= 1:18.1.0-676022) but it is not going to be installed

      Depends: mesa-amdgpu-omx-drivers (= 1:18.1.0-676022) but it is not going to be installed

      Depends: gst-omx-amdgpu (= 1.0.0.1-676022) but it is not going to be installed

      amdgpu-lib32 : Depends: libdrm2-amdgpu:i386 (= 1:2.4.92-676022)

      Depends: libdrm-amdgpu-amdgpu1:i386 (= 1:2.4.92-676022)

      Depends: libllvm6.0-amdgpu:i386 (= 1:6.0-676022)

      Depends: libwayland-amdgpu-client0:i386 (= 1.14.0-676022)

      Depends: libwayland-amdgpu-server0:i386 (= 1.14.0-676022)

      Depends: libxatracker2-amdgpu:i386 (= 1:18.1.0-676022)

      Depends: libgbm1-amdgpu:i386 (= 1:18.1.0-676022)

      Depends: libegl1-amdgpu-mesa:i386 (= 1:18.1.0-676022)

      Depends: libegl1-amdgpu-mesa-drivers:i386 (= 1:18.1.0-676022)

      Depends: libwayland-amdgpu-egl1-mesa:i386 (= 1:18.1.0-676022)

      Depends: libgles1-amdgpu-mesa:i386 (= 1:18.1.0-676022)

      Depends: libgles2-amdgpu-mesa:i386 (= 1:18.1.0-676022)

      Depends: libglapi-amdgpu-mesa:i386 (= 1:18.1.0-676022)

      Depends: libgl1-amdgpu-mesa-glx:i386 (= 1:18.1.0-676022)

      Depends: libgl1-amdgpu-mesa-dri:i386 (= 1:18.1.0-676022)

      Depends: libosmesa6-amdgpu:i386 (= 1:18.1.0-676022)

      Depends: mesa-amdgpu-va-drivers:i386 (= 1:18.1.0-676022)

      Depends: mesa-amdgpu-vdpau-drivers:i386 (= 1:18.1.0-676022)

      amdgpu-pro-lib32 : Depends: libgl1-amdgpu-pro-glx:i386 (= 18.40-676022)

      Depends: libegl1-amdgpu-pro:i386 (= 18.40-676022)

      Depends: libgles2-amdgpu-pro:i386 (= 18.40-676022)

      Depends: libgl1-amdgpu-pro-dri:i386 (= 18.40-676022)

      Depends: libgbm1-amdgpu-pro:i386 (= 18.40-676022)

      vulkan-amdgpu-pro:i386 : Depends: libc6:i386 (>= 2.17) but it is not installable

      Depends: libgcc1:i386 (>= 1:3.3.1) but it is not installable

      Depends: libstdc++6:i386 (>= 4.8) but it is not installable

      Depends: wsa-amdgpu:i386 but it is not going to be installed

      E: Unable to correct problems, you have held broken packages.

       

      ****************************************************************************************************************************************

       

      ./amdgpu-pro-install --opencl=legacy --headless

      deb [ trusted=yes ] file:/var/opt/amdgpu-pro-local/ ./

      Get:1 file:/var/opt/amdgpu-pro-local ./ InRelease

      Ign:1 file:/var/opt/amdgpu-pro-local ./ InRelease

      Get:2 file:/var/opt/amdgpu-pro-local ./ Release [816 B]

      Get:2 file:/var/opt/amdgpu-pro-local ./ Release [816 B]

      Get:3 file:/var/opt/amdgpu-pro-local ./ Release.gpg

      Ign:3 file:/var/opt/amdgpu-pro-local ./ Release.gpg

      Hit:4 http://ppa.launchpad.net/ethereum/ethereum/ubuntu bionic InRelease

      Hit:5 http://archive.ubuntu.com/ubuntu bionic InRelease

      Get:6 http://archive.ubuntu.com/ubuntu bionic-security InRelease [83.2 kB]

      Get:7 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]

      Fetched 172 kB in 5s (32.7 kB/s)

      Reading package lists... Done

      Package: *amdgpu*

      Pin: release o=AMD

      Pin: version *-676022

      Pin-Priority: 1000

       

       

      Package: *amdgpu*:i386

      Pin: release o=AMD

      Pin: version *-676022

      Pin-Priority: 1000

       

       

      Reading package lists... Done

      Building dependency tree

      Reading state information... Done

      Some packages could not be installed. This may mean that you have

      requested an impossible situation or if you are using the unstable

      distribution that some required packages have not yet been created

      or been moved out of Incoming.

      The following information may help to resolve the situation:

       

       

      The following packages have unmet dependencies:

      amdgpu : Depends: mesa-amdgpu-va-drivers (= 1:18.1.0-676022) but it is not going to be installed

      Depends: mesa-amdgpu-omx-drivers (= 1:18.1.0-676022) but it is not going to be installed

      Depends: gst-omx-amdgpu (= 1.0.0.1-676022) but it is not going to be installed

      E: Unable to correct problems, you have held broken packages.

       

       

       

       

      sudo apt-get install -y aptitude &&

      sudo aptitude -y update &&

      sudo aptitude -y upgrade &&

      sudo aptitude install -y tmux build-essential git cmake

       

      ****************************************************************************************************************************************

      ****************************************************************************************************************************************

      ****************************************************************************************************************************************

       

      I've also tried upgrading the 18.2 driver to 18.4 on the ubuntu server 18.04 and that caused issues and now I cant even uninstall amdgpu-pro on the 18.04 server to downgrade to 18.2

       

       

      command unknown since the log doesn't go back far enough

      Unpacking wsa-amdgpu:amd64 (18.40-676022) ...

      Errors were encountered while processing:

      /tmp/apt-dpkg-install-kxW9dB/17-libdrm-amdgpu-common_1.0.0-676022_all.deb

      E: Sub-process /usr/bin/dpkg returned an error code (1)

       

      ****************************************************************************************************************************************

       

      amdgpu-pro-uninstall

      Reading package lists... Done

      Building dependency tree

      Reading state information... Done

      You might want to run 'apt --fix-broken install' to correct these.

      The following packages have unmet dependencies:

      amdgpu : Depends: amdgpu-core (= 18.40-676022) but it is not going to be installed

      Depends: libdrm-amdgpu-common (= 1.0.0-676022) but it is not going to be installed

      amdgpu-dkms : Depends: amdgpu-core but it is not going to be installed

      amdgpu-pro-core : Depends: amdgpu-core but it is not going to be installed

      glamor-amdgpu : Depends: amdgpu-core but it is not going to be installed

      gst-omx-amdgpu : Depends: amdgpu-core but it is not going to be installed

      ids-amdgpu : Depends: amdgpu-core but it is not going to be installed

      libdrm-amdgpu-amdgpu1 : Depends: libdrm-amdgpu-common but it is not going to be installed

      libdrm-amdgpu-amdgpu1:i386 : Depends: libdrm-amdgpu-common:i386

      libdrm2-amdgpu : Depends: amdgpu-core but it is not going to be installed

      libdrm2-amdgpu:i386 : Depends: amdgpu-core:i386

      libegl1-amdgpu-mesa : Depends: amdgpu-core but it is not going to be installed

      libegl1-amdgpu-mesa:i386 : Depends: amdgpu-core:i386

      libgbm1-amdgpu : Depends: amdgpu-core but it is not going to be installed

      libgbm1-amdgpu:i386 : Depends: amdgpu-core:i386

      libgl1-amdgpu-mesa-dri : Depends: amdgpu-core but it is not going to be installed

      Recommends: libtxc-dxtn-s2tc0 but it is not installable or

      libtxc-dxtn0 but it is not installable

      libgl1-amdgpu-mesa-dri:i386 : Depends: amdgpu-core:i386

      Recommends: libtxc-dxtn-s2tc0:i386 but it is not installable or

      libtxc-dxtn0:i386 but it is not installable

      libglapi-amdgpu-mesa : Depends: amdgpu-core but it is not going to be installed

      libglapi-amdgpu-mesa:i386 : Depends: amdgpu-core:i386

      libllvm6.0-amdgpu : Depends: amdgpu-core but it is not going to be installed

      libllvm6.0-amdgpu:i386 : Depends: amdgpu-core:i386

      libwayland-amdgpu-client0 : Depends: amdgpu-core but it is not going to be installed

      libwayland-amdgpu-client0:i386 : Depends: amdgpu-core:i386

      libwayland-amdgpu-server0 : Depends: amdgpu-core but it is not going to be installed

      libwayland-amdgpu-server0:i386 : Depends: amdgpu-core:i386

      mesa-amdgpu-va-drivers : Depends: amdgpu-core but it is not going to be installed

      mesa-amdgpu-va-drivers:i386 : Depends: amdgpu-core:i386

      mesa-amdgpu-vdpau-drivers : Depends: amdgpu-core but it is not going to be installed

      mesa-amdgpu-vdpau-drivers:i386 : Depends: amdgpu-core:i386

      wsa-amdgpu:i386 : Depends: amdgpu-core:i386

      wsa-amdgpu : Depends: amdgpu-core but it is not going to be installed

      xserver-xorg-amdgpu-video-amdgpu : Depends: amdgpu-core but it is not going to be installed

      E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

       

      ****************************************************************************************************************************************

       

      sudo apt --fix-broken install

      Reading package lists... Done

      Building dependency tree

      Reading state information... Done

      Correcting dependencies... Done

      The following package was automatically installed and is no longer required:

      ids-amdgpu

      Use 'sudo apt autoremove' to remove it.

      The following additional packages will be installed:

      libdrm-amdgpu-common

      The following NEW packages will be installed:

      libdrm-amdgpu-common

      0 upgraded, 1 newly installed, 0 to remove and 184 not upgraded.

      64 not fully installed or removed.

      Need to get 0 B/6,736 B of archives.

      After this operation, 28.7 kB of additional disk space will be used.

      Do you want to continue? [Y/n] Y

      Get:1 file:/var/opt/amdgpu-pro-local ./ libdrm-amdgpu-common 1.0.0-676022 [6,736 B]

      (Reading database ... 114143 files and directories currently installed.)

      Preparing to unpack .../libdrm-amdgpu-common_1.0.0-676022_all.deb ...

      Unpacking libdrm-amdgpu-common (1.0.0-676022) ...

      dpkg: error processing archive /var/opt/amdgpu-pro-local/./libdrm-amdgpu-common_1.0.0-676022_all.deb (--unpack):

      trying to overwrite '/opt/amdgpu/share/libdrm/amdgpu.ids', which is also in package ids-amdgpu 1.0.0-606296

      Errors were encountered while processing:

      /var/opt/amdgpu-pro-local/./libdrm-amdgpu-common_1.0.0-676022_all.deb

      E: Sub-process /usr/bin/dpkg returned an error code (1)

       

      ****************************************************************************************************************************************

       

      sudo apt remove amdgpu*

      Reading package lists... Done

      Building dependency tree

      Reading state information... Done

      E: Unable to locate package amdgpu_18.40-676022_amd64.deb

      E: Couldn't find any package by glob 'amdgpu_18.40-676022_amd64.deb'

      E: Couldn't find any package by regex 'amdgpu_18.40-676022_amd64.deb'

      E: Unable to locate package amdgpu_18.40-676022_i386.deb

      E: Couldn't find any package by glob 'amdgpu_18.40-676022_i386.deb'

      E: Couldn't find any package by regex 'amdgpu_18.40-676022_i386.deb'

      E: Unable to locate package amdgpu-core_18.40-676022_all.deb

      E: Couldn't find any package by glob 'amdgpu-core_18.40-676022_all.deb'

      E: Couldn't find any package by regex 'amdgpu-core_18.40-676022_all.deb'

      E: Unable to locate package amdgpu-dkms_18.40-676022_all.deb

      E: Couldn't find any package by glob 'amdgpu-dkms_18.40-676022_all.deb'

      E: Couldn't find any package by regex 'amdgpu-dkms_18.40-676022_all.deb'

      E: Unable to locate package amdgpu-doc_18.40-676022_all.deb

      E: Couldn't find any package by glob 'amdgpu-doc_18.40-676022_all.deb'

      E: Couldn't find any package by regex 'amdgpu-doc_18.40-676022_all.deb'

      E: Unable to locate package amdgpu-install

      E: Unable to locate package amdgpu-lib32_18.40-676022_amd64.deb

      E: Couldn't find any package by glob 'amdgpu-lib32_18.40-676022_amd64.deb'

      E: Couldn't find any package by regex 'amdgpu-lib32_18.40-676022_amd64.deb'

      E: Unable to locate package amdgpu-pro_18.40-676022_amd64.deb

      E: Couldn't find any package by glob 'amdgpu-pro_18.40-676022_amd64.deb'

      E: Couldn't find any package by regex 'amdgpu-pro_18.40-676022_amd64.deb'

      E: Unable to locate package amdgpu-pro_18.40-676022_i386.deb

      E: Couldn't find any package by glob 'amdgpu-pro_18.40-676022_i386.deb'

      E: Couldn't find any package by regex 'amdgpu-pro_18.40-676022_i386.deb'

      E: Unable to locate package amdgpu-pro-core_18.40-676022_all.deb

      E: Couldn't find any package by glob 'amdgpu-pro-core_18.40-676022_all.deb'

      E: Couldn't find any package by regex 'amdgpu-pro-core_18.40-676022_all.deb'

      E: Unable to locate package amdgpu-pro-install

      E: Unable to locate package amdgpu-pro-lib32_18.40-676022_amd64.deb

      E: Couldn't find any package by glob 'amdgpu-pro-lib32_18.40-676022_amd64.deb'

      E: Couldn't find any package by regex 'amdgpu-pro-lib32_18.40-676022_amd64.deb'https://drivers.amd.com/drivers/linux/amdgpu-pro-18.40-676022-ubuntu-18.04.tar.xz

       

      ****************************************************************************************************************************************

      ****************************************************************************************************************************************

      ****************************************************************************************************************************************

       

      Any help would be greatly appreciated!

       

      ****************************************************************************************************************************************

      ****************************************************************************************************************************************

      ****************************************************************************************************************************************

       

      EDITS:

       

      2018-11-18 06:42 UTC

       

      I tried installing the "amdgpu-pro-18.20-606296" driver on the ubuntu server 18.04.01 and I seem to have gotten the same error messages. Maybe this is an issue with ubuntu repositories or something.

       

       

       

       

       

       

      2018-12-06 10:33 UTC

       

      I tried installing the amd 18.40 driver in a virtual machines (ubuntu desktop 18.04.1, ubuntu desktop 16.04.5, ubuntu server 16.04.5, ubuntu server 18.04.1)

       

      desktop 18: seemed to install but gave an error:

      "WARNING: amdgpu dkms failed for running kernel" (assuming this has something to do with the virtual machine)

       

      desktop 16: same as desktop 18

       

      server 16: seemed to install without issue

       

      server 18: same issues as above, also tried with amd drivers 18.20 and 18.30 and none worked, all gave "Depends: mesa-amdgpu-va-drivers ... but it is not going to be installed" I tried installing the package manually which lead to "Depends: libval1-amdgpu ..." with the error "Package 'libva1-amdgpu' has no installation candidate"

       

      so I'm guessing this is an issue specific to server 18.04.1 and not ubuntu 18.04.1 in general since it seems to install fine in ubuntu desktop 18.04.1.

       

      I tried changing the mirror in the server 18.04.1 installation from "http://archive.ubuntu.com/ubuntu" to "http://ao.archive.ubuntu.com/ubuntu" since that's the mirror desktop seems to be using but that didn't seem to do anything.

       

       

       

      2018-12-06 00:04 UTC

       

      Confirmed working on Ubuntu Desktop 18.04.1. I installed Ubuntu Desktop 18.04.1 onto a flash drive and was able to install amd-gpu-pro 18.40 and successfully run it with an RX 470.

       

      Still won't install on Ubuntu Server 18.04.1 and I still have no idea why.

       

      However I can't get the RX 590 to run on Ubuntu Desktop 18.04.1 and have opened a new question here (Can't get RX 590 to run on Ubuntu Desktop 18.04.1 with amd-gpu-pro 18.40)

       

       

       

      Message was edited by: John Doe