5 Replies Latest reply on Oct 18, 2018 4:48 PM by karatsonyi

    threadripper 2 raid

    karatsonyi

      Hi,

       

      We have a threadripper 2 2990WX CPU; and a MSI X399 MEG creation motherboard. BIOS rev 1.1 (latest currently available from MSI. We are trying to use the RAID controller of the system to create a RAID0 bootable volume for win 10. This board has 3 m2 slots. We installed 3x Intel 660p Series M.2 2280 512GB on the motherboard. We enabled the RAID controller in the UEFI; and created the array just fine. UEFI reports that it sees the 1.5TB RAID0 Array. We booted our W10 (build 1809) install media and it shows that it sees 3 independent 512 GB disks (it says it cannot use) and no raid array. We downloaded the oficial AMD RAID drivers from here:(NVMe RAID Support for the AMD Ryzen™ Threadripper™ platform)  loaded the drivers; but no luck seeing our 1.5TB raid volume to install W10 on..... We did notice that the W10 version supported by the driver is build 1703. Is it possible that 1809 isnt supported yet? Any input on this? Are we the only ones having an issue with this? Also we will try to use the riser card instead the slots on the mobo to see if that makes any difference or using the 1703 build of W10. Also the system in question IS a DUAL GPU system. We noticed the verbiage says "With a single GPU in the system, arrays containing up to six NVMe SSDs can be supported without adapters" so can anyone confirm if we use dual GPU this is a no go?

       

      v/r,

       

      Andras

        • Re: threadripper 2 raid
          amdmatt

          The Raid drivers you are using are quite old, please try again using the latest drivers linked here > X399 Drivers & Support | AMD

           

          Please note, it is important to make sure you select the correct Raid driver, select the Raid and Sata nVME driver 711kb and load these drivers prior to installing the latest Windows build.

            • Re: threadripper 2 raid
              misterj

              karatsonyi, when you do the Load Driver during W10 install, are you using the specified order?  Please use this order:

              1)rcbottom

              2)rcraid

              3)rccfg

              I suspect amdatt has hit on the problem.  I have not tried 1809 but 1803 works fine and I expect 1809 to be fine also.  Please do not go back to 1703.  I would also encourage you to check the MSI forum.  In this thread the user is having trouble with an SATA HDD RAID, but the RAID0 NVMe works fine.  I am user jhchris and trying to help.  There are also several Beta UEFIs available there.  BTW, I have the same MB and CPU, but have not powered up yet.  Enjoy, John.

               

              EDIT: Here is a snippet of instructions I created for TR RAID on an ASRock board:

              11. Install the RAID drivers in this order:

                 1-rcbottom - all your drives in the RAID will disappear

                 2-rcraid - you will see your one RAID

                 3-rccfg - you are good to go!

              Also, I strongly recommend you get all your drivers from the manufacturer not the MB Vendor.  In some cases a MB vendor may require use of their driver (modified) - you are just stuck then.  ALWAYS get the AMD drivers from the AMD Driver DL site.  Please make sure you have the latest AMD Chip Set driver from there.  You should also install the latest version of RAIDXpert2 (RX2).

              1 of 1 people found this helpful
            • Re: threadripper 2 raid
              karatsonyi

              Hi all,

               

              Thank you both "amdmatt" and "misterj". We figured it out. It was not the driver nor the BIOS version of the motherboard. It was W10 build 1809. apparently M$ kinda screwed this release up a tad bit. To mention a few:
              HP: Microsoft Issues Fix For Windows 10 October 2018 Update BSOD Woes On HP PCs | HotHardware

              Intel: (this wasnt M$`s fault but still) https://www.windowslatest.com/2018/10/12/fix-no-audio-output-device-is-installed-error-in-windows-10/
              and the classic: https://www.windowscentral.com/windows-10-october-2018-update-seems-be-deleting-users-data

               

              Maybe firing most of their QA team wasnt a good idea after all.....

               

              It seems the threadripper RAID drivers are not working on this release (1809 - aka Redstone 5) either. When we tried to load the drivers (the way misterj and the official doc instructed) the part where we were loading the "2)rcraid" driver the driver would just load forever without sucseeding and eventually the system would restart. Even if we completely disable raid and go with a single disk in AHCI mode (either SSD or nvme) the install would susceed in its first stage of copying the files and partitioning the drive, but after the initial restart and during the boot when it says "configuring hardware" the first time around 60-80% it BSOD`s and never recover from that. So 1809 would not work even without RAID. I guess we`ll be running 1803 for a while. 1803 does not have any of the issues. both RAID/ahci works the way it should, We tried it with both 1.0, and 1.1 version of the official BIOSes from MSI without any problems. Misterj hopefully you`ll get to get your machine up and running soon. Its totaly worth it. This CPU is insane as a Desktop CPU.

               

              Again Thank you both for looking into this and I hope our experience helps you and others troubleshooting issues for this CPU/mobo/W10 config.

               

              v/r,

               

              Andras

              3 of 3 people found this helpful
                • Re: threadripper 2 raid
                  misterj

                  Thanks much, karatsonyid.  Do you know what patch level of 1809 you were running?  Right now I am running 55 (10.1809.17763.55 latest version), no RAIDs.  My first install on this system was 1809, but I do not remember what version.  I will figure it out and post it.  I was able to create a RAID0 for W10, Load Drivers worked fine and install work fine till reboot.  It hung because I was installing from a flat.  After Load Drivers for my RAID0, all other drives disappeared because of how MSI implements AMD's RAID (all drives or none under RAID).  I have now moved my install files to USBs.

                  Media Creation Tool is still delivering 1803.  If you want to experiment on 1809 use this URL to get it (don't know what patch level yet): Xhttps://software-download.microsoft.com/download/pr/MediaCreationTool1809.exe     I added and X to the front to prevent the forum from delaying my post for minutes to days; please remove it.

                  My 1950X was fairly insane also and I attributed it to W10 on a RAID0 and all data (except backup) on a 4xSamsung 960 EVO RAID 10.  I extracted a W10 ISO (about 4 GB) with 7Z and it went so fast I can only guess it took 2 or 3 seconds.  Enjoy, John.

                   

                  EDIT: I was running 1809.17763.1.

                    • Re: threadripper 2 raid
                      karatsonyi

                      Hi,

                       

                      This is the build of 1809 i got (using the media builder tool at that time):

                       

                      (DISM)

                       

                      Name : Windows 10 Pro

                      Description : Windows 10 Pro

                      Size : 14,364,171,065 bytes

                      WIM Bootable : No

                      Architecture : x64

                      Hal : <undefined>

                      Version : 10.0.17763

                      ServicePack Build : 1

                      ServicePack Level : 0

                      Edition : Professional

                      Installation : Client

                      ProductType : WinNT

                      ProductSuite : Terminal Server

                      System Root : WINDOWS

                      Directories : 18872

                      Files : 87389

                      Created : 9/15/2018 - 2:36:07 AM

                      Modified : 10/2/2018 - 4:36:27 PM

                       

                      This ^ would not load the raid drivers for me.

                       

                      -- Still on 1803 and no problems

                       

                      I`ll wait untin M$ re releases 1809 for "real" and I`ll give it a shot again.

                       

                      A.