2 Replies Latest reply on Oct 6, 2018 10:42 PM by goodplay

    AMD Radeon R7 Series / HD 9000 Series  -  "ProgramName.exe has been blocked from accessing graphics hardware..."

    spunion

      Recently updated to Windows 10 (1809), Installed GPU driver via AMD Auto-Detect installer. Games give errors about 3D Acceleration access and crash to desktop. Which then result in AMD Control Center not responding, closing and then reloading on demand.(screen flashes black and back on). Attatched DxDiag and MsInfo text files. This happens in both 18.5.1 and 18.9.3 for Radeon drivers. Id also like to add that device manager name for display adapter changes from AMD Radeon R7 Series / HD 9000 Series to AMD R9 255 every now and then when i load device manager. Using windows to update driver causes name to be AMD R9 255 using AMD installer sets name to AMD Radeon R7 Series / HD 9000 Series. Both methods result in same errors.

       

      This spike to 100% under 3d section was Counter-Strike:Source freezing in a pix-elated state after i hit the options button:

      2018.10.06-02.44.png

       

      Error generated from World of Warcraft: Battle for Azeroth:

      2018.10.06-02.11_1.png

       

      GPU 3D Graph the waves at 16% are when CS:GO was selected as my main program, the cycles to 0% are when I alt-tabbed to actually select the task manager:

      *CS:GO never generated a screen, when u alt-tab to it its just see through

      2018.10.06-03.04.png

      I Apologize for the many edits, but its the only way I can get these screenshots while programs are freezing without causing a total computer crash.

       

       

      **UPDATE 10/7/18

      I was able to revert my windows to build 1803. Then I restarted using the advanced startup feature, and disabled driver signature enforcement. I currently have Crimson Relive software 17.1.1 installed, and so far I have tested World of Warcraft and it works. The frame rate is extremely low and spiking, however I am not getting any hardware acceleration errors. I have yet to test my steam games, and my audio workstation programs.

       

      **UPDATE 10/7/18 - 2

      Using the AMD auto detect tool, I updated the graphics card to Adrenalin 18.5.1 as recommended. Which has now regenerated the 3d acceleration error in World of Warcraft.

       

      **UPDATE 10/7/18 - 3

      Crimson Relive 17.1.1 - Jan 2017 caused 3d acceleration error. Crimson Relive 17.1.1 April 2017 allows applications to run 3d acceleration.

       

      **UPDATE 10/8/18

      Using Device Manager I selected my display adaptor and updated it through windows auto update. After it was complete it was renamed to AMD Radeon R9 255. Nothing worked. So I then went to AMD driver support, selected auto-detect, installed 18.5.1 recommended and again nothing worked. However this time through AMD update I actually got the AMD UI with it, with windows it did not. When windows updated and renamed my graphics card to AMD Radeon R9 255, I was able to right-click on my desktop and it showed the AMD menu option, but when I click it loads and then I don't see any visual representation or process representation of it, I only get the mouse loading icon and then nothing.

       

      So windows tried to update my card to AMD Radeon R9 255 and AMD installs the card as AMD Radeon R7 series / HD 9000 series. Windows doesn't give me the AMD settings and AMD doesn't give me a specific graphics. The box my computer came with on the outside label however says AMD Radeon R9 255 which is not available on the list of the drivers and support page.

       

      I have also attached my latest MsInfo and DxDiag.

       

      **UPDATE 10/09/18

      Tried Autodetect and Clean Install have 18.5.1 nothing seems to wanna solve this and now im back to where even browsers dynamic content is causing screen flashing and radeon application crashing.

      Overview.png

      Software.png

      Hardware.png

      **UPDATE 10/9/18

      Also want to add that my laptop runs NVIDIA and hasn't been on in months. It updated to windows 10 1809 October build with 1 click. It runs wow better than it did prior to the windows update and I can turn my graphics even higher than I had them.

       

      **UPDATE 10/9/18

      I took out my graphics card, plugged the HDMI into the motherboard input, started up my computer. Windows installed and had me configure Intel HD Graphics. I was able to use everything, no flashing no craziness. Not the same FPS and clarity as before but no joke no errors. Installed my graphics hardware, turned on my computer, installed the 18.9.3 from the support drivers page, and back to errors. The only problem is that in order to plug the HDMI and use the motherboard input and intel HD I have to physically remove my AMD graphics card. Which fixes acceleration blocking but then I don't get the power and quality of when both were working and I had my HDMI plugged into the graphics card.

       

      **UPDATE 10/10/18

      Ok totally uninstalled AMD Radeon. Shut Down. Removed physical graphics card. Pugged HDMI into motherboard input. Installed and updated Intel HD Graphics 4600. Also under Device Manager I had to right click every system device and upgrade everything like the PCIE controller and RAM controllers and everything. Restarted my computer. Entered into WoW(World of Warcraft) and Counter-Strike 1.6 no issues. Shut Down. Reinstalled physical graphics card. Plugged HDMI into graphics card input (PLEASE NOTE: When I attach the separate AMD PCIE graphics card my computer wont let me use motherboard HDMI input nor it wont let me see or control Intel HD Graphics Control Panel). I started my computer, installed Radeon Adrenalin Auto-Detect tool. It installed 18.5.1. Counter-Strike 1.6 worked, Source did not, CS:GO did not, and I also got graphics flickering and application graphics blocking. Through AMD control panel I updated to 18.9.3. I still have the same issues with games now blocking graphics however I now can use dynamic web content and move mouse and play HD videos with no stutter corruption or flickering. My text and scaling seems more clear and accurate as it was before this mess. The only problem is the only way to remove the error for blocking graphics is I have to shut off my comp and physically remove my video card and then hook my HDMI into my motherboard. So then I get access to graphics but awful quality and performance.

       

      **UPDATE 10/10/18

      New error dialogue pops up now when trying to load CS:GO along with "csgo.exe has been blocked from accessing graphics hardware"

       

       

      **UPDATE 10/11/18

      After checking my call logs on my phone, I would just like to add that this first started 9/18/18. I have reported the problem via contact us page. I have used the AMD problem report wizard. I have contacted Windows support, Microsoft support, XBOX Live support, AMD support, Blizzard support. The only driver I can get to work is Crimson Relive 17.1.1, which makes no sense because I have been using 18.x.x Adrenalin software with no issues. When I install the 17.1.1 it removes the error "example.exe has been blocked from accessing graphics hardware." however the performance and quality is just horrid. The other way to remove that error is to just take out my video card. My computer then switches to Intel HD 4600. the quality of 3d effects looks gorgeous and video playback/flash websites are instant load. However game performance is down in the 15fps range. I used to be able to run graphics in most of the games I own at almost the highest settings with extremely gorgeous quality, and would maintain 60 FPS, which i capped there on purpose, and even with settings on ultra in wow when 25 people blow there cooldowns and initiate a boss fight, Id have 60 fps. So im not sure *** happened, but the fact I cannot get anytype of solution is driving me nuts. Also, the fact that attaching my AMD graphics card to my computer completely disables my HD 3D pisses me off. When I run DxDiag on my other computer, I get a tab that says Display and a tab that says Render. Display is Intel HD and my Geforce 745m is set to render mode only. I havent once had to touch or manipulate my graphics. Meanwhile typing this post on my desktop is causing my screen to flicker and chrome or edge to crash out. Sigh...*** is the point, most likely the only person to answer is gonna tell me something I have already stated, or to buy a new graphics card.

       

      **UPDATE 10/16/18

      Reinstalled Windows fresh partitioned harddrive have 1803. Windows automatically installed AMD Radeon R7 / HD 9000 w. Crimson Relive 17.1.1 . Everything works as far as FL Studio, WoW:BfA, No dynamic content crashing in edge, or chrome. used device manager to update display. Update failed. I believe that AMD Adrenalin Edition sudden change a month ago to all their builds really just, was fail. 18.5.1 worked fine. I ran my wow at 1920x1080x60hz @ 60fps with no frame spiking or loss even mid combat. I remember I had upgraded to 18.9.3 and everything was fine no issues. Keep in mind I had anti-stropic filters 16x ssao on projected texture on depth settings at high. I don't know how or what happened but I don't install anything on my computer once its set up. only updates, and they are download only I install. within a 3 hour period a few days after my 18.9.3 update and after everything was working fine I came back to a locked computer screen. Windows update showed no updates, I knew it couldn't be AMD because I already updated to 18.9.3. Well im not gonna beat the dead horse on this one, if u have a predator 63 605 with amd radeon r9 255 2gb DDR5 and an Intel 4770 processor, no even uninstalling the graphics physically will allow u to install and use the Intel chipset graphics HD for rendering and your Radeon for display like it was when you first bought it. However if your trying not to go nuts, fresh install windows from the update manager, connect to the internet during installation, login using your Microsoft account, it will restart a few times and then boom everything will work, ur settings are synced from ur account all easy peasy. U just have to now sit and wonder why even though none of your builds, hardware or software changed, or if they did and have been working for a week or so amazingly, why u now have to revert to 17.1.1 crimson relive and why Windows is able to pick the right driver for your card, and why AMD update recommendation straight off the website, eventually leads to your computer graphics freezing and hanging ur system. Which also seems to be triggered by even the simplest of animations from windows. So u cant update ur card cause the new AMD support destroys your computer and u cant play your games because the only working driver is one from years ago and your games tell u to go to AMD and update. Ontop of that you cant find amd radeon 255 2gb ddr5 support on the AMD site. So......yea.

       

       

      **UPDATE 10/22/18

      So I have narrowed down the issue to two things. 1. AMD Radeon R9 255 DDR5 has no specific drivers supported by AMD so when you try to auto detect and install it gives you compatible but not signed drivers. When you use the Acer VGA package update for windows 10, its most recent driver is catalyst, which is no longer the 3d application, and then you will get errors in games about missing diff types of shaders and so on, or the game will notify you to go to your hardware manufacture for the new drivers. Now if you allow drivers to be installed without signature, pretty much anything in your series will get you the closest compatible drivers. For instance in the drop down menu I select Radeon Graphics > Radeon r9 > 200 Series and then I click search and I get the page for the drivers per OS or auto detect. Either way, the next issue is OverDrive(WattMan). I don't know exactly how or when but my card ever since I could remember getting the prebuilt PC always ran gpu 930 memory clock 1150. But for some reason now, those settings cause crashing. If I drop below 800 for GPU it unlocks the blocking for graphics hardware. However the performance is no where near the same, not to mention the logging intervals cause noticeable spikes in activity and usage, and you pair that with a in game dynamic render and now your lowered settings are crashing. so I sacrifice the clock for stability, drop the frames, and everything is fine and working but somewhere along the way, the settings for wattman just reset back to 930gpu 1150mem and crash out. Then I get error AMD Settings has been blocked from accessing graphics hardware. AMD settings will not respond, close out and reload, but reload back to the default settings, so while its chopping and blinking you have to attempt to turn those gpu clock down before you crash, then your system will stabilize, you can go and begin to do things but before ya know it, and no matter how low you turn your settings, no chance, they just reset, crash, reset, flicker, and then u either save the total freeze or your computer stops processing and hangs. as of now Crimson 17.1.1 , 17.12, Adrenalin 18.5.1, 18.9.3, 18.10.1. all work, and do not give you driver certification errors, but they will cause crashing no matter how you have your settings. If you need to use your computer for basic use and not heavy multimedia / gaming then there is a slight fix you can try.

       

      1. When you first extract your installer it will extract into your Primary drive (usually C:\). Inside that folder you will find AMD Cleanup Utility. This thing is amazing, it automatically reboots your computer into safe mode, removes ALL the AMD drivers, and then notifies you that it is successful and then auto restarts back into normal mode.

       

      2. Once you are back into normal boot, then you can can go right to the AMD website, Drivers and Support, and just grab the auto-detect tool.

      Install your driver.

      *****IMPORTANT****** Before you can use OverDrive you have to accept the user agreement. HOWEVER DO NOT ACCEPT, JUST LEAVE THE AGREEMENT UP AND CLOSE OUT SETTINGS.

       

      If you accept the overdrive as far as I know you have to repeat the whole uninstall process because just reinstalling doesn't clear your accept.

       

      3. Now after reinstalling, and setting up your monitor settings like color scale and scaling pref, and if you left the OverDrive where it shows you just the Agreement, and you didn't accept, you should still be able to use your performance on music and single tab HD Streaming. (Alternatively you can use device manager to just install the basic Microsoft Display Adapter but this one will give you real ugly videos, real slow start menu functionality, and you will have no 3d services)

       

      To Access Device Manager:

      -Right Click on your windows start icon, it will display a menu. Select Device Manager.

       

      -On the next menu you will want to extend the section called Display Adapters.

       

      -Right click on your device and select Update Driver.

       

      -Now select the bottom of the 2 choices

       

      -And then again select the bottom of the 2 choices

       

      -Finally select Microsoft Basic Display Adapter

      -Click the next button and then the Microsoft basic display driver will install, this is the driver your card usually uses when you first hook your graphics card into your computer but haven't yet installed the drivers.

       

      At this point, the OverDrive settings causing graphics blocking can be worked around, and those settings and procedure they follow from install to crash are repeatable for all the driver versions I have tested from catalyst to adrenalin.

       

      I hope this helps, and I'm sorry I haven't been able to get a solid solution, ive been reinstalling windows and graphics for over a month now. I am currently using 18.10.1 and build 1803 for windows(April Update), but the windows version doesn't matter(same thing happens in 1809), the problems with Over Drive are the same, whether you update, downgrade, refresh, clean install, clean install from bootable memory with partition wipe.

       

      **UPDATE 10/27/2018

      After multiple re-installs of Windows the problem is always the same. Whether I install with the graphics out or in. Whether I re partition, reset, or fresh start, AMD settings always crashes at the first load of multiple dynamic or multiple rendering tasks. Then you open Over Drive and its like "Well there is your problem right there. Got yourself a Permanently Jammed Blunderbuss". All joking aside AMD Settings will notify you it has been reset and then Over Drive settings stick your memory clock at 149 MHz.

      PermanentlyJammedBlunderDrive.PNG

      The activity spikes are from me resizing and moving the settings window. When it is stuck like this, those activity spikes from resizing will then freeze the OS until your bios shuts down from temp control or you manually hold your power down. The bad thing is when this type of freezing happens windows then wont start, resulting in me having to reinstall windows from a bootable media because it will not even load past bios, and wont allow me to even enter any type of startup repair.

       

      -Side Note: I removed my dxdiag and msinfo because...well let's just say the few who have viewed it didn't use the info to help.

       

      **UPDATE 11/7/18

      After a few days of reduced performance, and not being able to figure out why my graphics card suddenly would work with settings above what I had previous to initial error and then within minutes block me from even using the non-agreement default settings. These are the settings the card runs at before you click accept to use and change the AMD recommended default clocks(for my card its GPU 300MHz Mem 150MHz, default is 930 and 1150 respectively). I began monitoring what else shares the GPU even when I'm sitting inactive on my desktop. I came across a flickering process named (Rundll32).exe and yea it was in parenthesis. I opened the file location to that and it led me to a process inside WinSxS/AMD64 folder. What really caught my attention was that there was also names inside this folder of controlled environment variables so like the $JIBAJABBA-N8HfF3-etc... Now when I went to remove all these I got a error saying that I don't have permission from Trustedinstaller to do this. Which is funny because I recently just repartioned all of my drives and reinstalled windows, at the time the only 2 programs I had were Windows Defender and AMD settings and then the base system apps. I let windows know I think over a week ago that Trustedinstaller was running with permissions greater than SYSTEM, and the program that kept appearing when my AMD settings would go from working to unstable was the (Rundll32).exe . Well anyways, events in windows system are dated to launch in year 1999....these are the maintinence and defender and all the core events. All the graphics and network related ones are a mess of manual triggers, with variable calls to the Trustedinstaller user who has permissions higher than the only 2 users on my computer(SYSTEM, Administrator). I noticed that my graphics never encountered random crashing while offline(so 3d applications like paint and stuff) would run no problems. However games and dynamic web content would always cause flickering and graphics blocking. So, I went into the data usage per program and found a hidden little "wermgr.exe" application that was hogging data after a fresh install, and appeared after I had 18.9.3 working fine with 930 and 1150 clock settings.

      Wirelessmgr.jpg

      Ethermgr.jpg

       

      After finding out, that the application circled is actually a known worm/virus I searched my computer and found 4 instances of it 1 was nestled in an AMD folder. I wanted to just let you know that I think this worm is originating inside the default windows files under the sections for I think maybe the signed preloaded drivers for initial plug and play of devices. It possibly could make sense seeing as how it may be using a temporary administrator call to create and install these exe in folders named with your detected hardware. Making it seem like it is those very first essential programs needed like the updated AMD settings and for me personally wow and my usb audio controller interface. Well if your curious just look at the following locations of where I have recently found the worm exe.

      cannotremoveTrustedInstaller(user).jpg

      I cannot remove any of those files because I get a UAC warning first, then another warning saying Trustedinstaller had denied my permission(Administrator) to delete the files. So then I went into my computer windows drive properties and attempted to remove the Trustedinstaller user who has more permissions than both SYSTEM and Admins and I got a purple pixel smear, followed by a green screen crash, which then sticks at gathering information at 80%. Which then will restart automatically to black screen, then to a Blue Screen crash and shut down. At this point windows startup is then broken and system restore images are all corrupted and the only way to get back onto windows is to recreate a bootable media from a different computer and repartition and install windows fresh. Whether 1803 or 1809 same systematic flawless running followed by browser loading(blizz app and AMD settings have banners and what not) flicker and then whether it be browser launch or game launch in seconds I get graphics blocking. When I adjust my settings then to get my graphics to work at a reduced efficiency, within about 10-15 minutes my screen flickers black and then graphics block error. When I go into AMD settings after even though there is no notification from AMD about any system failures(which it was doing before) all my settings for overdrive are set back to the highest AMD tested and recommended overclock settings(the settings that I had to reduce to get to work, but also the settings that I originally had before any of this started way back on the 18th of September. I used to always run GPU 930 Mem 1150 power 0% fan Auto, didn't have 1 problem in 4 years. And if you've been following any of my ramblings you would know that I walked away from my computer for a 3 hour period on 9/18/18 and returned to graphics errors. I remember installing the optional 18.9.3 that morning, but I played all day excited at the fact I was able to turn my graphics even higher without suffering any frame dropping. And my computer isn't set to sleep or lock itself after inactivity it only is locked when I turn it on or manually sign myself out or lock it. So something had to update, unfortunately that graphics block error resulted in me having to use a bootable media that was going to wipe my factory defaults and drivers. Applying the idea that this worm was engineered using prior knowledge of known errors in a release with some crafty system logging and script triggers, im sure it could be a clever graphics sabotage. I mean it uses the same system of steps as the windows feature to clear up blurry apps. 1st load of app is to find the what and set the where, and then the second is the execution. Windows blurry app fix uses its first run to set it self all up and change the settings specifically for that app, so the next time you run it, it will also run with specified commands. It would also explain the way the crashing works, in games its usually initial load into map or your first movement that requires out of visual range rendering(for me specifically I noticed in wow when im running settings that are borderline gonna cause the error, I can run my toon at frame control with 0 spikes until I hit that first load of object into range, which then is doubled frozen and power off.

       

      I hope this helps in either narrowing this down, or things to keep in check for the future. I mainly wanted to post on here because I wanted to let yall know it could be a simple a worm but its location of where it runs from, and that it runs triggered by other applications. Makes it seem as if there is a issue with the most recent drivers, software or hardware they got, and makes the company have to waste tons of hours trying to figure out how to break their working masterpiece in the specific way of the affected user. So then they can find a solution to the makeshift problem.

       

      Message was edited by: Mr. Spunion