2 Replies Latest reply on May 6, 2018 7:35 PM by the_slayer

    Freesync does not work on fullscreen

    the_slayer

      Hi there. I am having freesync problems. I must firstly say I have a 144hz monitor. On GTA V, freesync doesn't work completely, it REDUCES the tearing but doesn't delete it.  Now I started playing the old good game called Crysis, and this is the behaviour: if I try to play it in fullscreen, it is a tearing mess. If I try to play it in windowed mode, it is not perfectly centered (other games have this problem too, there is an ampty margin on the left), freesync WORKS but it is a STUTTERING mess. I tried with vsync and it works, but it is useless since I need to play at more than 60 fps and the added input lag is annoying. I did set the fps limiter in adrenalin to 142 and set freesync on "Activated" rather than on "optimized for AMD" (which I don't know what it is for and it caused some issues sometimes).

      I even tried to disable the windows fullscreen optimization but nothing changed. Since windows 10 FCU I have huge stutters in all the games I play, and a lot of people reported it..

      I have a vega 56, ryzen 5 1600, 2x8gb of ram.

      I play on an AOC AG241QX.

        • Re: Freesync does not work on fullscreen
          waltc

          Then turn off freesync, or turn on vsync.  I don't have a freesync monitor and I run in enhanced sync mode, and it preserves 90% of the vsync-off frame rate while only allowing almost no page tearing at all--that is what enhanced sync is designed to do.  Works great on my RX-480 8GB.  @144Hz with vsync on you should get no tearing and 144 fps, too.  Tip: if you set enhanced sync in the game profile, be sure and set the in-game controls to vsync off to get the full benefit.  I have no stuttering at all.

            • Re: Freesync does not work on fullscreen
              the_slayer

              Hey, thank you for the reply. Unfortunately the option to force the radeon settings to disable in-game v-sync does not work at all, the game v-sync is still active if actived in-game. If I set v-sync on in the games, they work at 60 fps (windows monitor setting is set at 144hz), and enhanced sync only works when you exceed the monitor refresh rate. I think if I set the monitor hz on windows on 60, enhanced sync would eventually work, but I can't change between 60 and 144hz everytime (it's not like I want to do it since I don't want to play at only 60 fps), especially since the mouse ponter on the screen is very laggy on 60hz screens.