4 Replies Latest reply on Apr 5, 2018 7:32 AM by elstaci

    OpenCl for AMD RADEON HD 5770 crossfire (Need advice)

    mysterdee

      Just for relevant info, CHeck this website, This states it has OPenCl,

       

      So am i right in thinknig it will support opencl if i install the offerd drivers...

       

      Correct card and everything.

       

      Thanks.

       

                        http://www.hisdigital.com/gb/product2-490.shtml

       

       

       

       

      Hi folk,s Can anybody help me out here, Preferably sum1 who knows what they are doing or sum1 who has had simlar issues or has the same graphics card experience..

       

      this is the issue is have.

       

      i recently overcame an issue i was having with a graphics card (Namely Radeon Crossfire HD 5770 )

       

      The problem i had was i could not get the right drivers installed, And when i eventually got a driver to work, The card was not using its OpenCl. Even though the GPU settings program's where telling me that open cl was installed along with openGl.

       

      Anyway, i eventually, decided to start from scratch, so i uninstalled everything and began a new installation..

       

      i eventually figured out that i could get a stable driver installed simply through window update installing the system drivers for a 5700 Series.

       

      And that got me a graphics card that works,

       

      however. when i wish to use a programme with OpenCl, I get errors stating no openCl installed ect.

       

      So im back to square 2 so to speak.

       

       

      I now an established graphics card with stable driver, But no openCl or Gl for that matter.

       

      Iv checked the drivers, and no opencl being used..

       

      Anyway.

       

      I realise that i could install another installer and go through the last process installing drivers in the hope that il land a driver with OpenGl/OpenCl

       

      But this is where it gets iffy..

       

      My card is a HIS Radeon 5700 crossfire , And the drivers i find are for AMD or ATI, which i installed before and got a drive with opencl showing but not working.. So i dont want to go installing those drivers again and going through the same process as last time, only to end up back where i am now , Tommorow.

       

      So my next option is, the HIS radeon driver from the HIS website..

       

      But again, iv installed these and had driver issues, I actually got no stable driver installed, Even though i was installing the right driver, But this may be due to my corrupting this with numerous downloads of drivers & updates ect.

       

      So should i try the HIS drivers and risk it or is there i better way around, this.

      let me know.

       

      I basically just need OpenCl to be operational, And the knowledge about how to actually get openCl installed alongside my GPU.

       

      From what i understand i need AMD drivers for my GPU that install the OPENCL drivers alongside the GPU, but like i say i tried the drivers that had openCL only to be told no openCl devices found..

       

      So im very unsure as to what i should be doing.

       

      Is there a way to install just openCl and it would append to my driver automaticcaly.. Or am i right in thinking its down to AMD drivers to have OpenCl..

       

       

      Please let me know if anybody has any ideas.

       

       

      My PC is

       

      Dell XPS gen4 Dimension

      3.4Ghz

      2gig ram

      1tb hd

       

      Graphics card is

       

      HIS Radeon HD 5770 crossfire

       

      Am i also right in thinking that normal amd ati drivers will work for the his device , as they are the same device..

       

      Let me know folks, cheers.

       

       

       

      AMD APP which is the latest opencl driver

      Hi folk,s Can anybody help me out here, Preferably sum1 who knows what they are doing or sum1 who has had simlar issues or has the same graphics card experience..

       

      this is the issue is have.

       

      i recently overcame an issue i was having with a graphics card (Namely Radeon Crossfire HD 5770 )

       

      The problem i had was i could not get the right drivers installed, And when i eventually got a driver to work, The card was not using its OpenCl. Even though the GPU settings program's where telling me that open cl was installed along with openGl.

       

      Anyway, i eventually, decided to start from scratch, so i uninstalled everything and began a new installation..

       

      i eventually figured out that i could get a stable driver installed simply through window update installing the system drivers for a 5700 Series.

       

      And that got me a graphics card that works,

       

      however. when i wish to use a programme with OpenCl, I get errors stating no openCl installed ect.

       

      So im back to square 2 so to speak.

       

       

      I now an established graphics card with stable driver, But no openCl or Gl for that matter.

       

      Iv checked the drivers, and no opencl being used..

       

      Anyway.

       

      I realise that i could install another installer and go through the last process installing drivers in the hope that il land a driver with OpenGl/OpenCl

       

      But this is where it gets iffy..

       

      My card is a HIS Radeon 5700 crossfire , And the drivers i find are for AMD or ATI, which i installed before and got a drive with opencl showing but not working.. So i dont want to go installing those drivers again and going through the same process as last time, only to end up back where i am now , Tommorow.

       

      So my next option is, the HIS radeon driver from the HIS website..

       

      But again, iv installed these and had driver issues, I actually got no stable driver installed, Even though i was installing the right driver, But this may be due to my corrupting this with numerous downloads of drivers & updates ect.

       

      So should i try the HIS drivers and risk it or is there i better way around, this.

      let me know.

       

      I basically just need OpenCl to be operational, And the knowledge about how to actually get openCl installed alongside my GPU.

       

      From what i understand i need AMD drivers for my GPU that install the OPENCL drivers alongside the GPU, but like i say i tried the drivers that had openCL only to be told no openCl devices found..

       

      So im very unsure as to what i should be doing.

       

      Is there a way to install just openCl and it would append to my driver automaticcaly.. Or am i right in thinking its down to AMD drivers to have OpenCl..

       

       

      Please let me know if anybody has any ideas.

       

       

      My PC is

       

      Dell XPS gen4 Dimension

      3.4Ghz

      2gig ram

      1tb hd

       

      Graphics card is

       

      HIS Radeon HD 5770 crossfire

       

      Am i also right in thinking that normal amd ati drivers will work for the his device , as they are the same device..

       

      Let me know folks, cheers.

        • Re: OpenCl for AMD RADEON HD 5770 crossfire (Need advice)
          elstaci

          You didn't mention what Operating System you have installed.

           

          Your HD 5xxx series GPU Card is not supported by AMD anymore. The last official driver is from here: Legacy

           

          Found OpenCL 2.0 from AMD but for Windows 8.1: AMD OpenCL™ 2.0 Driver . See if this Catalyst Driver works with your GPU card.

           

          Known Issues from OpenCL 2.0 from link above:

           

          Known Issues

          • Graphical corruption observed while running Sandra subtest bandwidth
          • Adobe Premiere Pro 2014 application hang observed
          • Multi-GPUs not supported on OpenCL 2.0
          • CPU Conformance not supported on OpenCL 2.0

           

          According to the "Known Issues" Crossfire is not supported on Opencl 2.0.

          2 of 2 people found this helpful
            • Re: OpenCl for AMD RADEON HD 5770 crossfire (Need advice)
              mysterdee

              Why thank you for a reply, Your the 1st to actually reply... So thank you.

               

              My OS is

               

              Windows 7 32bit

               

              intel pent 4

              Dell XPS Gen 4 dimension

              460w

              3.4ghz

              2g ram

              1tb hd

               

               

              Like i say in my post, I have managed to get a installer to work and installed the drivers and i got a system settings menu AMD crimson (i think)

               

              And i stated that it did indeed have open Cl , Everything was running fine, only when i tried to use OpenCl in any programs i got NO OPENCL DEVICE , ( i couldn't understand why not as it was saying i had OPENCL in my settings) so i went on a mad installing binge and installed different drivers trying to get open cl recognized, But this messed things up worser and i ended up with no stable driver with a caution next to my driver in manager.

               

              So eventually i wiped everything(drivers&updates) and windows installed update for the driver and i got my driver back with no erros. But standard windows 5700 series.. But no OpenCl..

               

              So im at the point now where i should be installing the correct drivers. but this is my problem, Which blooming drivers...

               

              the HIS web-page shows that opencl is available, so im hoping that its within the drivers.

               

              However, Why did the 1st driver give me full specs (AMD crimson) And should i attempt the same drivers again..

               

              I guess its gonna be a trial and error challenge, But iv trawled the internet finding positive results from other people, But it all comes down to correct drivers and procedure ect,

               

              So like i say iv got a bit of a challenge ahead of me..

               

              But if anybody has had a similar experience and has any good suggestion about how to get openCL working for my GPU i would be very great-full.

               

              In the meantime, Thanks for the advice Elstica.