1 Reply Latest reply on Mar 29, 2018 4:56 AM by axlc

    X crash with Radeon RX560 amdgpu driver 17.50

    axlc

      I have a Radeon RX560 on Linux Mint 18.3. This Linux distribution is normally very similar to Ubuntu and I am able to get packages from Ubuntu's apt xenial repositories.

      I am trying to install the AMDGPU-pro 17.50 drivers.

      My kernel is 4.13.0-37.

       

      The install proceeds with error (I need to edit the amdgpu-install script to replace "ubuntu" with "linuxmint" so that it accepts to proceed with my OS):

      ./amdgpu-install

       

      Then, I reboot and X server fails to start:

      [   744.640] (EE)

      [   744.640] (EE) Backtrace:

      [   744.640] (EE) 0: /usr/lib/xorg/Xorg (xorg_backtrace+0x4e) [0x561f96cb16ce]

      [   744.640] (EE) 1: /usr/lib/xorg/Xorg (0x561f96aff000+0x1b6a69) [0x561f96cb5a69]

      [   744.640] (EE) 2: /lib/x86_64-linux-gnu/libc.so.6 (0x7f2cd7a02000+0x354b0) [0x7f2cd7a374b0]

      [   744.640] (EE) 3: /opt/amdgpu/lib/xorg/modules/libglamoregl.so (glamor_init+0x168) [0x7f2cd57d0338]

      [   744.640] (EE) 4: /usr/lib/xorg/modules/drivers/modesetting_drv.so (0x7f2cd600d000+0x7860) [0x7f2cd6014860]

      [   744.640] (EE) 5: /usr/lib/xorg/Xorg (AddScreen+0x101) [0x561f96b53131]

      [   744.641] (EE) 6: /usr/lib/xorg/Xorg (InitOutput+0x3f1) [0x561f96b97521]

      [   744.641] (EE) 7: /usr/lib/xorg/Xorg (0x561f96aff000+0x57c24) [0x561f96b56c24]

      [   744.641] (EE) 8: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xf0) [0x7f2cd7a22830]

      [   744.641] (EE) 9: /usr/lib/xorg/Xorg (_start+0x29) [0x561f96b41069]

      [   744.641] (EE)

      [   744.641] (EE) Segmentation fault at address 0x561f96c9f3b0

      [   744.641] (EE)

      Fatal server error:

      [   744.641] (EE) Caught signal 11 (Segmentation fault). Server aborting

      [   744.641] (EE)

      [   744.641] (EE)

       

      My graphic card says:

      inxi -Gx

      Graphics: Card: Advanced Micro Devices [AMD/ATI] Baffin [Radeon RX 550 640SP/ RX560] bus-ID: 01:00.0

      Display Server: X.org 1.18.4 drivers: (unloaded: fbdev, vesa) FAILED: amdgpu

      tty size: 430x90 Advanced Data: N/A out of X

       

      I have also tried with kernel 4.10.0-42 and get the same X crash.

       

      Previously, I managed to get the 17.40 drivers working with another kernel, but I don't know what has changed, and I can't it to work anylonger.

       

      Help appreciated!

       

       

        • Re: X crash with Radeon RX560 amdgpu driver 17.50
          axlc

          I just solved the issue.

          In /usr/share/X11/xorg.conf.d:

          backup the configuration files 00-amdgpu.conf and 10-amdgpu.conf (in my case) and remove them.

          For example:

          sudo mv 00-amdgpu.conf 00-amdgpu.conf.bak

          sudo mv 10-amdgpu.conf 10-amdgpu.conf.bak

           

          Then, restart MDM: sudo service mdm restart

          X started ok in my case.

          Hope this solves issue for other users.

           

          Would be good though that AMD debugs those drivers install a bit better though...