0 Replies Latest reply on Jan 21, 2018 12:12 AM by lax

    BSOD on Windows 10 - Disappearing SATA AHCI Driver - Solution

    lax

      Just want to share a problem that kept crashing my machine and creating BSOD on reboot with INACCESSIBLE BOOT DEVICE for a whole month.

       

      It seems that Windows 10 will erase the AHCI SATA Driver (ahcistore.sys) every once in a while . Probably related to sleep. It tries to find a suitable alternative, can't find one and thus renders your system unusable. A reboot will give you an unfixable BSOD with INACCESSIBLE BOOT DEVICE. This will happen even if you set windows NOT to update device drivers automatically or not to install updates right away.

      Funny enough, a system restore works. So system restore will use standard IDE drivers, but can't figure out that there are no SATA drivers in the system. Ugh.

      I discovered this after a month of painstaking reboots and constant backups and restores.

      I found two solutions that worked (for me)

      1. My motherboard - ASRock X379b Taichi - has SATA connectors for ASMedia. This is for RAID. Connecting to those and installing ASMedia drivers worked. However, the drives are listed as EJECTABLE. Not perfect
      2. I found old AMD SATA drivers in the AMD-chipset-drivers. They are not installed automatically (AMD just relies on MS). But they seem to work and the system has been stable ever since.

       

      I suspect that the Spectre and Meltdown correction code are somehow involved. Once they got installed, my system went unstable.

       

      Hope this helps other people

       

      * Here's my saga for those interested: Month of BSOD – Thanks Microsoft and AMD – Amar Musings