6 Replies Latest reply on Mar 16, 2018 2:22 PM by pokester

    Radeonsettings.exe - Application error

    jaksha

      Hi all, after updating Windows 10 to Fall Creators Update i started getting this message on boot. I have tried reinstalling drivers but it did not help. I have windows 10 pro, R9 Fury, amd ryzen 1600x and asus c6h. tried to goolge the error but no success.

      Here is a screenshot of the message, error 0x0000142

       

      Capture.JPG

        • Re: Radeonsettings.exe - Application error
          elstaci

          You didn't state what driver you currently using. Here is the link to download the latest driver for the Desktop R9 Fury series GPU card from AMD Support: Desktop

           

          Make sure your Windows 10 is fully updated via Windows update including the "Optional" downloads. Otherwise your AMD driver may not work correctly or install.

          Make sure to use DDU (latest version) in safe mode to uninstall the current AMD driver. After rebooting install the latest AMD driver full set.

           

          You also may want to check to see if you have the latest BIOS for your motherboard. It is possible Asus added a new BIOS to download to make the motherboard more compatible with the latest Windows 10 version.

           

          If your motherboard is ROG CROSSHAIR VI HERO, I googled the Asus C6H and it seemed to indicate that Asus motherboard. There is a relatively new BIOS for the motherboard for the above mentioned:

          BIOS

          Version 17012017/10/035.67 MBytes

          CROSSHAIR VI HERO BIOS 1701
          Improve system stability.

          Plus a AMD Chipset for the same motherboard:

          Chipset

          Version 9.0.000.82017/06/141.3 GBytes

          AMD Chipset Driver
          AMD Chipset Driver V9.0.000.8 for Windows 10 64-bit.(RS2)

          1 of 1 people found this helpful
          • Re: Radeonsettings.exe - Application error
            jaksha

            I have the latest drivers, 17.11.4. Used DDU in safe mode, windows is fully updated, i had the BIOS and chipset installed before fall creators update.

            I did all the things you mentioned above, either it is an drivers issue or something went wrong during the installation of FCU, my windws copy is relatively fresh installed, it has been 4 months since i installed it and it has been working without any issues until the update.

              • Re: Radeonsettings.exe - Application error
                elstaci

                Try installing a earlier driver. The latest drivers seems to have some issues. Some one else in this forum with a R9 Fury may be able to assist you with recommending the best driver for this GPU card in Windows 10. I have heard from previous posts that 17.11.1 is fairly stable.

                1 of 1 people found this helpful
              • Re: Radeonsettings.exe - Application error
                ceratx18

                Hi,  I had the same error message for months, and found this post via google. So here is what helped me:

                 

                In Dec 2017 I updated my Windows 10 to the Fall Creators Update and the latest AMD drivers for my R9 380.

                 

                After that I always got the same error message after each PC reboot: "RadeonSettings.exe - Application Error. The application was unable to start correctly (0xc0000142)."

                 

                It did not seem to have any negative effects (my Radeon Settings worked just fine), but I could not get rid of this error message even with a DDU driver uninstall and then installing all the latest AMD drivers (17.12, 18.1, 18.2.1, 18.2.2 ...) again and again.

                 

                Today I stumbled over a reddit post with the solution for my problem: I had to disable the  "use my sign-in info" option (Windows Settings > Accounts > Sign-in Options > "Use my sign-in info to automatically finish setting up my device..."), which was apparently introduced in the Win 10 Fall Creators Update. After disabling that option, the strange error message after reboots finally disappeared for me.

                 

                 

                edit:

                I occasionally see the "RadeonSettings.exe - Application Error" message while rebooting still. I think it happens after playing a game like Overwatch where my Radeon settings host application crashes during the game and restarts automatically. After that I get the boot error message again.

                However it does not happen all the time like before, so I guess the aforementioned procedure (disable "use my sign-in info) still helped.

                1 of 2 people found this helpful