5 Replies Latest reply on Nov 1, 2017 3:29 PM by jigzaw

    Asrock Motherboard ab350 and USB problems

    x58

      Hello everyone sorry for bother this community with my Issue, but even Asrock forums seems not to help or ignore my sitatuation, also i wanted to apologies for my poor English-grammar, vocabulary, my main language is Spanish.

      But backing to the topic, is   that,  I-m having a problem with my mouse g9 and keyboard g15,  it seems that this motherboard or bios are forcing all usb ports included  2.0 usb  to work as 3.0 usb ports, it may sound like a joke but is not. the day that I realise that i was having a Issue, was when I downloaded a software made for my motherboard, the software was: F-stream which this software allow pc users to connect exclusively mouses in the port usb 2.0 with the F-stream technology, wish i ensure that i connect my mouse in that port, them I realise that there was a problem, because when I downloaded the software and run it, the software was like missing a option for my mouse, like the features that allow my mouse to changes hertz,polling rates, where not there, and i double check my motherboard+manual indications and yep, effectively for any reason this motherboard or bios were locking the usb ports 2.0 functions
      Also i notice that something was not okay, when tried to Install Windows 7 by using the USB-TOOL-CREATION made by my motherboard, which is a tool that brings drivers for mouse and keyboard to allow usb 2.0 or 3.0 to install Windows 7 without using a PS/2 mice, when i use that USB-tool and put the windows 7 and make the pendrive booteable, i notice that, that didn't work..
      like i wasnt able to use my keyboard in any usb ports, included mouse

       

      Another thing that I discovered was that both windows even 7 or 10 there were detecting my g9 and g15 as 3.0 usb...and prompting a message like this:

      message.png

       

       

      And them i went to a software called HWINFO64 to check the USB ports speed and stuff, and it clearly says that G9 and g15 are running on 1.1 speed. and support 2.0
      g9-logitech

       

      help1.png

       

       

      G-15 Keyboard
      help2.png

       

       

       

       

       

      Also in G-15 keyboard there is a hub that is running full speed on 1.1

       

      help3.png

       

       

      Also when all this say, it seems that my asrock ab350 chipset with latest bios 3.20  sees to be hidding some Mouse features that appears in my manual, but of course the manual shows a date of 1 january, when i got this motherboard was in may 18, with bios 1.40, now i have 3.20 , but even that, why would they hidden Mouse features?

       

      See the manual indicated that it has options like:
      USB-Controllers
      Legacy Usb Support
      usb 3.0 Controller
      XHCI LEGACY Support
      And all that options are like missing , in my actual bios screen
      bios.png

       

       

       

      Them i decided to Download a program called  AMIBCP Version 5.02.0023 which is an editor, so i loaded there original latest bios from my motherboard which is 3.20 version
      Them I discovery that there are many Mouse Options and features that seems to be Either forced Enable, or disabled, I really wants to have a accurate mouse, I can use any logitech software to increse mhz, or dpi, but thats not helping ,is like every mouse i connected here in this pc, seems to be affected, i didn-t have this problem before on my old MSi-h55-e33 intel...
      So what i can do?I cannot enjoy anymore gaming, also seems like there is visual lag, when playin games =/ i-m totally sad u.u

       

      If you can click on this picture below,  you will see that even it says (yes) show, it doesnt shows... i cannot select XCHI hand off, or EHCI or none of that options to test my mouse or keyboard

       

      editor.png

       

       

       

       

      Hope someone can help me, i really sorry for my poor english or repeated vocabulary, but i need help
      This is my actual bios pictures that i take, all that options are default, i didn't modify anything.

      I had to upload to mediafire and compressed with 7zip there are 46 pictures of the whole bios all is default.
      Thanks for your time.

       

       

      http://www.mediafire.com/file/264dbklkv5a3dq5/MyBiosPicturesDefault.7z

        • Re: Asrock Motherboard ab350 and USB problems
          jigzaw

          I have the same motherboard as you have. I had no issues connecting my keyboard, Kensington expert mouse and Eaton UPS usb anywhere to usb 2.0 or 3.0 ports. However when I changed my my UPS to a 1000Va Aglion VX that used ViewPower monitoring,  the usb ports got bad. The reason is that the ViewPower monitoring uses Java that won't run properly on FireFox or MS Edge and reverts to IE11 that caused extra CPU load on my system. Is there an java based utility that is connected to your USB ports?

            • Re: Asrock Motherboard ab350 and USB problems
              x58

              Hello Jigzaw thanks for commenting, do you us windows 10 like me? and if so, which version are you running?

               

              Does your mouse and keyboard are usb 3.0? or usb 2.0? also did you install your AMD USB drivers and again what OS version you use?
              And what happen if you go to devices and printers and trouble-shooting the mouse and keyboard, does it prompt the same message? and what bios version do you have? sorry for many question

               

              Also do you use UART in bios, what are those options, are them necessary? i'm very noob when comes to AMD things
              Did you just check my bios 7zip all settings, are like default i didnt touch any setting

               


              Also in this motherboard i only have plugged these compones: 2 Patriot memory 3200 16-16-18 2x4 gb (8gigs total)
              In PCIE EXPRESS 3.0 Silver x16 i connected the EVGA GTX 1060
              Them i connected an external chasis fan that i buy to use as exhaust in the rear, to push the warm air

               

              And everything is just.... the PSU Molex for SSD and HDD, and CPU connector, the POWER 24 pins, the Fan cooler cable, the audio HD
              And nothing else...

               

              I mean i don't use any external ethernet card or sound card....... so I dont know what are those UART options in bios, are they neccesary for better performance? because those options came all disable like i show in my bios

               

              url bios:

              http://www.mediafire.com/file/264dbklkv5a3dq5/MyBiosPicturesDefault.7z

                • Re: Asrock Motherboard ab350 and USB problems
                  jigzaw

                  I mistook your AB350 for  Asrock AB350 PRO4. There are similarities though. My mouse and keyboard is plug on the 2 black usb 2.0 port which is in line with the violet/green PS2 port. I purchased 4 Port USB A Female Slot Plate Adapter - USB panel - 4 pin USB Type A (F) USBPLATE4 which was connected to USB_1_2  and USB_3_4 on the bottom of the motherboard for extra USB 2.0. I connected my 3D Connexion SpaceNavigator, Microsoft LifeCam HD-3000 and ups usb connection on this.

                   

                  I set everything to the default setting on bios 2.60 (AGESA 1.0.0.6) as I didn't overclock my Ryzen 7 1700X. What I did set is my memory for the XMP and rated it at 2933 Mhz and at the rated 1.35V DRAM Voltage on my G.Skill 32GB kit F4-3000C14D-32GVK. Yours should work with this settings and go further to 3200Mhz as its rating.

                   

                   

                  I am using W10 Fall Creators Update OS. Leave other settings on bios untouch on the chipset features till you resolve your USB problems.

                    • Re: Asrock Motherboard ab350 and USB problems
                      x58

                      Yeah i have a AB350 asrock fatality k4 gaming, or motherboards are pretty similar, by the way, why would you use a bios 2.60 while there is avalaible 3.20 for yours motherboard too?

                       

                      And yeah as i said bios came like default and most options disable, all i do was to Disable SMT and Cool-quiet to avoid C-states, and xmp profile 3200, and processor went from 3.2 to 3.7  and voltage cpu from 1.2 to 1.3 on my ryzen cpu 5 1600,  and HPET auto, windows let decide

                       

                      But yeah i was using 1607 because the 1703 creator was too bad with glitches i havent tried the last fall creators update because people says that is under beta fase, and, maybe ill try old bios, becasue the F-STREAM utility that came with my fatality usb 2.0 ports functions doesnt work see the F/stream for my motherboard
                      The Tools tabs appears in the f/stream and yeah i have connected my mouse to usb 2.0 f-stream

                       

                       

                      CjhpFDECTR_7n2vBEC72CA.png

                       

                      This is my F-stream tool you clearly can see that there is not Tool<-- option.plop.png

                       

                      So probably i dont know the f-stream or 2.0 usb ports, are not working with that technology and thats the reason that when tried the USB patch 1.2 for install windows 7 on ryzen, it also doesnt detect the usb ports 2.0 aff im tired of this motherboard.....

                        • Re: Asrock Motherboard ab350 and USB problems
                          jigzaw

                          3.00 was boosting bus past 100 MHz while raising CPU voltage when I had the problem with ViewPower java applet issue. 3.20 seems to rectify that but observe that 2.60 was more stable if I bump the memory speed to 3066MHz.

                           

                          Likewise I installed the 17.30 chipset drivers when it came out Chipset from AMD driver support. I didn't disable SMT or Cool N Quiet as I didn't overclock the 1700X.

                          I didn't have crashes and stable enough to work on my 3D cad projects all day with open apps Windows Mail, FireFox and Foxit reader for CAD pdf reference which was around 100 MB. I tweaked the ryzen power plan to reduce minimum percentage from 90 to 81%

                           

                          Initially I had a 1700 that I tried to overclock a bit by raising the clock to 3.5GHz but there are lot of work to get sleep working, down clocking at low load like tweaking P-States. If something goes wrong it takes up too much time to fix.

                           

                          AB350 PRO4 came with Asrock A-Tuning utility that is suppose to be a version  of the F-Stream for my motherboard, but didn't seem to work either maybe be because I was using the 1700 then which wasn't the X model.

                           

                          Ontop of that you an option for Ryzen Master that actually works better but as I rather keep it simple.