AnsweredAssumed Answered

1950X stuck as 4C/8T - Ryzen Master won't apply changes

Question asked by jamesomega on Oct 16, 2017
Latest reply on Oct 20, 2017 by amdmatt

I've got a weird disabled/locked core problem.


After applying the Game Mode profile in Ryzen Master on Win10 x64, my 1950X is stuck in a 4C/8T mode. When I first applied it and rebooted, my MSI x399 Gaming Pro Carbon AC would black screen and wouldn't boot past Post Code 07 until I cleared the CMOS. After loading BIOS (7B09v15) defaults and confirming my 16 core count, I power cycled (C0 warm reboot due to MSI) back into windows and it still only shows 4C/8T. Applying the Creator Mode profile and rebooting doesn't do anything at all. The only change I can make from the BIOS is setting the Memory Access modes. No other settings stick.


So far I've tried:


- Uninstalling all AMD chipset software and Ryzen Master and then re-flashing my BIOS (which freezes with C0 when it completes and tries to reboot- MSI problem).
- Downcore control only goes up to 3+3 but the motherboard gets stuck on post code 01 until the CMOS is cleared and reset back to Auto.

- Tried to apply other profiles in Ryzen Master, but it remains 4C/8T.


My BIOS is is ID'ing my 1950x correctly and windows task manager confirms "16 cores" in the name but Ryzen Master won't enable my cores after shutting down/restarting.


Is my only worse case scenario solution to wipe the system and reinstall Windows? This seems like a serious software issue to me rather than a BIOS one.


Thanks in advance if anyone has any other ideas I can try.