23 Replies Latest reply on Jan 28, 2018 8:07 AM by sylverion

    Atikmpag.sys on Windows 10 w/ RX Vega 56

    judge_dredd_3d

      Hi there guys,

      This has been driving me crazy for an entire week.

      I purchased a Sapphire RX Vega 56 from Amazon.

      Tried to install it on my PC with Windows 10.

      Before installing it did the usual,

      Boot in Safe mode, run DDU,

      Restart install Drivers 17.9.3 and BAM! BSOD atikmpag.sys

      Tried everything for 2 days, watched Youtube tutorial, online solutions ETC.

      Rolled back to old drivers and same result.

      SO... I did a fresh Windows 10 install, installed only the Intel.inf and tried installing 17.9.3

      SAME atikmpag.sys... So I fully updated Win 10 and tried again... Same result!!!

       

      I'm a broken man , Fresh install on windows 10 TWICE!!! multiple versions of drivers with a Brand New RX Vega 56 and can't use it at all!!!

      What kind of diabolical game is AMD playing!

       

      FYI,

       

      Intel Xeon X5690 not OC

      Corsair gtx110i AIO

      EVG X58 SLI LE Latest Bios

      12GB GSskill DD3 2133 runnung at 1333

      2x 500GB SSD Samsung Evo in Raid 0

      Corsair AX860 psu

      Sapphire RX Vega 56, stock bios.

      Windows 10 Pro, fresh install, after a fresh install (full format)

       

      Drivers:

      AMD 17.9.3, 17.9.2, 17.9.1 used

      Intel.inf from Intel website and from EVGA site

      latest DDU on Safe mode used.

       

      How is it possible that this is broken?!