Stop Windows 10 Automatically Updating your AMD Graphics Drivers.

Discussion created by colesdav on Sep 27, 2017
Latest reply on Mar 7, 2019 by colesdav


I have been having some fun installing latest AMD Graphics Drivers on Windows 10 64 Bit OS recently.
I have a copy of Windows 10 64bit OS that I had kept just for DX12 Testing so I did not have to use Windows 10 64bit it much, since there are hardly any DX12 Titles anyhow.


Now unfortunately I have to use Windows 10 64bit to test the latest DX11 drivers from AMD since AMD have dropped support for Windows 8.1 64bit OS 5 years early.


Note 1:  I am seeing DX11 Games & Benchmarks perform worse on Windows 10 64bit than on Windows 10  8.1 64bit, on the same machine i7-4790K & 3 R9 Nano (FuryX) cards.
Note 2:  I have switched Windows 10 Gaming Mode off ... so that games and graphics applications actually run better.
Note 3:  All Windows 10 64bit "Privacy" Options have been turned on, for what that is worth.



Windows 10 64bit seems to have a mind of it's own when it comes to installing AMD Graphics Drivers, especially if I am installing older versions of AMD Crimson ReLive.


I have hit cases where I uninstall AMD Driver, reboot, run amdcleanuputility.exe, reboot, download and install a particular AMD Driver, reboot, only to find that I have a different version of the AMD Driver installed than I intended or a "mish mash" of driver components.

Here is a way to prevent Microsoft Windows 10 64bit from applying it's own idea of what should be on your machine.


1. Open Control Panel.

2. Search for Advanced.
3. Go to View Advanced System Settings.
4. Click the Hardware Tab.
5. Click Device Installation Settings.
6. Select No.
7. Save Changes.


Here is a picture:



Once you have done that and you install AMD Crimson Relive version you want, make sure to double check the software version you have is correct in the following Overview TAB, I also suggest you check the Software Tab in detail as well.




Note doing the above can be quite a pain when you connect new hardware to your Windows 10 64bit device, such as a new USB3.0 Drive etc, as you will have to install drivers manually unless you change the above settings back. Once you have your new hardware drivers installed. Change the above settings back again.


The other better workaround is  stay on Windows 8.1 64bit, in which case you will have to purchase an Nvidia Card, or longer term move from Windows 10 64bit to Linux.