20 Replies Latest reply on Oct 3, 2017 9:07 AM by thefireknight

    Ryzen Balanced power plan does not allow standby

    thefireknight

      Hi all,

       

      Although it's not a major issue, I'd like to point out that my system does not go into standby when I activate the Ryzen Balanced power profile.

      This issue has been present since the power plan first came out. I've already reinstalled Windows 10 once and the issue remains.

       

      Here's my system configuration (built in early April):

      AMD Ryzen 7 1800X - with Cryorig R1 Ultimate

      Asus Crosshair VI Hero with 1602 BIOS

      G.Skill FlareX 16GB DDR4 3200

      EVGA GTX 1050 Ti FTW (temporary graphics card )

      EVGA 850 P2 Platinum PSU

      Samsung 960 Pro 512GB w/ Alphacool HDX M.2 cooler - latest firmware

      Seagate Firecuda 2TB HDD

      NZXT Noctua 450

      Windows 10 Pro 1703 latest updates

      Razer Diamondback Chroma

      Roccat ISKU+ Force FX

      LG BE16NU50 BD Writer

      Samsung CFG70 24" Monitor

       

       

      I'm willing to try out suggestions if anyone wants to help solve this issue.

        • Re: Ryzen Balanced power plan does not allow standby
          parsec_

          Do you mean the PC will not go into S3 Sleep mode, Windows Sleep automatically, with the Ryzen Balanced Power Plan?

           

          If that is the situation, that is caused by the Sleep option in the Advanced settings of the Ryzen Balanced Power Plan being set to Never by default.

          Can you manually enter Sleep mode? Sleep works fine with my Ryzen PC.

           

          You can change the Sleep setting if you click on Power Options, then select Additional power settings, and then click on Change plan settings for the Ryzen Balanced Power Plan.

          At this point, you should see the Put the computer to sleep: setting displayed, which will be set to Never. Change it to whatever you like.

           

          On that screen, you could also click on Change advanced power settings, and in the list of settings open the Sleep option. Open the Sleep after setting, which you'll find is set to Never. Change Never to whatever you want for the time before the PC enters Sleep automatically.

           

          Why Sleep after is set to Never in the Ryzen Balanced Power Plan, I don't know. That is the default setting for the Windows High Performance plan.

            • Re: Ryzen Balanced power plan does not allow standby
              thefireknight

              Thanks for the answer, but nope. That was the first thing I tried.

               

               

              I've also tried cloning the High Performance power plan and then setting the Minimum processor state to 5% (High Performance doesn't park cores), but same result.

              The system doesn't go into S3 Sleep automatically. I've also tried shorter timings than 30 minutes but no go.

              I've also tried a few things by cloning the Balanced power plan.

               

              The system will enter Sleep mode if I do it manually through the Start menu.

               

              I've also tried cloning the two power plans and setting all the settings equal (so that the only difference is core parking) and I believe that core parking is the culprit.

               

              Power plans with core parking disabled do not enter S3 Sleep, whereas if the core parking is enabled automatic Sleep works.

               

              Could this be a BIOS issue or maybe a Windows 10 issue?

            • Re: Ryzen Balanced power plan does not allow standby
              stacey.leibermann

              In an elevated command window, run this:

               

              powercfg -requests

               

              Report back what it says.  You can output this to a file by adding >C:\Folder\To\File\Name.txt if you want to just copy-paste it from Notepad.

               

              Step 1 is to figure out what is stopping it from sleeping; it's very likely some roque hardware that, when it's being allowed to get into a lower power state, it's waking and resetting the sleep timer.

                • Re: Ryzen Balanced power plan does not allow standby
                  thefireknight

                  Ran the command and the output doesn't seem to have any clues. I ran it after the timer should have put the system to sleep. The power plan was set to the Ryzen Balanced.

                  Here's the output:

                   

                  DISPLAY:

                  None.

                   

                  SYSTEM:

                  None.

                   

                  AWAYMODE:

                  None.

                   

                  EXECUTION:

                  None.

                   

                  PERFBOOST:

                  None.

                   

                  ACTIVELOCKSCREEN:

                  None.

                    • Re: Ryzen Balanced power plan does not allow standby
                      stacey.leibermann

                      What happens if you set the sleep time to like 1 minute?  It seems very odd that your computer CAN sleep (manually), but windows isn't going to sleep for no reason.

                       

                      Try that, and run that same command a few times; this is the first time, personally, that I've seen that command not report (some potentially cryptic) answer for why the computer isn't sleeping.

                       

                      Edit: So, I did some Googling, and it seems that the command I provided doesn't necessarily include all devices.  Found it on here:

                      https://support.microsoft.com/en-us/help/976877/windows-7-does-not-go-to-sleep

                      ... namely, the section that involves "Powercfg -devicequery wake_armed". You could try disabling all of those one-by-one, see if the PC goes to sleep.  If it does, you'll know which of them is causing the issue, and maybe just disable that device's power-saving features, or hunting down a driver issue.

                    • Re: Ryzen Balanced power plan does not allow standby
                      thefireknight

                      I tried it again with a short time interval (2 minutes) and I still get the same result.

                       

                      As usual, if I switch to the MS Balanced power plan the system goes to sleep. If I use the High Performance with 2 minute timer (no core parking) the system does not go to sleep (just like the Ryzen plan).

                        • Re: Ryzen Balanced power plan does not allow standby
                          stacey.leibermann

                          Did you try the part I mentioned after "Edit" ?

                           

                          Random other thing: did you install the Samsung NVMe driver?

                            • Re: Ryzen Balanced power plan does not allow standby
                              thefireknight

                              I don't see the part after "Edit".

                               

                              Yes, I am using the Samsung NVMe 2.2 driver. Normally unless there's a major issue I keep everything updated to the latest.

                                • Re: Ryzen Balanced power plan does not allow standby
                                  stacey.leibermann

                                  No idea: here it is ...

                                   

                                  Edit: So, I did some Googling, and it seems that the command I provided doesn't necessarily include all devices.  Found it on here:

                                  https://support.microsoft.com/en-us/help/976877/windows-7-does-not-go-to-sleep

                                  ... namely, the section that involves "Powercfg -devicequery wake_armed". You could try disabling all of those one-by-one, see if the PC goes to sleep.  If it does, you'll know which of them is causing the issue, and maybe just disable that device's power-saving features, or hunting down a driver issue.

                                    • Re: Ryzen Balanced power plan does not allow standby
                                      thefireknight

                                      Here's my list from running "Powercfg -devicequery wake_armed"

                                       

                                      Razer Diamondback

                                      HID Keyboard Device

                                      Razer Diamondback (002)

                                      HID Keyboard Device (001)

                                      Xbox Gaming Device

                                      Intel(R) I211 Gigabit Network Connection

                                      HID-compliant mouse (001)

                                       

                                      I'll remove the game controller and try disabling what's possible one at a time. I've got a MS mouse and keyboard that I can plug in instead.

                                        • Re: Ryzen Balanced power plan does not allow standby
                                          stacey.leibermann

                                          You don't have to disable the actual devices, you just have to disable powercfg's monitoring of those devices to keep your PC awake.

                                           

                                          If it was me, I'd disable all of them through powercfg ... then add them back one at a time.

                                            • Re: Ryzen Balanced power plan does not allow standby
                                              thefireknight

                                              Ok, so it looks like we're getting somewhere. I disabled all the devices and the system went to sleep for 15 seconds then it woke back up.

                                               

                                              This is what I ran.

                                               

                                              PS C:\Windows\system32> Powercfg -requests

                                              DISPLAY:

                                              None.

                                               

                                              SYSTEM:

                                              None.

                                               

                                              AWAYMODE:

                                              None.

                                               

                                              EXECUTION:

                                              None.

                                               

                                              PERFBOOST:

                                              None.

                                               

                                              ACTIVELOCKSCREEN:

                                              None.

                                               

                                              PS C:\Windows\system32> Powercfg -devicequery wake_armed

                                              Razer Diamondback

                                              HID Keyboard Device

                                              Razer Diamondback (002)

                                              HID Keyboard Device (001)

                                              Intel(R) I211 Gigabit Network Connection

                                              HID-compliant mouse (003)

                                               

                                              PS C:\Windows\system32> Powercfg /DEVICEDISABLEWAKE "Razer Diamondback"

                                              PS C:\Windows\system32> Powercfg /DEVICEDISABLEWAKE "HID Keyboard Device"

                                              PS C:\Windows\system32> Powercfg /DEVICEDISABLEWAKE "Razer Diamondback (002)"

                                              PS C:\Windows\system32> Powercfg /DEVICEDISABLEWAKE "HID Keyboard Device (001)"

                                              PS C:\Windows\system32> Powercfg /DEVICEDISABLEWAKE "Intel(R) I211 Gigabit Network Connection"

                                              PS C:\Windows\system32> Powercfg /DEVICEDISABLEWAKE "HID-compliant mouse (003)"

                                              PS C:\Windows\system32> Powercfg -devicequery wake_armed

                                              NONE

                                              PS C:\Windows\system32> Powercfg -requests

                                              DISPLAY:

                                              None.

                                               

                                              SYSTEM:

                                              None.

                                               

                                              AWAYMODE:

                                              None.

                                               

                                              EXECUTION:

                                              None.

                                               

                                              PERFBOOST:

                                              [DRIVER] Legacy Kernel Caller

                                               

                                              ACTIVELOCKSCREEN:

                                              None.

                                               

                                              PS C:\Windows\system32> powercfg /LASTWAKE

                                              Wake History Count - 1

                                              Wake History [0]

                                                Wake Source Count - 1

                                                Wake Source [0]

                                                  Type: Device

                                                  Instance Path: PCI\VEN_1B21&DEV_1343&SUBSYS_86F21043&REV_00\6&783d3b1&0&0000020B

                                                  Friendly Name:

                                                  Description: ASMedia USB3.1 eXtensible Host Controller (ASM1143)

                                                  Manufacturer: ASMedia Technology Inc

                                              PS C:\Windows\system32>

                                               

                                              I'm currently using the ASMedia 1.16.48.1 driver, but the same happened with 1.16.38.1 and 1.16.47.2 from the Asus support page.

                                               

                                              All devices are still disabled. What do you recommend as the next step?

                                                • Re: Ryzen Balanced power plan does not allow standby
                                                  stacey.leibermann

                                                  If you go find that item in your Device Manager (Probably USB Controllers ->ASMedia USB3.1 eXtensible Host Controller) ... in the "Power Management" tab, can you deselect "Allow this device to wake the computer"?

                                                   

                                                  Edit: or maybe try uninstalling that driver totally.  Or maybe try moving devices off of that controller (in device manager, click "View->Devices by Connection" ... find the USB controller, and you'll see what is connected to it.

                                                   

                                                  MAYBE having your keyboard on the 3.0 controller instead of the 3.1 controller will fix things (for example).

                                                    • Re: Ryzen Balanced power plan does not allow standby
                                                      thefireknight

                                                      By process of elimination I was able to figure out what's actually causing this.

                                                       

                                                      I put in Bold the device that is the problem.

                                                       

                                                      PS C:\Windows\system32> Powercfg /DEVICEDISABLEWAKE "Razer Diamondback"

                                                      PS C:\Windows\system32> Powercfg /DEVICEDISABLEWAKE "HID Keyboard Device"

                                                      PS C:\Windows\system32> Powercfg /DEVICEDISABLEWAKE "Razer Diamondback (002)"

                                                      PS C:\Windows\system32> Powercfg /DEVICEDISABLEWAKE "HID Keyboard Device (001)"

                                                      PS C:\Windows\system32> Powercfg /DEVICEDISABLEWAKE "Intel(R) I211 Gigabit Network Connection"

                                                      PS C:\Windows\system32> Powercfg /DEVICEDISABLEWAKE "HID-compliant mouse (003)"

                                                       

                                                      This corresponds to the Roccat keyboard

                                                      What's interesting is that once this component of the keyboard was disabled, the system was able to go into standby but now it will no longer allow me to enable this device (either from the command line or from the device properties).

                                                       

                                                      I'm going to try rebooting the system to see if the setting sticks or if it decided to reset itself.

                                                        • Re: Ryzen Balanced power plan does not allow standby
                                                          thefireknight

                                                          Ok, so I rebooted the system and "HID Keyboard Device" was re-enabled.

                                                           

                                                          The strange thing is that now the system goes into standby!

                                                          After the reboot the keyboard software noticed an update (no driver update though) and it seems the issue is gone.

                                                           

                                                          The device still shows as enabled.

                                                           

                                                          I'm still curious as to what the root cause could be.

                                                            • Re: Ryzen Balanced power plan does not allow standby
                                                              stacey.leibermann

                                                              Try the "powercfg -devicequery wake_armed" command again; maybe device manager shows stuff enabled, but it's disabled internally or something.

                                                               

                                                              Lots of weird things happen with sleep; sleep states aren't always defined properly/sometimes device manufacturers just don't care (I have a cheap Bluetooth dongle that does this), or that keyboard has it's own USB hub that has some goofy keepalive feature, or it has some other goofy internal functionality that keeps asking the PC for state information ... who knows.

                                                               

                                                              I also wonder if, when you disable the "host" device's ability to wake the computer, if it also disables the "child" devices; that keyboard has a lot of features (or, internal hardware devices, essentially) that maybe are controlled by Windows software?  Maybe one of those random features is no longer able to wake the PC (go one-by-one to those child devices to see if they're not able to wake now).

                                                               

                                                              Regardless, happy to hear you've sorted it out.