8 Replies Latest reply on Sep 13, 2017 8:31 PM by hardcoregames™

    USB performance/connectivity issues on Threadripper 1950x

    ssuski

      Just got a new Asus Zenith Extreme setup with AMD 1950x processor. Build is lightning fast, but is experiencing some strange USB connectivity issues. We use a secure USB hardware key that is checked by our software at various intervals. During certain testing, this is stressed a significant amount and are seeing both exponentially reduced performance as well as random errors and disconnects. This USB device is used by our company on a daily basis, as well as by thousands of our clients, without issue. We have a new AMD Ryzen machine with an equivalent ASUS ROG motherboard that is not experiencing these issues.

       

      So far I have tried just about every available BIOS (0305, 0503, 0601, 9980, 9906, and 9910, 0046) to no avail. I've also tried installing a separate PCIe USB 3.0 card, but experience the same issue (interestingly enough, the card which is PCIe x1 would only work at all if it was in an x16 slot, not the x1 or the x4). Have also tried disabling all other USB ports except for those on the add-on card, changing PCIe modes, etc., but that didn't change anything either. I've tried the fix that some people were seeing benefits from of disabling and removing 'useplatformclock' via bcdedit, with no change.

       

      Being that it's affecting both onboard USB and external PCIe USB adapters, it seems like it could be a chipset driver issue (currently have latest installed). Is anyone else seeing similar issues? Does anyone know if there were major differences for these subsystems vs those on Ryzen chips (our issue is not present on the Ryzen system)?