14 Replies Latest reply on May 8, 2018 3:22 PM by globalrebel

    RX Vega 64 BSOD on driver install

    dvcelica

      I picked up an MSI Vega. When I install the card and try to install the 17.3 package from msi, or the 17.8 package from AMD I will get the BSOD about halfway through the driver installation. If I force windows to find and install the appropriate driver through device manager, It will also BSOD as it installs the driver. This card has done this on 3 seperate machines. I have had no problem installing the 17.3 package or the 17.8 package with my rx470 installed. Just with the vega, right as it tries to refresh the screen with the new drivers. Is this card DOA or is there a known issue with the vega drivers atm?

        • Re: RX Vega 64 BSOD on driver install
          nvs

          Same here, it errors on ATIkmdag.sys and says this driver is not for your system. It's win 10 64,as is the driver package. Does it on a clean windows install with a fresh driver install,exactly as you describe it. Does it on the last driver version also

           

          motherboard is a gigabyte ga-970a-ds3p with current bios

          cpu amd fx 6350

          psu Lepa 1000 watt

          memory 16 gbs ddr3 1600

          Os win 10 64 clean install

          graphics radeon vega xtx

          I know a weak machine for a powerful card, I won it though. I wonder if its not compatible with my mb

          • Re: RX Vega 64 BSOD on driver install
            elstaci

            Don't take my word on this, Since you didn't post your computer specs, But it does sound like your card is DOA. Since it did BSOD on three separate computers. Using both MSI and AMD drivers. I would try and RMA it and get another card.

            Could it be that your Power Supply is too weak and when the Vega starts working it causes a BSOD?

            Maybe someone else may have an idea why your VEGA is causing a BSOD when installing it driver. But you first need to post your computer specs including Windows OS , PSU, etc.

              • Re: RX Vega 64 BSOD on driver install
                elstaci

                After seeing Hotrith posted link, it does seem to be a AMD driver problem. I imagine the best person to know would be RAY_M or AMD MATT.

                • Re: RX Vega 64 BSOD on driver install
                  dvcelica

                  My apologies. My system is as follows

                   

                   

                   

                  i7 3770

                  Gigabyte P67A-UD4-B3 on F8 bios (most recent)
                  16 GB of DDR3
                  MSI RX Vega 64 8gb Aircooled
                  Windows 10 Pro. 64bit - Creators update.
                  750w PSU

                   


                  The other 2 systems I tested in were

                  4790k and fx6350 builds. Both on gigabyte boards, ample ram, the 4790k build supporting pcie3.0. 950w PSU in the amd build, 1200w PSU in the intel build. Both on win 10 pro 64 creators update...both fully updated. both on most recent bios updates also (these systems arent mine so I dont know exactly what mobo is in them etc)

                • Re: RX Vega 64 BSOD on driver install
                  hotrith

                  you guys could indicate this topic, Sapphire RX Vega 64 Watercooled Version, Bluescreen during driver installation since you already answear there and you are having the same issue.

                   

                  AMD Issue Reporting Form

                  1 of 1 people found this helpful
                  • Re: RX Vega 64 BSOD on driver install
                    protivakid

                    Just came in to say I have the same exact issue. EVGA x58 Mobo with Windows 10. I get a BSOD error with atikmdag.sys when trying to install the drivers. If there is no fix this card will be going back. Looks like AMD's "awesome" drivers strike again.

                    • Re: RX Vega 64 BSOD on driver install
                      aurean

                      Fixed the issue on a PCIE 2.0 Gigabyte Z68XP-UD3.

                       

                      Updated the BIOS to UEFI bios, and it worked like a charm.

                       

                      I had the same issue with a VEGA FE that I ended up returning.

                      • Re: RX Vega 64 BSOD on driver install
                        globalrebel

                        I know this is an old thread, but I had to reply. I myself have a P67A-UD4-B3 Gigabyte Motherboard and am unable to install my brand new Vega 64 GPU! I've reached out to Gigabyte already to see if they will EVER create a UEFI BIOS for my MB, but why does Vega require this to function? My build has been running GREAT for years, and works just fine with a GTX 1070 GPU, so why won't Vega?? I've searched and this seems to be a known issue across the board for Legacy BIOS users, and AMD hasn't said A THING about resolving this?!?! I wanted to jump to AMD to support them, cause I like what they do, but I'm VERY hesitant now moving forward....

                         

                        Can this be fixed AMD?? Blue Screen of Death Vega 64 BSOD during driver install on GA-P67A-UD4-B3 mobo

                          • Re: RX Vega 64 BSOD on driver install
                            protivakid

                            Return the card while you still can. I doubt Gigabyte will issue a BIOS fix for a 7yr old board.

                              • Re: RX Vega 64 BSOD on driver install
                                globalrebel

                                I wish I could, but I bought it from Newegg on a no return policy. (Got it for $740 after tax, which is OVER MSRP, but under current selling prices, hence why i jumped on the deal.) Its a sad day when you want to support a company that speaks to being behind its customers, only to find you're simply screwed now.

                                 

                                PS: AMD does not have UEFI as a REQUIREMENT in any documentation, so if Gigabyte doesn't fix the problem, AMD should. Or at least, they should stand behind their own words. . .

                                  • Re: RX Vega 64 BSOD on driver install
                                    protivakid

                                    AMD should fix it but Nvidia did the same thing back in 2012. X58 Pheonix BIOS owners had an issue where Sleep mode would not work with any GTX 600+ Series card. It's still broken on the 1000 series as well. Nvidia looked into the issue but never solved it and went radio silent about it. AMd will probably do the same with this.

                                      • Re: RX Vega 64 BSOD on driver install
                                        globalrebel

                                        Well, I'm hoping that's not the case, but ready for that to happen. If they just don't respond or choose not to fix it, I'll just return the card and monitor and basically never go AMD in the future. Which is sad, but that's a horrible way to handle things. With the AMD Threadripper and such I was really hoping to jump to this new solution, but its not looking good.

                                         

                                        Going to do a full rebuild tonight on an empty HD and see if that gets me able to install. If not, than I wait for AMD to reply to my ticket. That will decide my future builds (and my builds for my customers/friends; I help out a bunch of people when they want new comps. What I choose and test for myself, I build for my friends/family).