4 Replies Latest reply on Apr 17, 2018 3:44 AM by inras

    Sapphire RX Vega 64 - Stellaris hangs on start up  / loading 

    toxic_gummi

      Describe your system:

      • AMD Graphics Card
        • Sapphire RX Vega 64
      • Desktop
      • Operating System
        • Windows 10 64bit
      • Driver version installed
        • Radeon Software 17.8.1
      • Display Devices
        • Samsung C34F791 34" Silver Curved FreeSync Monitor 3440 x 1440 @60Hz Active Display port
      • Motherboard + Bios Revision
        • Gigabyte Z77X-UD5H + American Megatrends Version F14
      • CPU/APU
        • i7-3770K - Currently @ Stock Speeds
      • Power Supply Unit  Make, Model & Wattage
        • Seasonic Snow Silent-1050 1050W
      • RAM
        • 16GB

      Describe your issue:

      • Post Vega upgrade (did full uninstall of display drivers) Stellaris would hang on loading screen at "preparing game" section of loading bar. Contacted Paradox support.  Did a clean install of game. Issue persisted.  Tried many other games no persistent issues, but there have been issues. 
      • Stellaris Adams build (no mods) v1.6.2 (d7ec)
      • Desktop resolution.  3440x1440 Tried multiple resolutions and settings enabled/disabled. Game menu loads and you can change options but when you try to load the game proper will always hang on loading.
      • Insert screenshot of frozen loading window here.....