2 Replies Latest reply on Aug 2, 2017 4:31 PM by ray_m

    ATI RADEON HD 3450 is detected on Device Manager, but errors in properties with "No drivers installed..." with Windows 10 Pro 1703

    ludakiks

      I'm using a Desktop.. I contacted Microsoft support but they said that its not compatible with windows 10 and told me to just wait for a release driver update from the manufacturer which is AMD (I know its an older version but unlike with my other video card from my other device (laptop) that is part of the LEGACY video cards, I just searched it with Windows Catalogue, I download the drivers and got it updated and worked with Windows 10). There's a high chance that it will work with 7 but I don't want to downgrade.

      Video card is detected and can change resolution to the max.

      Here are some troubleshooting steps that I tried:

      1. Downloaded AMD catalyst but no chance of updating the video card, still "no drivers installed..." in Device Manager but still detected. And upon launching catalyst by right clicking on the desktop and selection the catalyst control panel, its giving me an error message of no drivers installed etc..

      2. Run windows update but there is no showing update with drivers

      3. On device manager, right clicked video card > update driver > search online

      4. On device manager, right clicked video card > update driver > picked from a list - it detected 2 driver updates like 4-14-2017 and something in 2016. And some Microsoft Display Driver

      5. Uninstalled drivers in device manager > restarted pc - still the same

      6. Uninstalled drivers in device manager > deleted driver > restarted pc > driver still detected but still no drivers found

      7. Rollback the driver from device manager > restarted pc - still the same and now can't change the resolution (grayed out)

      8. Downloaded drivers from Windows Catalogue with exact driver names and OS and update it through device manager - still the same (didn't remember what step I did with my "other device" with a legacy driver to update it and worked)

      I also checked some forums with AMD site forum and had some similar issues with other users. A tech from AMD said that don't install catalyst just check and update it through Windows update. I keep on checking windows update but no chance of getting driver update.

      System specs:

      Board - EMAXX (don't remember the whole details since I'm in office, will update details once got home)

      Processor - AMD A6-7400K R5

      ANY HELP WILL BE MUCH APPRECIATED!