16 Replies Latest reply on Jun 12, 2017 10:04 AM by amdmatt

    Games not working in DX9/DX11/OpenGL since 17.4.4 on RX 460 in a DVI Monitor.

    shadbr

      AMD Graphics Card

      PowerColor RX 460 2GB

      Desktop

      Operating System

      Windows 10 Creator's Edition 64bit

      Driver version installed

      Radeon ReLive 17.5.1 and 17.4.4

      Display Devices

      Samsung Syncmaster P2270 DVI-DVI 1920x1080 @59Hz

      Motherboard

      ASUS M5A78L-M LX

      CPU/APU

      FX-6100 3.3GHZ

      Power Supply Unit

      OCZ 430W

      RAM

      8GB Corsair Vengeance

       

      Since 17.4.4 No games working in DX9/DX11 or OpenGL. Tried various games like Assassins Creed Revelations for DX9, Rage for OpenGL and Battlefield 1/Sherlock Holmes - The Devil's Daughter on DX11 but don't start. Only a small box displaying problems to iniciate DX9/11 and close to desktop.

      On OpenGL displays: "No valid monitors found" an error similar to this guy: FATAL ERROR: No valid monitors found. :: DOOM General Discussions

      Tried to check triple buffering on OpenGL since i read in some boards on game settings but not worked.

      People says that using a hdmi cable resolved in this case, but my monitor is dvi, and in 17.3.2 everything works flawless. OpenGL included that is broken since 17.4.2., but DX games started to broken since 17.4.4 and 17.5.1 not working either.

       

      What happened? This issue is already known? I bought an RX 400 series hoping a good support for a new product, but in 6 months already having this kind of bug was really weird. I hope a good solution, because 17.3.2 mass effect andromeda is really slow.

        • Re: Games not working in DX9/DX11/OpenGL since 17.4.4 on RX 460 in a DVI Monitor.
          shadbr

          Anyone help? I see others having the same problem. No games launch after the update like this: No game will launch after 17.3.3 driver update  .

          I really want to upgrade to the newest drivers, but i used DDU on security mode and didn't help. The 17.3.3 is the most stable on my rx 460 at least. Seems that the AMD staff doesn't care for such a huge problem like this. I used to have an NVIDIA card, and never had such a extreme bug like this in such 8 years.

          • Re: Games not working in DX9/DX11/OpenGL since 17.4.4 on RX 460 in a DVI Monitor.
            amdmatt

            Please try updating your DX components. If the issue continues, please use the last working driver and wait for our next update.

            Download DirectX End-User Runtimes (June 2010) from Official Microsoft Download Center

              • Re: Games not working in DX9/DX11/OpenGL since 17.4.4 on RX 460 in a DVI Monitor.
                shadbr

                The problems aren't from DX. I already use the last one. This driver 17.4.4 and 17.5.1 doesn't launch any games. I only said DX9, DX11 and OpenGL to show that is not an especific issue, is a global that affects every games to launch. Last 17.3.2 and 17.3.3 are the last stable on that works everything, so directX problem is discarded. I hope the next driver fix this issue, i'm seeing that is a common issue on this board. I saw several cases, includes RX480 and RX580 here.

                  • Re: Games not working in DX9/DX11/OpenGL since 17.4.4 on RX 460 in a DVI Monitor.
                    geloczigeri

                    I can confirm that the issue is related to the DVI output of the card. I have an Sapphire R9 290X Tri-X OC. My games and MPC-HC does not work when I plug my monitor into the DVI port. The workaround is to use the HDMI or DisplayPort output of the card, this is >working< for me.

                     

                    So plugging the monitor into HDMI or DisplayPort will work! Anyway, it is really annoying that the DVI output broken on a high-end graphics card after a driver update.

                    Reverting back the driver to version 17.3 or 17.2 fixes this issue too but lacks the optimizations for new games.

                      • Re: Games not working in DX9/DX11/OpenGL since 17.4.4 on RX 460 in a DVI Monitor.
                        amdmatt

                        Please can you provide the essential INFORMATION REQUIRED WHEN POSTING A QUESTION and share detailed reproduction steps so i can pass this information to engineering.

                          • Re: Games not working in DX9/DX11/OpenGL since 17.4.4 on RX 460 in a DVI Monitor.
                            geloczigeri

                            Here are the details:

                             

                            Describe your system:

                            • AMD Graphics Card
                              • AMD, Sapphire R9 290X Tri-X OC with 4GB RAM
                            • Desktop system
                            • Operating System
                              • Microsoft Windows 7 64bit
                            • Driver version installed
                              • whql-win7-64bit-radeon-software-crimson-relive-17.4.4-may3
                            • Display Devices
                              • LG IPS231, DVI connection, 1920x1080, 60Hz
                            • Motherboard
                              • Asus P8Z68-V
                              • BIOS: 3603
                            • CPU
                              • Intel 2500K, no overclock
                            • Power Supply Unit  Make, Model & Wattage
                              • Corsair RM850, 850W, CP-9020056-EU
                            • RAM
                              • 16GB, DDR3, 2133Mhz, XMP

                             

                            Describe your issue:

                            • Provide a detailed description of the issue you are experiencing and the steps required to reproduce the issue

                            After updating my AMD graphics card driver from 17.3 to 17.4.4 or newer, I cannot start games, Windows Areo theme disabled, Media Player Classic displays "DX9AllocatiorPresenter failed" error message.

                             

                            • The following applications/games not working:

                            Media Player Classic Home Cinema x64 v1.7.11

                            RAGE

                            The Evil Within

                            Dying Light

                            Mass Effect

                            Alan Wake

                            Rise of the Tomb Raider

                            Outlast

                            Homefront

                             

                            But I have found an exception! Prey is working! I can confirm that the new Prey PC game is working with 17.4.4 driver!

                             

                            • Graphical settings used in the application/game (resolution and 3D settings)

                            1920x1080 (native resolution of my monitor)

                            High level 3D settings, I have tried other levels too.

                             

                            • If possible, include a screenshot or video link of the issue

                            Here is a link to an image gallery with screenshots of the errors:

                            Postimage.io — free image hosting / image upload

                             

                            Error message from RAGE game:

                             

                            Rage.1700.342015 win-x86 Release  Oct 10 2012 14:14:10

                            ------ Initializing File System ------

                            Current search path:

                            C:/Users/Administrator/Saved Games/id Software/Rage/base/

                            C:/Games/RAGE/base/

                            file system initialized.

                            BenchmarkGameData: ofs 0 and 0x1208090624x

                            29 microseconds

                            52 microseconds

                            14 microseconds

                            11 microseconds

                            12 microseconds

                            11 microseconds

                            11 microseconds

                            11 microseconds

                            11 microseconds

                            10 microseconds

                            Average seek time without outliers: 13 microseconds

                            fileBenchmarkImpliesGameIsOnHD: true

                            ---------------------------

                            1 CPU package, 4 physical cores, 4 logical cores

                            3300 MHz Intel CPU with MMX & SSE & SSE2 & SSE3 & SSSE3 & SSE41 & SSE42 & AVX

                            32768 kB 1st level cache, 262144 kB 2nd level cache, 6291456 kB 3rd level cache

                            16352 MB System Memory

                            Winsock Initialized

                            Found interface: {5D0F1960-BD36-4391-AF20-B637213B0D0E} Intel(R) 82579V Gigabit Network Connection - 192.168.1.51/255.255.255.0

                            Found interface: {C4ABD60B-A11E-4517-BF0C-578D28A0D043} VMware Virtual Ethernet Adapter for VMnet1 - 192.168.124.1/255.255.255.0

                            Found interface: {123528EA-F55D-4F67-949F-5B05D8E20C81} VMware Virtual Ethernet Adapter for VMnet8 - 192.168.9.1/255.255.255.0

                            Sys_InitNetworking: adding loopback interface

                            execing default.cfg

                            execing joystick.cfg

                            Unknown command 'com_videoRam'

                            Unknown command 'vt_restart'

                            execing default.cfg

                            execing joystick.cfg

                            Unknown command 'com_videoRam'

                            Unknown command 'vt_restart'

                            execing default.cfg

                            execing joystick.cfg

                            Unknown command 'com_videoRam'

                            Unknown command 'vt_restart'

                            execing default.cfg

                            execing joystick.cfg

                            Unknown command 'com_videoRam'

                            Unknown command 'vt_restart'

                            ReadTitleStorage: MANUALLY CREATED

                            Num args: 32

                            chainRally_weighting = 0.40

                            meteorRally_weighting = 0.25

                            Carnage_weighting = 0.20

                            triadRally_weighting = 0.15

                            gearhead_weighting = 0.19

                            meteor_weighting = 0.19

                            reactor_weighting = 0.19

                            southernHighway_weighting = 0.19

                            abandoned_weighting = 0.19

                            prime_weighting = 0.05

                            meteor_Shower_killScore = 1

                            vdm_killScore = 10

                            rally_killScore = 1

                            tri_rally_killScore = 5

                            rallyPointScore = 2

                            tri_rallyPointScore = 10

                            meteorCapturePoints_0 = 3

                            meteorCapturePoints_1 = 6

                            meteorCapturePoints_2 = 12

                            meteorCapturePoints_3 = 24

                            meteorCapturePoints_4 = 36

                            meteorCapturePoints_5 = 48

                            meteorCapturePoints_6 = 60

                            meteorCapturePoints_7 = 72

                            meteorCapturePoints_8 = 80

                            meteorCapturePoints_9 = 100

                            itemMaxCount_vehicle/quickuse/jump = 4

                            itemSetCount_vehicle/quickuse/jump = 4

                            itemMaxCount_vehicle/quickuse/emp = 3

                            itemSetCount_vehicle/quickuse/emp = 3

                            itemMaxCount_vehicle/quickuse/boostextender = 3

                            itemSetCount_vehicle/quickuse/boostextender = 3

                            EnumerateDownloadableContent: C:\Games\RAGE\dlc

                                Found DLC: dlc1...and info.txt!

                            Resource hashSeed = 3

                                    ...successfully mounted 'C:\Games\RAGE\dlc/dlc1/info.txt.  ID: 1

                                Found DLC: dlc2...and info.txt!

                            Resource hashSeed = 3

                                    ...successfully mounted 'C:\Games\RAGE\dlc/dlc2/info.txt.  ID: 2

                                Found DLC: dlc3...and info.txt!

                            Resource hashSeed = 3ffffffe

                                    ...successfully mounted 'C:\Games\RAGE\dlc/dlc3/info.txt.  ID: 3

                            idLib::SetProduction( PROD_PRODUCTION )

                            contentpackage path:  C:/Games/RAGE/dlc/dlc1

                            contentpackage id:  1

                            Failed to find DLC at C:/Games/RAGE/dlc/dlc1/base/gameresources.resources

                            contentpackage path:  C:/Games/RAGE/dlc/dlc2

                            contentpackage id:  2

                            Failed to find DLC at C:/Games/RAGE/dlc/dlc2/base/gameresources.resources

                            contentpackage path:  C:/Games/RAGE/dlc/dlc3

                            contentpackage id:  3

                            setting patchFileIsForVoOnly to true

                            Found DLC resource at C:/Games/RAGE/dlc/dlc3/base/gameresources.resources

                            couldn't exec rageConfig.cfg

                            Resetting cheat cvar: aas2_showFloorTrace

                            Resetting cheat cvar: ai_alignToPointDist

                            Resetting cheat cvar: ai_minCornerCircleRadius

                            Resetting cheat cvar: ai_cornerCircleRadius

                            Resetting cheat cvar: ai_turningCircleAlignmentTolerance

                            Resetting cheat cvar: ai_pointTolerance

                            Resetting cheat cvar: atv_bumpForwardScale

                            Resetting cheat cvar: aa_ZoomSnapScale

                            Resetting cheat cvar: poi_playerScaleMinimum

                            Resetting cheat cvar: poi_scaleMinimum

                            Resetting cheat cvar: poi_ScreenPercentage

                            Resetting cheat cvar: poi_IconSizeSplitscreen

                            Resetting cheat cvar: poi_IconSize

                            Resetting cheat cvar: poi_GoalHeightOffset

                            Resetting cheat cvar: swf_minimap_scale_foot

                            Resetting cheat cvar: swf_minimap_scale_vehicle

                            Resetting cheat cvar: blendTree_scale

                            Resetting cheat cvar: swf_jobnav_mindist

                            Resetting cheat cvar: swf_minimap_ant_first_step_foot

                            Resetting cheat cvar: swf_minimap_ant_step_foot

                            Resetting cheat cvar: swf_minimap_ant_first_step

                            Resetting cheat cvar: swf_minimap_ant_step

                            Resetting cheat cvar: swf_scopeZoomDistance

                            Resetting cheat cvar: gc_fictionBlurAmount

                            Resetting cheat cvar: cine_cameraAccel

                            Resetting cheat cvar: rcbomb_initialOffset

                            Resetting cheat cvar: cam_deathCamblurTime

                            Resetting cheat cvar: cam_deathCamblurAmount

                            Resetting cheat cvar: revivecam_HeightEnd

                            Resetting cheat cvar: revivecam_HeightStart

                            Resetting cheat cvar: spl_qn_pathbonus

                            Resetting cheat cvar: spl_qn_zpenelty

                            Resetting cheat cvar: swf_invFadeTime

                            Resetting cheat cvar: ai_NonPlayerOneShotChance

                            Resetting cheat cvar: ai_droppedLootDistance

                            Resetting cheat cvar: pm_ct_jump_dist

                            Resetting cheat cvar: pm_ct_push_dist

                            Resetting cheat cvar: pm_ct_push_decayIn

                            Resetting cheat cvar: pm_ct_push_decayOut

                            Resetting cheat cvar: pm_ct_checkDist

                            Resetting cheat cvar: g_playerDamageThreshold

                            Resetting cheat cvar: swf_combatSubtitleRange

                            Resetting cheat cvar: swf_subtitleRange

                            Resetting cheat cvar: vehicle_clientImpactDmg_MaxDmg

                            Resetting cheat cvar: vehicle_clientImpactDmg_MinDmg

                            Resetting cheat cvar: vehicle_clientImpactDmg_MaxVel

                            Resetting cheat cvar: vehicle_clientImpactDmg_MinVel

                            Resetting cheat cvar: v_steerControlClamp

                            Resetting cheat cvar: v_steerControlInfluence

                            Resetting cheat cvar: v_compressiontime

                            Resetting cheat cvar: v_dusttime

                            Resetting cheat cvar: pm_clientZoomInDelay

                            Resetting cheat cvar: pm_clientAuthoritative_warnDist

                            Resetting cheat cvar: pm_clientAuthoritative_minDistZ

                            Resetting cheat cvar: pm_clientAuthoritative_Lerp

                            Resetting cheat cvar: pm_clientAuthoritative_minDist

                            Resetting cheat cvar: net_voiceVolume

                            Resetting cheat cvar: net_peer_throttle_bps_decay

                            Resetting cheat cvar: net_debughud3_bps_max

                            ------- Initializing renderSystem --------

                            Initializing OpenGL subsystem

                            Rage.exe @ 0x006a96b4(  ) +  bytes () : ** UNKNOWN **( ** FUNC_PARAM_ERROR ** )

                            Rage.exe @ 0x006a983c(  ) +  bytes () : ** UNKNOWN **( ** FUNC_PARAM_ERROR ** )

                            Rage.exe @ 0x006a98dc(  ) +  bytes () : ** UNKNOWN **( ** FUNC_PARAM_ERROR ** )

                            Rage.exe @ 0x0058bf86(  ) +  bytes () : ** UNKNOWN **( ** FUNC_PARAM_ERROR ** )

                            Rage.exe @ 0x0058c027(  ) +  bytes () : ** UNKNOWN **( ** FUNC_PARAM_ERROR ** )

                            Rage.exe @ 0x00565616(  ) +  bytes () : ** UNKNOWN **( ** FUNC_PARAM_ERROR ** )

                            Rage.exe @ 0x005ec01f(  ) +  bytes () : ** UNKNOWN **( ** FUNC_PARAM_ERROR ** )

                            Rage.exe @ 0x006aa4b9(  ) +  bytes () : ** UNKNOWN **( ** FUNC_PARAM_ERROR ** )

                            kernel32.dll @ 0x7694336a(  ) +  bytes () : BaseThreadInitThunk(  )

                            ntdll.dll @ 0x773a9902(  ) +  bytes () : RtlInitializeExceptionChain(  )

                            ntdll.dll @ 0x773a98d5(  ) +  bytes () : RtlInitializeExceptionChain(  )

                            ERROR: No valid monitors found.

                            Dumped console text to C:\Users\Administrator\Saved Games\id Software\Rage\base\ErrorLog_05-24-2017__07-59-23pm.txt.

                             

                            idRenderSystem::Shutdown()

                            Shutting down OpenGL subsystem

                            ...releasing DC

                             

                            ***************************

                            No valid monitors found.

                            ***************************