4 Replies Latest reply on Apr 29, 2017 10:57 PM by looncraz

    Ryzen 16-bit Virtualization Problems

    looncraz

      I have a horribly bizarre problem.  I just built a Ryzen 7 1700 based system using the Asus Prime X370 Pro.  This system is running a clean Windows 10 Pro x64 install (also tried Windows 7 Ultimate x64, where the problem was first discovered).  Due to a pressing need to run a selection of 16-bit programs the previous system has long run VMWare Player with a Windows XP SP3 virtual machine which would host the 16-bit programs and custom software by yours truly to bridge the gap between the guest and the host for backups and data sharing.

       

      The virtual machine's first problem on Ryzen was that VMWare Player gave a weird error about AVX2 being required but AVX was not supported by the CPU.  Changed the HW version to 12 - no problem, VM booted and worked just fine for everything... except ANY 16-bit Windows program.  They simply did nothing.  In addition, the sound playback is choppy shortly after boot (but is fine as soon as XP boots).

       

      I moved the VM to another machine for testing - an AMD Athlon II (AM3, IIRC) system.  Works perfectly.  Same exact VM, same config, same version of VMWare (I tried 7.0 and the latest 12.5.5 or whatever it is).

       

      In addition, it seems virtualization overall has issues.  I can't get 2000 or 98 to install, and Windows XP video goes black until the VMWare driver is installed (so I can't see the second part of the installation) and Safe Mode is inaccessible.  These problems, interestingly, persist in Virtual Box as well.

       

      I tried two different BIOS versions, including the latest with AGESA 1.0.0.4a with no impact.

       

      I'm simply out of ideas aside from a possible CPU fault.  HELP!

       

      UPDATE: 4/23/17 - For clarity:

       

      The problem happens with Windows 7 and Windows 10 with VMWare Player 7.0 & 12.5.5 and the latest Virtual Box. I've purchased another motherboard for testing purposes - and because I'm generally unhappy with the artificial restrictions ASUS placed on the Prime X370 Pro (no custom P-states... you're joking, right!?! $160 motherboard and you remove features my wife's $100 ASRock board provides because it costs nothing to implement!?!).

       

      UPDATE 4/24/17 - Discovery

       

      Installing Linux Mint 18.1 as a VMWare guest and then running my XP virtual machine inside the Linux Machine guest allows 16-bit programs to run.

       

      This really seems like it might be a driver problem.  Also, the problem has been experienced by "Mr. Evil" as can be seen here