6 Replies Latest reply on Oct 1, 2018 2:12 AM by h0ppus

    dpkg: error processing archive /var/opt/amdgpu-pro-local

    fermulator

      Attempting to upgrade from 16.30 to 16.60...

       

      followed the docs

      - https://community.amd.com/discussion/create.jspa?containerType=14&containerID=2111&question=true&subject=dpkg%3A error processing archive %2Fvar%2Fopt%2Famdgpu-pro-local

      - How-To Install/Uninstall AMD Radeon™ Software AMDGPU-PRO Driver for Linux® on an Ubuntu System

       

      Fails

       

      http://paste.ubuntu.com/24044226/

       

      attempt to remove/reinstall amdgpu-pro package also failed

      failure messages like this

      dpkg: error processing archive /var/opt/amdgpu-pro-local/./opencl-amdgpu-pro-icd_16.60-379184_i386.deb (--unpack):

        trying to overwrite '/etc/OpenCL/vendors/amdocl32.icd', which is also in package amdgpu-pro-opencl-icd:i386 16.30.3-315407

      (as you can see, I'm upgrading from 16.30.3, to 16.60...

        • Re: dpkg: error processing archive /var/opt/amdgpu-pro-local
          fermulator

          Since there has been no reply, I forced the packages out using purge and force-all

           

          for amdgpupkg in $(dpkg --list | grep amdgpu-pro | awk '{print $2}'); do echo $amdgpupkg; sudo dpkg --purge --force-all $amdgpupkg; done

          for amdgpupkg in $(dpkg --list | grep amdgpu | awk '{print $2}'); do echo $amdgpupkg; sudo dpkg --purge --force-all $amdgpupkg; done

            • Re: dpkg: error processing archive /var/opt/amdgpu-pro-local
              fermulator

              I probably shouldn't have removed ALL the amdgpu stuff, afterwards had to do this:

               

              {{{

              $ sudo apt-get -f install

              Reading package lists... Done

              Building dependency tree      

              Reading state information... Done

              Correcting dependencies... Done

              The following packages were automatically installed and are no longer required:

                linux-headers-4.4.0-57 linux-headers-4.4.0-57-generic linux-headers-4.4.0-59 linux-headers-4.4.0-59-generic linux-image-4.4.0-57-generic linux-image-4.4.0-59-generic

                linux-image-extra-4.4.0-57-generic linux-image-extra-4.4.0-59-generic

              Use 'sudo apt autoremove' to remove them.

              The following additional packages will be installed:

                libdrm-amdgpu1 libdrm-amdgpu1:i386 xserver-xorg-video-amdgpu

              Suggested packages:

                firmware-amd-graphics

              The following NEW packages will be installed:

                libdrm-amdgpu1 libdrm-amdgpu1:i386 xserver-xorg-video-amdgpu

              0 upgraded, 3 newly installed, 0 to remove and 164 not upgraded.

              Need to get 52.6 kB/88.6 kB of archives.

              After this operation, 316 kB of additional disk space will be used.

              Do you want to continue? [Y/n] y

              Get:1 http://ca.archive.ubuntu.com/ubuntu xenial-updates/main amd64 xserver-xorg-video-amdgpu amd64 1.1.2-0ubuntu0.16.04.1 [52.6 kB]

              Fetched 52.6 kB in 0s (92.4 kB/s)                   

              Selecting previously unselected package libdrm-amdgpu1:amd64.

              (Reading database ... 590671 files and directories currently installed.)

              Preparing to unpack .../libdrm-amdgpu1_2.4.70-1~ubuntu16.04.1_amd64.deb ...

              Unpacking libdrm-amdgpu1:amd64 (2.4.70-1~ubuntu16.04.1) ...

              Selecting previously unselected package libdrm-amdgpu1:i386.

              Preparing to unpack .../libdrm-amdgpu1_2.4.70-1~ubuntu16.04.1_i386.deb ...

              Unpacking libdrm-amdgpu1:i386 (2.4.70-1~ubuntu16.04.1) ...

              Selecting previously unselected package xserver-xorg-video-amdgpu.

              Preparing to unpack .../xserver-xorg-video-amdgpu_1.1.2-0ubuntu0.16.04.1_amd64.deb ...

              Unpacking xserver-xorg-video-amdgpu (1.1.2-0ubuntu0.16.04.1) ...

              Processing triggers for libc-bin (2.23-0ubuntu5) ...

              Processing triggers for man-db (2.7.5-1) ...

              Setting up libdrm-amdgpu1:amd64 (2.4.70-1~ubuntu16.04.1) ...

              Setting up libdrm-amdgpu1:i386 (2.4.70-1~ubuntu16.04.1) ...

              Setting up xserver-xorg-video-amdgpu (1.1.2-0ubuntu0.16.04.1) ...

              Processing triggers for libc-bin (2.23-0ubuntu5) ...

              }}}

                • Re: dpkg: error processing archive /var/opt/amdgpu-pro-local
                  fermulator

                  /then/ finally (after cleaning up my apt, upgrading all packages, etc.), tried the installation script again

                  as per latest amdgpu-pro driver download for Ubuntu 16.04 AMDGPU-PRO Driver for Linux Release Notes

                  {{{

                  :/usr/local/src/amdgpu-pro/amdgpu-pro-16.60-379184$ sudo ./amdgpu-pro-install

                  }}}

                    • Re: dpkg: error processing archive /var/opt/amdgpu-pro-local
                      fermulator

                      For future reference, we MAY want to recommend in documentation (or in the script itself) to run amdgpu-pro-uninstall first?

                       

                      {{{

                      $ which amdgpu-pro-uninstall

                      /usr/bin/amdgpu-pro-uninstall

                      }}}

                        • Re: dpkg: error processing archive /var/opt/amdgpu-pro-local
                          fermulator

                          and,... a final reboot tada

                           

                          {{{

                          $ dpkg -l amdgpu-pro

                          Desired=Unknown/Install/Remove/Purge/Hold

                          | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend

                          |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)

                          ||/ Name                                     Version                   Architecture              Description

                          +++-========================================-=========================-=========================-=====================================================================================

                          ii  amdgpu-pro                               16.60-379184              amd64                     Meta package to install amdgpu Pro components.

                           

                          $ uname -a

                          Linux fermmy 4.4.0-66-generic #87-Ubuntu SMP Fri Mar 3 15:29:05 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

                          }}}

                  • Re: dpkg: error processing archive /var/opt/amdgpu-pro-local
                    h0ppus

                    after a reboot my dual monitor setup simply got into clone mode and display manager was listing my monitor as unknown and none secondary being recognised.

                    I have played with different display managers without success, then decided to reinstall the amd driver, since a newer version was available, however I have tried to install on top of the existing and it's got into errors.

                    found your post and decided to use your script to remove all amd drivers, when rebooted the system got stuck with a screen going black and returning to system start up.

                    I had to go into recovery mode and after reinstalling the driver with ./amdgpu-install and rebooting the dual monitor config returned to normal and all monitors were shown in display manager as expected.

                     

                    thanks for the tips.

                     

                    System INFO -------------

                    Linux ubuncraft 4.15.0-34-generic #37-Ubuntu SMP Mon Aug 27 15:21:48 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

                    amdgpu                                        18.30-641594                        amd64        Meta package to install amdgpu components.

                    root@ubuncraft:/etc/X11# cat default-display-manager

                    /usr/sbin/gdm3

                    ---------------------------------