14 Replies Latest reply on Oct 16, 2017 4:56 AM by birchyboy

    How to disable HDCP?

    kekonn

      Since the 16.12 drivers HDCP seems to be enabled all the time. I haven an RX480 that uses an active adapter to convert to dual link DVI to drive a CrossOver 27QHD monitor (that only has a dual-link DVI input). I keep getting a weird glitch everywhere now and I think this is due to HDCP. Is there a way I can get around this without buying new hardware and keeping the latest drivers?

       

      I have already tried a complete reinstall of new drivers. Rolling back to the 16.11 drivers solves the issue, but I want to keep up to date obviously. I don't mind not having access to HDCP enabled content, if I can just use my computer for games.

       

      Any help or insights? Attached is an image of the problem. It's something in the control signal, because the picture itself is fine when I take a screenshot.

        • Re: How to disable HDCP?
          ray_m

          Unfortunately, HDCP being a legal requirement, there are no ways to disable it.

            • Re: How to disable HDCP?
              kekonn

              But previously this was only an issue when I tried to play back HDCP protected content like Netflix. Now it's just always on. It can't be that my desktop is HDCP protected, right?

              • Re: How to disable HDCP?
                pdcm

                This exact same setup worked just fine in Radeon Software Crimson Edition 16.11.5, it was a legal requirement in November 2016, so something else must have changed.

                • Re: How to disable HDCP?
                  kekonn

                  The problem is that HDCP is now always active, even when no HDCP content is being displayed. I would like an update on how this is going to be fixed.

                    • Re: How to disable HDCP?
                      ray_m

                      HDCP cannot be turned off and on at will, such a facility would defeat the very purpose of legal copy protection mechanism.

                      1 of 2 people found this helpful
                        • Re: How to disable HDCP?
                          kekonn

                          Not at will no, but it can be turned off by the signal generator (aka the GPU and/or it's driver). If not, explain to me why my screen previously only looked like this when watching Netflix (which I don't usually do on this pc) when I was on 16.11.3 or lower. When I update to anything higher I get the problem in the screenshot above.

                           

                          Disalbing HDCP would disable the playback of HDCP protected content, thus still keeping the copyright protection in place. I don't want to outright disable it, I just want to solve the issue I am having so I can finally update my drivers again. On my PS4 I can simply disable HDCP and it will disable playback of HDCP protected content. AFAIK your company makes the GPU for this system as well, so I am not following your train of thought.

                           

                          I simply want my issue solved, I don't want to bypass HDCP enabled content. I don't consume it on my desktop. What I do take issue with is that it tries to protect non-protected content, thus generating this glitch I experience.

                            • Re: How to disable HDCP?
                              ray_m

                              This discussion is focused on HDCP, which is a driver feature that is not user controllable, since you referred to HDCP in your opening post.


                              Your actual issue may not be HDCP related at all, which is why I have escalated it to Engineering for their feedback.

                              2 of 2 people found this helpful
                                • Re: How to disable HDCP?
                                  pdcm

                                  Thank you ray.

                                  • Re: How to disable HDCP?
                                    kekonn

                                    I originally worded my questions in that way because I hoped there was a way to fix this with just a setting or editing a file. Your information has convinced me the issue lies deeper withing the software, so I thank you for forwarding this to engineering. I hope they reply soon.

                                    • Re: How to disable HDCP?
                                      sylvethter

                                      i, too seem to be having an issue with my rx480 with driver packs newer than the 16.11 i cannot even capture my desktop environment. has there been any word as of yet to this getting resolved?

                                      • Re: How to disable HDCP?
                                        kekonn

                                        Has there been an update? I have done more research myself and other driver updates don't solve the problem. I have done multiple clean installs. The last "known good" driver for me was

                                         

                                        Versie Radeon-instellingen - 2016.1121.1657.30480

                                        Versie stuurprogrammapakket - 16.40.2311.1002-161121a-309377E

                                        Aanbieder - Advanced Micro Devices, Inc.

                                        Versie 2D-stuurprogramma - 8.1.1.1571

                                        Direct3D® Version - 9.14.10.01221

                                        OpenGL® Version - 6.14.10.14008

                                        OpenCL™ Version - Not Available

                                        Versie AMD Mantle - 9.1.10.0146

                                        API-versie AMD Mantle - 98310

                                        AMD-geluidsstuurprogrammaversie - 10.0.1.0

                                        Vulkan™ Driver Version - 1.3.0

                                        Vulkan™ API Version - 1.0.21

                                          • Re: How to disable HDCP?
                                            sylvethter

                                            not as of yet it seems. i have been emailing back and forth very slowly with tech support, and the last potentially useful thing they said to me was to make sure that xbox dvr on windows 10 was disabled. but it was already disabled, and i informed them of this, and still haven't heard back from them yet and i replied back 3 days ago.

                                • Re: How to disable HDCP?
                                  pdcm

                                  I get this exact thing with the Accell B087B-007B adapter to a 27" QHD DL-DVI monitor.   I notice that it is reported as connected with HDMI and has HDCP enabled even though it's a Displayport connection?  Oddly enough, I also had a passive DP to DVI adapter for my secondary monitor and do not have this problem at all with that one - that one reports that it is connected by DVI.

                                  • Re: How to disable HDCP?
                                    birchyboy

                                    Hello, kekonn,

                                    HDCP has been littered with problems.  We all agree that the hard work and money going into media production should be rewarded and piracy prevented. However, Intel's original digital rights management protection with HDCP never managed to prevent piracy and usually interfered with legitimate users enjoyment of their expensive hardware. Now hardware manufacturers (including AMD) can't escape paying licence fees to have their kit HDCP certified, so we are stuck with it.

                                     

                                    Although you can't disable HDCP, for obvious reasons, you can bypass it with a cheap HDMI splitter.  Some splitters don't separate out the HDCP protection, but one which is known to be effective is the View HD mini 2-port splitter.  Go to  Amazon.com and put in   VHD-1X2MN3D  (it's currently $18).