3 Replies Latest reply on Jan 18, 2017 10:17 AM by izzycm

    4k 60hz on R9 390 Driver bug

    izzycm

      I have a R9 390 connected up to a LG 4k display, using a Display port connection (1.2).  It was working fine up until about 3-4 weeks ago when I got an automatic driver update. After the driver update I no longer can chose 4k @ 60Hz, it only lets me use 30Hz.  After a few days of digging and troubleshooting, I finally realized that it was a driver issue... After re-installing windows, and re-downloading all my games... I rolled back to a previous version 16.7, Disabled automatic driver updates, Blocked all ATI*.exe (amd/radeon applications) from any network access, Disabled windows updates (set the service to disabled and restarted pc), and all was well until today...   Upon boot up I was still on driver 16.7 but no longer had 4k@60Hz, I had been changed to 4k@30Hz.  I have tried upgrading to the latest driver, and still no 60Hz... I'm going to roll back to a 15.12 driver and see if that fixes the issue...

       

      Why was 4k@60hz removed?

      Is there any way to fix it so it always stays at 60Hz?

       

      Thanks

      Izzy