12 Replies Latest reply on Jan 16, 2017 2:35 PM by awsi_2099

    Memory Clock Stuck!

    zen-makeamdgreatagain

      Hi,

      I have HD 7950 (asus hd7950-dc2t-3gd5-v2) with well-known memory clock stuck issue after installing crimson drivers. So my memory clock is always on max 1250mhz whether I have one or more monitors installed, or whatever my display's refreshrate is.

      I installed Windows 10 a few months ago and had same problem with clean install. This is really old AND big issue, since it's raising my tempts more than 10c on idle.

      I have tried almost everything (I think?), cleaning drivers (DDU and official driverclean exe), uninstalling programs that might affect mem clock, forcing mem clock with other programs (msi afterburner, asus tweak), installing only the display driver, installing different drivers (the old ones before crimson obv work but don't optimize for newer games)...

      I haven't tried flashing a newer bios to my card, haven't heard it would have helped anyone(?). Also flashing R9 280 bios is an option but will it helps?

       

      I want to get this problem fixed, but even more I want to AMD address this problem and telling us what they've done to fix this? I don't want any "we'll look into it" answers that were okay year ago when this problem came with the first crimson drivers; I want some sort of explanation - why?

      And if GPUs this old don't be supported anymore, give us legacy drivers!

       

      And yeah, I got latest drivers installed (16.11.1)

       

      Sincerely, Hopefully-Zen-And-Vega-Owner

        • Re: Memory Clock Stuck!
          goodplay

          Could it be hardware acceleration in browser.

          • Re: Memory Clock Stuck!
            ivnm

            Hi,
            I have the same problem with 7970. Use driver version 15.12 - I do not have that problem with that driver version. I also tried different ways to solve this with no success including every newer driver. I know this is not the best solution but it is the only one that I found so far that it works. Keep in mind though if you have Windows 10, it will update the driver to the newest version Microsoft has without asking you and it will be a mess. You can stop that automatic driver update through Group policy only - nothing else will work.

            Doom is working perfectly fine with 15.12 at highest settings but use Vulcan instead of OpenGL.

            I completely agree with you that this is very annoying and must be fixed but I doubt AMD will ever try to fix it for those cards. The fact is that this problem is old and it has not been fixed yet and it is obvious to me it is driver issue. Probably my next VGA will be from the competition.

            • Re: Memory Clock Stuck!
              abi

              im having the same issue with an R9 380 4gb, mem clock stuck at highest value. 1st thing i thought was wht goodplay proposed, which could be somekind of browser accelaration or background app, but even when i close all apps except hwinfo mem clock is still stuck. I used the same method (close all apps) and verified with afterburner and gpu-z also, with no background apps, and mem clock always stuck.

               

              at the moment tht happend i had a mem oc done by sapphire trixx and if i remembre well an automatic Windows update was made. To solve this i tried

              1.  clean driver uninstall with DDU+ Windows registry manual profile delete and C:\ amd/ati folders deleted - with no success.

              2. switched on GPU the dual bios switch - with no sucess

              3. regraded to 16.4.2 and upgraded drivers to 16.11.2 - no success

               

              I dnt think tht this issue is  related to drivers but some kind of Windows register tht i didnt found out- Im  open to sugestions.

               

              16.11.2

              Sapphire R9 380 4gb

              Windows 10 pro

              16gb ram

              i7-6700k

              Asus Z170 Pro gaming

                • Re: Memory Clock Stuck!
                  abi

                  I investigated a bit more and my GPU memory clock goest to top when i extend both of my displays as seen in the image bellow. i dont know if this is intentional or can be corrected from Microsoft or AMD side??

                   

                  All apps closed still mem clock at max and with Display extended:

                  mem clock2.jpg

                   

                  When i select "show only on 1" on display settings

                  mem clock4.jpg

                    • Re: Memory Clock Stuck!
                      goodplay

                      That would be better answered by amdmatt

                      • Re: Memory Clock Stuck!
                        zen-makeamdgreatagain

                        Didn't work for me, but this problem exist on r9 3xx series too? That not acceptable at all imo.

                        Edit: Also looking forward for some answer from AMD amdmatt

                          • Re: Memory Clock Stuck!
                            amdmatt

                            If you have more than one display this requires more resources from the GPU, so the memory clock moves up into the next state to compensate and avoid flickering, black screen issues, etc.

                             

                            If you use 'Show only on 1' as in the example above, the second display turns off and the GPU memory clock may drop back to a lower clock. If you use Extend or Duplicate, both monitors will be on the GPU memory clock will increase.

                             

                            It's not a bug so it can't be 'fixed'.

                            1 of 1 people found this helpful
                              • Re: Memory Clock Stuck!
                                abi

                                thnkx matt for clearing out. With 144hz display the gpu mem clock goest also to max?

                                • Re: Memory Clock Stuck!
                                  aixtra

                                  It's weird because, when I start Windows with two 1080p screen, the numbers are:

                                   

                                  Core Clock: 300 MHz

                                  Memory Clock: 150 MHz

                                   

                                  I don't open anything, I lock Windows (windows key + L), and I go back after maybe 30 minute and boom, Memory: 1400 MHz, fan loud, temp high...

                                   

                                  No programs running, just pure idle.

                                   

                                  I have this problem for months now.

                                   

                                  -Windows 10 (64)

                                  -Radeon R9 200

                                  -Crimson 16.9.2

                                  1 of 1 people found this helpful
                                    • Re: Memory Clock Stuck!
                                      awsi_2099

                                      i am having your problem , memory clock always stuck at 1400hz while browsing or watching videos & Fan spins Crazy , all drivers after 16.3.2 have have the 2D profile clocks destroyed like that.

                                      the fact that AMD cannot tweak a 2D profile right for months ,made me sure that this is definitely my last AMD product.

                                      my card is R7 270X , win 10 64x .