2 Replies Latest reply on Nov 3, 2016 2:54 PM by rujan

    Finding AMD processors with NPT/RVI virtualization support?

    rujan

      I'm searching for a CPU with the Nested Page tables (NPT) a.k.a. Rapid Virtualization Indexing (RVI) extension.

      Reason is to run hardware-enforced memory virtualization using SLAT under the newest hypervisors.

      More info: http://www.virtualizationadmin.com/blogs/lowe/news/difference-between-amd-vintel-vt-x-and-amd-viintel-vt-d-188.html

       

      First I checked if my current CPU has NPT:

      For windows: http://www.howtogeek.com/73318/how-to-check-if-your-cpu-supports-second-level-address-translation-slat/

      For linux: http://www.cyberciti.biz/faq/linux-xen-vmware-kvm-intel-vt-amd-v-support/

      Or: http://www.cyberciti.biz/faq/linux-display-cpu-information-number-of-cpus-and-their-speed/

       

      Typing the command: # less /proc/cpuinfo did not show a NPT flag. Meaning, my AMD A8-7600 CPU does not support it.

       

      Then I tried to find out which CPU's do.

      The only thing I found was this list: http://support.amd.com/en-us/kb-articles/Pages/GPU120AMDRVICPUsHyperVWin8.aspx

      But this seems a bit outdated as only older processor families are included.

       

      Question: How can I find AMD processors with NPT/RVI?

       

      Cheers

        • Re: Finding AMD processors with NPT/RVI virtualization support?

          Hello rujan,

           

          http://www.cpu-world.com/CPUs/Bulldozer/AMD-A10-Series%20A8-7600.html

           

          One might find information of AMD A8-7600 from the above link. This processor does definitely support NPT/RVI without doubt. AMD introduced Nested Paging with AMD 10h processors. Since then, all AMD processors support this technology if Virtualisation feature is provided.

           

          If you are using Windows 8 and later, you can simply issue command msinfo32 under Command Prompt, then you would find whether your processor support Hyper-V Second Level Address Translation Extensions.

           

          Best Regards,

          Aaron Janagewen

          1 of 1 people found this helpful
          • Re: Finding AMD processors with NPT/RVI virtualization support?
            rujan

            Thanks janagewen,

             

            That's a nice website you shared, just what I was looking for...

             

            Good to know my processor has NPT. When I initially ran the # less /proc/cpuinfo command, no NPT flag showed up. So I though my processor doesn't have it. But I ran the command in a hypervisor. When I rebooted to a normal Linux OS and ran #grep -wo npt /proc/cpuinfo there, NPT was flagged. Happy days. I guess there is an issue with not seeing the NPT flag in a hypervisor, is all.. Lessons leaned!

             

            Cheers