7 Replies Latest reply on Jan 26, 2018 2:32 PM by kengaru

    How I fixed crashes on my R9 290

    kyrillik

      My card is ASUS R9 290 DirectCU II OC (R9290-DC2OC-4GD5). It was working perfectly for the first year while I was using Catalyst drivers, but once I installed Crimson, I immediately started to get BSODs (thread stuck in device driver, atikmdag.sys). Those crashes happen both in Windows 7 and Windows 10, but only in 2D (browsing, working with files), randomly. NEVER in games, even the most demanding ones! But, once I exit the game to the desktop, I immediately get a crash. So it was obvious there were no problems with the hardware itself, but something wrong with the new drivers.

       

      Once I reverted back to Catalyst, BSODs disappeared completely, so I was using those old drivers for the last 9 months. However they are outdated now and some games (like Battlefield 1 beta for example) refuse to start or have performance issues. So I had to find a solution, since AMD refuses to provide one (and there are loads of people having the same issues, judging from the forums).

       

      The first thing I’ve tried is visiting the ASUS web site for an updated BIOS. However the latest BIOS version is dated June 2014 and it was already installed (way to screw over your customers, ASUS!)

       

      Then I tried raising the 2D voltage with Afterburner. I had really high hopes for this, but surprisingly it didn’t help me at all – still BSODs.

       

      Then I found out about the hilariously named app “ClockBlocker”. If you install it and set the DEFAULT rule to “Block” you essentially remove the 2D mode completely. The card raises the clocks, voltages and power limits to the maximum, even if no game is running. The crashes disappeared completely. However, this solution has obvious drawbacks – the card is running at full speed 100% of the time, so this means more heat, more noise, more power consumption and additional wear and tear. So I’ve decided to search for another solution.

       

      And this solution is custom BIOS, since ASUS and AMD refuse to do their job (warning: flashing the wrong BIOS void the warranty and can brick your card, so stick to ClockBlocker unless you know what you’re doing). I’ve found a couple of custom BIOSes, flashed them, but they had no effect, I still got the same “thread stuck in device driver” BSODs. So I decided to make my own custom BIOS. I’ve backed up the existing BIOS, downloaded the program called “Hawaii BIOS Reader”, loaded my BIOS and started editing (don’t forget to save a second original copy, you will need it). First I’ve tried to change the 2D voltage, but apparently I did something wrong and this BIOS caused an immediate crash at Windows startup. So I reflashed a backup copy and returned to editing. This time I’ve tried raising the 2D video processor speed (the parameter is called “GPU Clock 3”) from default 300 to 450, and to my surprise, once again, the crashes disappeared. Actually, I still don’t quite understand why this helped (maybe raising the GPU clock also raised some other 2D parameters), but the system is rock solid for a week now.

       

      This whole debacle left me VERY disappointed with AMD and ASUS. ASUS is just trash, quite simply. The card is still very capable, for example I play SW:Battlefront with all settings but AA set to Ultra at 2560x1080, and they stopped supporting it two years ago?? No more ASUS for me EVER, thank you very much. But AMD is just as guilty here. If ASUS doesn’t care if their cards are buggy, why not step up and release the BIOS yourselves?  Don’t you care that your reputation is destroyed here? The forums are FILLED with similar complaints, and that includes Sapphire and Gigabyte cards as well. OR, if BIOS option is not available, why not providing an alternative solution in drivers? Catalyst was very stable, so there’s gotta be a way to add a toggle in Crimson GUI to get a stable system even with old outdated BIOS. To be quite honest, the only reason why I still even consider buying AMD is my Freesync monitor. Otherwise I'd migrate to nVidia in a heartbeat.

        • Re: How I fixed crashes on my R9 290
          tag75

          just asking mate have you download your drivers from asus website them self and not amd website some times that helps .

          • Re: How I fixed crashes on my R9 290
            jigzaw

            Very interested in what you did with clock for 2D video processor, since it may improve CAD performance. One thing why stuck with AMD gpus is that it allows me to run my legacy Illustrator 9.0. It won't run on any nvidia solutions past GT200. In my MSI FX720 notebook which has GT520M/intel3000, I have to set Illustrator 9 to run only with the intel graphics to make it work. I am using currently a Sapphire Nitro R7 370 4GDR5 which experienced not issue with 16.9.1. My son's PC which is using my previous gpu Sapphire R7 260X 2GDR5 won't work with 16.8.2.

              • Re: How I fixed crashes on my R9 290
                kyrillik

                You should definitely try ClockBlocker. You can create a "block" rule for a particular program, setting the clock to the max only when the CAD program is running, leaving the system cool and quiet during normal usage. Just check the stats with GPU-Z to make sure rule is applied.

                 

                ClockBlocker was created to block the power saving system of newer Radeons (yet another AMD screwup). Some people have performance issues even when running games, since those Radeons think it's a good time to start saving power.

              • Re: How I fixed crashes on my R9 290
                luchilucs

                I have the same problem with a ASUS/AMD gpu: R7260X. The gpu is running well in 3d mode but when doing random stuff and the gpu switch from 2d/3d sometimes it randomly frooze completly my pc. The only workaround for me, since two years, was asus gpu tweak and run the card at 3d clock always. Can't find any program to change the 2d clocks... Never tried to flash a new bios: too scared.
                Many people has this problem... with many different cards... ASUS and AMD never did anything about it...

                • Re: How I fixed crashes on my R9 290
                  kengaru

                  Have that problem with Gigabyte GV-R736OC-2GD with F3 BIOS.

                   

                  Did you changed both GPU Clock 3 and GPU Freq Table values or GPU Clock 3 only?