AnsweredAssumed Answered

Trouble installing an rx 480 in a Dell XPS 420

Question asked by bshagopian on Sep 21, 2016
Latest reply on May 11, 2017 by muhupy

I'm at my wits end and hope posting my problem will find a solution. I've recently purchased a new XFX Radeon RX 480 8gb Graphics card and have nothing but problems trying to get my Dell XPS 420 to recognize it. I keep getting the infamous "Windows has stopped this device because it has reported problems. (Code 43)" error. So, its day three, its 11:00 pm, I'm two days away from throwing in the towel and returning the card (which I would hate to do) so please HELP! I've installed it into the only PCIe x16 slot on the computer, which is a 2.0, but I know the RX 480 can step down from 3.0 to 2.0. Here are my system specs.

 

Dell XPS 420

Intel Core2 Duo CPU E8500 @ 3.16GHz

4 GB RAM

Windows 10 @ 64 BIT

450W Dell PSU

250GB SanDisk SSD HD

 

And to help speed things along I tell you what I've already done to date.

1) Completely uninstalled the old drivers with DDU, restarted, updated the BIOS (A07 from dell), restarted, updated Windows 10, restarted, ran SFC and DISM (as per Troubleshooting Common AMD Graphics Driver Installation Problems), disabled my Norton anti-virus and firewall, downloaded the latest drivers (crimson 16.9.1 Sep 13), did a clean install of the drivers, restarted, and still no luck.

2) Rinse and repeat the above steps, but also made sure that the BIOS were reading the PCIe slot (FYI I have no integrated video on the MOBO). Still no joy.

3) I've also tried unplugging the computer from the wall, pushing the power button, and discharging the capacitors to hopefully wipe any old settings...did not work.

 

I've made sure that I've installed the 6 pin power supply (six different ways from Sunday, even went so far as using a secondary power supply unit to ensure it was getting enough power). Windows can see and detect the display adapter in my device manager, it shows it as "Radeon (TM) RX 480 Graphics", so I know it can see it. Heck, I know its using the default display pass-though on it in order for me to even use the monitor that's plugged into it. I've heard conflicting reports on the RX 480 only being compatible with UEFI/EFI and not legacy BIOS and other reports that it can work with legacy, so I'm not sure if that's the issue. I'm almost positive that this is a software, or deeper hardware issue and hope someone has an answer.

Outcomes