17 Replies Latest reply on Apr 13, 2018 8:07 AM by stbrandon

    RX 480 4k@60hz via HDMI issue

    jtdoan

      Hi all,

      I have an issue with my brand new ASUS RX 480 DUAL 4GB. I have 1 LG ultrawide monitor and 1 4k tv both hooked up to my PC. I have no issue with the ultrawide monitor. But when I change the TV refresh rate to 60hz, the TV screen just go on and off repeatedly. Lowering the refresh rate down to 50 or 30 and the issue gone. Don't know whether this is a driver problem or a hardware problem. Hope someone can help me out.

       

      Monitor: LG 29UM68-P

      TV: Sceptre U500CV-UMK

       

      PC specs

      CPU: FX 8350

      RAM: 8 GB

      MOBO: Asus M5A97 R2

      PSU: Evga 500w

      GRAPHIC: Asus RX 480 DUAL 4GB

        • Re: RX 480 4k@60hz via HDMI issue
          amdpete

          I would try a new HDMI 2.0 cable first of all and connect it to HDMI port 1 of the TV.

          • Re: RX 480 4k@60hz via HDMI issue
            dnev

            I am having the exact same issue with my Sceptre 50" 4k UHD TV/Monitor. The TV supports 4k @60hz using HDMI 2.0, and I've tried 3 cables. I can get it at 50hz, but not 59hz or 60hz. 60hz works properly at lower resolutions, but anything in the 4k range only works up to 50hz. When I set it to 59 or 60, the TV displays the image for around 3-5 seconds, then off (looks like it's just changing resolution, not actually turning off). This continues until I set the refresh rate back to 50 or below.

             

            I've updated to the latest drivers with no success. Sceptre seems to think it's an issue with their TV, and recommended I send it back to them, but that's going to cost me a fortune, and I think they're wrong to be honest.

             

            Any help would be great! I got this card with the hopes of running at 4k 60hz. Exact model of the TV is the U508CV-UMK

             

            Thanks!

            • Re: RX 480 4k@60hz via HDMI issue
              daniilzol

              Exact same issue here too. I have MSI RX 480 Gaming X 8GB card that's driving two LG 27UD68-P 4K 60Hz Freesync monitors. When using displayport windows moves all of my open applications onto primary monitor coming out of sleep, and when I use HDMI at 4K 60Hz I get monitor black-outs every so often. The number of blackouts is really random, when it's good I only get one every hour, when it's bad I get blackout screens every 5-10 seconds. Each blackout only lasts couple of seconds, but it is really annoying and frustrating.

               

              I have installed drivers for my monitors, I have tried different HDMI cables, I have switched video output from YCbCr 4:4:4 to RGB 4:4:4, I have updated my video graphics to the latest version, nothing helps. I just can't get stable 4K 60Hz image over HDMI interface.

               

              Any help would be highly appreciated, this issue is so aggravating I'm contemplating returning the whole setup, monitors and video card...

              • Re: RX 480 4k@60hz via HDMI issue
                bbrownlow

                Dont think this is limited to HDMI, having the same issue over Display port, even bought new cables to make sure. I have dual AOC U2879VF 28" 4K Freesync monitors running on the XFX RX 480 8GB (RX-480P8LDLR). 1920x1080 and 2560x1440 at 60Hz+ but moment I move to 4k resolutions it blacksout, the displays let me know that they've lost signal.

                2 of 2 people found this helpful
                • Re: RX 480 4k@60hz via HDMI issue
                  fehlermann

                  I have the same issue with a Sapphire Radeon Nitro RX 480 and an iiyama ProLite X4071UHSU-B1 (which has DP 1.2 as well as HDMI 2.0).

                  Radeon Software Version is 16.12.1 at the moment.

                   

                  When running 3840x2160 at 60Hz the image occasionally is "lost" for up to a second.

                  This also affects the sound (my monitor has integrated speakers via hdmi/dp) - it either "cracks" or stops for <1 second at the same time as the image fails.

                  This happens every few minutes (didn't measure the intervals yet), sometimes just a short "flicker" on the lower part of the screen, sometimes it turns completely black for a second.

                   

                  I have tried to connect the monitor via HDMI as well as via DisplayPort:

                  The issue does occur in both cases while using 60Hz.

                   

                  If I use the HDMI port and configure it to be using version 1.4 rather than 2.0 (I can do that via on-screen-menu on the iiyama) the image becomes stable, the sound is stable and I have no issues other than the poor 30Hz refresh rate.

                  The same happens if I use DP and set it to use version 1.1 rather than 1.2: Everything is fine, but only 30 Hz.

                   

                  My second display (an old SyncMaster 275T, connected via DVI as that's the only digital input it has) does not show any issues at the same time.

                  It does not make any difference if I am running a 3d application or not.

                  Playing back a movie does also not make any difference.

                  It does not make any difference which display is set as the "main display"

                   

                  Update:

                  I have tested the X4071UHSU with the on-board "Intel HD Graphics 530" (of an Asus Z170-A with an i7-6700K) with driver version 21.20.16.4508 to see if the issue maybe is the monitor or the cables:

                  The Intel HD 530 works fine via DisplayPort 2.0 with 3840x2160 at 60Hz (image is stable over hours, no flickering, etc).

                  HDMI is only supported up to v1.4 by the HD 530, so I can't test that with more than 30Hz.

                  If it is of any relevance: The OS is Windows 7 Professional (in all cases, as it's the same PC after all..)

                   

                  => So basically I can say that DP 1.2 with the RX480 has issues with 4k @ 60Hz while the exact same display (and cables) work completely fine on my onboard Intel HD 530 with 4k @ 60 Hz.

                   

                  I'm looking forward for a solution to this being published.

                    • Re: RX 480 4k@60hz via HDMI issue
                      veahavarde

                      I have a reference Sapphire RX 480 8GB, and have issues running 4K 60hz as well. Im using the same driver as you too.

                       

                      Im using a Phillips BDM4065 40' 4K display. Using my buddies GTX 1070, it ran 4k 60hz flawlessly, using the same Displayport 1.2 capable cable.

                       

                      I think I'll return it.

                      • Re: RX 480 4k@60hz via HDMI issue
                        fehlermann

                        A brief update from me:

                        After upgrading to 17.1.1 the issue seems to have disappeared (or at least gotten a lot better).

                        Currently I am using DisplayPort 1.2 for the X4071UHSU (4k@60Hz) => I did not observe any issues yet.

                         

                        I have not tested this in detail (busy with work right now), but I will try to test HDMI at a later time as well and post another update here.

                        Also I have seen that 17.1.2 got released - have not installed that version yet.

                          • Re: RX 480 4k@60hz via HDMI issue
                            ebpepper

                            Just updated my driver and I'm still having this issue on my 4k TV.  At 60hz the TV flickers constantly but at 50hz its fine.  There isn't a display port on the 4k TV either and it's connected with a brand new HDMI cable.

                              • Re: RX 480 4k@60hz via HDMI issue
                                fehlermann

                                Another update from me (maybe this is of help for you as well):

                                 

                                17.1.1 has been working flawless over the past weeks with 3840x2160 @ 60Hz via DisplayPort 1.2 with my X4071UHSU.

                                 

                                So I have changed to HDMI 2.0 now:

                                17.1.1 was horrid with HDMI 2.0: The picture didn't last longer than 60s, in addition to the screen going black briefly every ~30 seconds every other time there was also just full screen "noise" (every pixel has a random color) for a second.

                                17.2.1 (just updated ~1 hour ago) seems to fine (or at least a lot better than 17.1.1) with HDMI 2.0: I did not observe any issues in the past hour. I will try to post another update in a few days.

                            • Re: RX 480 4k@60hz via HDMI issue
                              jryoung

                              I have a similar / same issue with the same iiyama monitor - originally on my Thinkpad, using HDMI, I got the screen blanking, etc. Using a DP cable on 1.4 I can drive 4k 60hz with the intel graphics. My new homebuilt pc with a Radeon RX560 can also drive 4k 60hz with DP, but only 30hz with HDMI. Screen does seem stable though - using new cables. The difference is I am using linux, open source drivers.

                            • Re: RX 480 4k@60hz via HDMI issue
                              rzii

                              I just purchased a LG 27UD68 4k monitor. It theoretically supports HDMI 2.0 - 4K@60hz. I also have a RX 480 card and am using 17.2.1 drivers, and Win 10 on an Alienware Aurora R4 (circa few years back now). It still has the stock 875W power supply.

                               

                              My observations:

                              Problem 1 -

                              Over HDMI, 30 Hz is the highest frequency possible to select. (UHD Deep Color is ON, but also tried OFF)

                              Edit: This problem was fixed by entering the monitor menu and changing the "Ratio" to Original or 1:1. It came from the factory set to "Wide".

                               

                              Problem 2 -

                              I have the same screen blanking issue, and it happens over both HDMI and DisplayPort. I get it more frequently when playing games at higher resolutions and higher frequencies. When the fans are audible I can expect blackouts. I only have one game, and it is pretty old and not very graphically intensive (Diablo III).

                              On DisplayPort the results were the same regardless of whether FreeSync was on or off.

                               

                              I did not see the "full screen noise" as mentioned above, except for maybe one split second once, and only as part of the screen as some tearing of the image already there.

                               

                              Problem 3-

                              After determining that d3 was unplayable at 4k without blackouts every 2-20 seconds (maybe after a couple of minutes of uninterrupted warm-up), I tried changing the in-game resolution down to 2k, and got similar but less frequent black outs. I changed it to 1920x1080, and then it worked for hours without a problem, until a different kind of blackout happened. Not only did it blackout, but all fan noise from the card stopped at the same time.

                               

                              I had previously used this card to drive a 1920x1200 display over DisplayPort, and had done so without any incident for the month that I've had it.

                               

                               

                              I now suspect hardware/cooling failure because every time the GPU temp hits 73C it blanks out. My hypothesis is that when I ran it at the highest resolutions, the heat degraded the contact between the heatsink and gpu. Now it not reliable even at lower resolutions. This card is going back to the store because I have no interest in watercooling or even re-seating the heatsink. My card was manufactured by XFX. Buyer beware.

                                • Re: RX 480 4k@60hz via HDMI issue
                                  jeztur2003

                                  download msi afterburner sounds like your gpu is overheating in afterburner set up a custom fan profile or run them at 100% then try to play at 4k for awhile and see if it still does it. Once it gets to hot your gpu crashes the driver to prevent you from damaging your card hence the black screen.

                                • Re: RX 480 4k@60hz via HDMI issue
                                  dariocop

                                  Hello! I'm very intrested in your story, i want to share mine and give/have some help.

                                   

                                  I had recently buy an XFX RX480 for a 1080p panel and i was very happy for my purchase, cause finally i could play Ds3, the witcher 3 and other similar-specs games maxed out without any problem. This week i had an occasion on a 4k monitor "Samsung U28E590D" which is a 4k @60hz panel with one Displayport and two HDMI 2.0.

                                   

                                  The problem i'm experiencing is exactly the same that is described in this post (even the card is the same). I had no luck formatting, switching the PCI-E slot, plugging and unplugging the cables, using HDMI 2.0, displayport 1.2, buying a new cable. The only thing i can do to play a game in 4k is to switch to 30hz (pure garbage compared to the 60hz) or to lower my resolution @1080p. 1440p is giving me problems too but 4k is completely unplayable. Sometimes the image flickers and the input signal is lost even on the desktop while i watch a video in Windows media player (desktop @4k).

                                   

                                  Is this a problem related to a defective VGA or a driver issue? I would test a new panel but i'm a bit doubtful.

                                   

                                   

                                  EDIT: i'd notice that the problem goes away if i set "Power limit" to -20% using MSI afterburner. This cause the framerate to drop dramatically from 40 to 15fps in the witcher 3. The game is unplayable.

                                   

                                  So is it a faulty card or my psu?

                                   

                                  Here are the details

                                   

                                  CPU: intel i7 6700k

                                  2x8gb G-skill ddr4 3200mhz

                                  Enermax NaxN 500w

                                  MSI Z-170A pro

                                  SSD 850evo (250g)

                                   

                                  Can it be my psu? i'm really confused about this issue, and i want to be sure before buying something new or even request an RMA.

                                  • Re: RX 480 4k@60hz via HDMI issue
                                    stbrandon

                                    Hi all,

                                     

                                    I haven't seen if this was resolved at all, but I'm having the exact same issue.

                                     

                                    I have an RX 480 running via HDMI to my TCL P-series 4K TV.  I have no problems if I run at 1080P, but whenever I run it at 4K, 60hz I have issues.

                                     

                                    I tested it again last night while mucking around in World of Warcraft, Archeage and Divinity: Original Sin 2.  I had set the resolution via my desktop to be at 4K, 60hz and the same as in-game and everything seemed to be working fine. 

                                     

                                    After some time (maybe an hour or so) I'd start getting the familiar "flickering".  If left alone, it will continue getting worse during the session and may eventually completely go to a static screen. 

                                     

                                    Has there been found to be any resolution for this?  Or is the RX 480 just incompatible with 4K gaming?